Spooler SubSytem App has stopped working (windows vista)



I have tried just about everything that i know to fix this problem. Yet I
still cannot print to my network printer. I had been able to previously.
Here are the problem details:
Problem signature:
Problem Event Name: APPCRASH
Application Name: spoolsv.exe
Application Version: 6.0.6000.16386
Application Timestamp: 4549b734
Fault Module Name: StackHash_b96e
Fault Module Version: 6.0.6000.16386
Fault Module Timestamp: 4549bdc9
Exception Code: c0000374
Exception Offset: 000af1c9
OS Version: 6.0.6000.
Locale ID: 1033
Additional Information 1: b96e
Additional Information 2: 438eb0dac54b4c5ef53871db589f1f53
Additional Information 3: 652b
Additional Information 4: 77f0f489268055e2de68a0741a77f15b

Read our privacy statement:

If you have any ideas to fix this problem it would be greatly appreciated.


I too have this problem, it seems to started back in March when I tried to
install the VISTA drivers my DELL 920 and 922 all in one printers.

I have removed them and also run the DELL cleanup utility but the spooler
dies occasionally. I have run Windows defender full check and full virus
scan, all come up clean.

Today I installed a new Canon ip2500 printer which is working fine so far
although I did have to restart the spooler 3 times during the installation.


Peter West UK



I have 3 printers that I assume are virtual.
ADOBE PDF, Family Tree Maker Printer and Microsoft XPS Document writer. Is
one of these the problem and how do I resolve the problem?


Cari \(MS-MVP\)

Check for updates for Acrobat with Adobe, if none of them, uninstall Acrobat
and reinstall. Same with Family Tree Maker Printer. If you don't use the
XPS Document writer, disable (or delete) it. Keep trying until you find the
'bad' printer.



I removed the 3 virtual printers yesterday, however the Family Tree Maker
Printer reappeared once I started the application. A few instances of
spooler failure but most of the time was OK and I was able to use my new
canon ip2500 printer that I installed on Tuesday. NB The spooler issues go
back to March and that is when I tried to install the new Dell Vista
drivers. There are references to the Dell printers in the registry and Vista
tries to start a Dell program (dlbkmgr.exe) from a folder in program files
which no longer exists. I found this after running HiJackThis.

This morning (Friday) I had continual spooler fails, I had to regularly
restart the spooler manually using Services. The FTM printer was there still
but sometime the printer folder was empty and info only re-appeared when I
restarted the spooler which then died. Unable to delete the FTM printer as
it requires spooler to be running to do it, catch-22.

I shut the machine down as I was going out and when I started it again 2
hours later so far no spooler errors! I have deleted the FTM printer and
this worked, I now have just 2 printers showing the canon and an HP DeskJet
840C/841C/842C/843C which is at my house in France so is not connected.

I would also add that on some occasions over the 2 weeks my PC has not
started correctly, it stops after logging on requiring a reboot and safe
mode option. Most cases I opted for full start except that last week it
would not start at all and I had to do a system restore which seems to have
solved this problem.

Any ideas please, sorry to be a trial.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question