Spell Check Works Sporadically in Outlook 2007 E-mail


C

Colin

Sometimes, paragraphs seem to be hidden from the Word spell check.
Misspelled words are not underlined. If I hit the Spell Check button, it
finds no errors. I can type word after word of gibberish and it reports
everything is fine.

In the most recent such message, it seemed to be tied to a numbered list.
Every misspelled word in the list it ignored. Everything outside the list it
correctly flagged as misspelled. But if I cope the text out of the numbered
list, it remains immune to the spell check, even if the words are copied out
and pasted elsewhere in the document. It's as if every bit of garbage I type
in the numbered list is being flagged as "Ignore" during the spell check.

This also seems more likely to happen during a Reply than in a new
composition. The only work-around I've found is to copy the text, close the
reply, re-click reply on the original message, then Paste Special,
Unformatted Text. That seems to reset the spell checker for that block of
text.

Any suggestions? Is this a known issue? Is there any way to un-ignore words?
I haven't seen any other posts about this, but seems like an obvious bug.

Thanks,
Colin
 
Ad

Advertisements

D

Diane Poremsky [MVP]

if you right click on the misspelled words, what menu do you see? if it's
the signature menu, you are typing in the signature field. If the normal
context menu, the list style may have spelling disabled on it. Copy and
paste includes the style so no spell check. (paste into notepad then copy
and paste into the email to clear the style)

--
Diane Poremsky [MVP - Outlook]
Need Help with Common Tasks? http://www.outlook-tips.net/beginner/
Outlook 2007: http://www.slipstick.com/outlook/ol2007/



Exchange Messaging Outlook newsletter:
(e-mail address removed)




You can access this newsgroup by visiting
http://www.microsoft.com/office/community/en-us/default.mspx or point your
newsreader to msnews.microsoft.com.
 
C

Colin

It's the normal list context menu.

Why would lists occasionally have spelling disabled? How can I check this
for a given list? Usually I don't have this problem. It occurs about 10% of
the time and seems to happen in replies with HTML active. I'm not sure it's
always in a list, but it may be. It certainly was this time.

I thought styles like that would be carried in the final paragraph marker at
the end of the paragraph. I can copy the individual text (just a few words)
from the middle of the paragraph, and the problem follows them. It is cured
whenever it's coverted back to plain text (such as pasting and recopying
through Notepad as you suggest or just doing a Paste Special | Unformatted
text).

- Colin

Diane Poremsky said:
if you right click on the misspelled words, what menu do you see? if it's
the signature menu, you are typing in the signature field. If the normal
context menu, the list style may have spelling disabled on it. Copy and
paste includes the style so no spell check. (paste into notepad then copy
and paste into the email to clear the style)

--
Diane Poremsky [MVP - Outlook]
Need Help with Common Tasks? http://www.outlook-tips.net/beginner/
Outlook 2007: http://www.slipstick.com/outlook/ol2007/



Exchange Messaging Outlook newsletter:
(e-mail address removed)




You can access this newsgroup by visiting
http://www.microsoft.com/office/community/en-us/default.mspx or point your
newsreader to msnews.microsoft.com.


Colin said:
Sometimes, paragraphs seem to be hidden from the Word spell check.
Misspelled words are not underlined. If I hit the Spell Check button, it
finds no errors. I can type word after word of gibberish and it reports
everything is fine.

In the most recent such message, it seemed to be tied to a numbered list.
Every misspelled word in the list it ignored. Everything outside the list
it correctly flagged as misspelled. But if I cope the text out of the
numbered list, it remains immune to the spell check, even if the words
are copied out and pasted elsewhere in the document. It's as if every bit
of garbage I type in the numbered list is being flagged as "Ignore"
during the spell check.

This also seems more likely to happen during a Reply than in a new
composition. The only work-around I've found is to copy the text, close
the reply, re-click reply on the original message, then Paste Special,
Unformatted Text. That seems to reset the spell checker for that block of
text.

Any suggestions? Is this a known issue? Is there any way to un-ignore
words? I haven't seen any other posts about this, but seems like an
obvious bug.

Thanks,
Colin
 
D

Diane Poremsky [MVP]

You'd need to look at the source. I'm guessing the sender either disabled it
in his version (if using outlook) or the message uses the same style name as
one outlook uses that has spell checking disabled.

--
Diane Poremsky [MVP - Outlook]
Need Help with Common Tasks? http://www.outlook-tips.net/beginner/
Outlook 2007: http://www.slipstick.com/outlook/ol2007/



Exchange Messaging Outlook newsletter:
(e-mail address removed)




You can access this newsgroup by visiting
http://www.microsoft.com/office/community/en-us/default.mspx or point your
newsreader to msnews.microsoft.com.


Colin said:
It's the normal list context menu.

Why would lists occasionally have spelling disabled? How can I check this
for a given list? Usually I don't have this problem. It occurs about 10%
of the time and seems to happen in replies with HTML active. I'm not sure
it's always in a list, but it may be. It certainly was this time.

I thought styles like that would be carried in the final paragraph marker
at the end of the paragraph. I can copy the individual text (just a few
words) from the middle of the paragraph, and the problem follows them. It
is cured whenever it's coverted back to plain text (such as pasting and
recopying through Notepad as you suggest or just doing a Paste Special |
Unformatted text).

- Colin

Diane Poremsky said:
if you right click on the misspelled words, what menu do you see? if
it's the signature menu, you are typing in the signature field. If the
normal context menu, the list style may have spelling disabled on it.
Copy and paste includes the style so no spell check. (paste into notepad
then copy and paste into the email to clear the style)

--
Diane Poremsky [MVP - Outlook]
Need Help with Common Tasks? http://www.outlook-tips.net/beginner/
Outlook 2007: http://www.slipstick.com/outlook/ol2007/



Exchange Messaging Outlook newsletter:
(e-mail address removed)




You can access this newsgroup by visiting
http://www.microsoft.com/office/community/en-us/default.mspx or point
your
newsreader to msnews.microsoft.com.


Colin said:
Sometimes, paragraphs seem to be hidden from the Word spell check.
Misspelled words are not underlined. If I hit the Spell Check button, it
finds no errors. I can type word after word of gibberish and it reports
everything is fine.

In the most recent such message, it seemed to be tied to a numbered
list. Every misspelled word in the list it ignored. Everything outside
the list it correctly flagged as misspelled. But if I cope the text out
of the numbered list, it remains immune to the spell check, even if the
words are copied out and pasted elsewhere in the document. It's as if
every bit of garbage I type in the numbered list is being flagged as
"Ignore" during the spell check.

This also seems more likely to happen during a Reply than in a new
composition. The only work-around I've found is to copy the text, close
the reply, re-click reply on the original message, then Paste Special,
Unformatted Text. That seems to reset the spell checker for that block
of text.

Any suggestions? Is this a known issue? Is there any way to un-ignore
words? I haven't seen any other posts about this, but seems like an
obvious bug.

Thanks,
Colin
 
Ad

Advertisements

S

szymon nadolski

Hi, I have very similar problem. Outlook 2007 in HTML or Rich Text mode does not seem to do the spell check. When I switch it to plain text it works ok. Also when I switch it back to HTML, it works fine now.
Right clicking on the text brings up regular menu (not the signature one).
Any suggestions? (before I try reinstalling it). ;)

p.s. other forums advise changing Registry, but that did not work for me.
Sometimes, paragraphs seem to be hidden from the Word spell check.
Misspelled words are not underlined. If I hit the Spell Check button, it
finds no errors. I can type word after word of gibberish and it reports
everything is fine.

In the most recent such message, it seemed to be tied to a numbered list.
Every misspelled word in the list it ignored. Everything outside the list it
correctly flagged as misspelled. But if I cope the text out of the numbered
list, it remains immune to the spell check, even if the words are copied out
and pasted elsewhere in the document. It's as if every bit of garbage I type
in the numbered list is being flagged as "Ignore" during the spell check.

This also seems more likely to happen during a Reply than in a new
composition. The only work-around I've found is to copy the text, close the
reply, re-click reply on the original message, then Paste Special,
Unformatted Text. That seems to reset the spell checker for that block of
text.

Any suggestions? Is this a known issue? Is there any way to un-ignore words?
I haven't seen any other posts about this, but seems like an obvious bug.

Thanks,
Colin
On Monday, February 16, 2009 5:56 PM Diane Poremsky [MVP] wrote:
if you right click on the misspelled words, what menu do you see? if it's
the signature menu, you are typing in the signature field. If the normal
context menu, the list style may have spelling disabled on it. Copy and
paste includes the style so no spell check. (paste into notepad then copy
and paste into the email to clear the style)

--
Diane Poremsky [MVP - Outlook]
Need Help with Common Tasks? http://www.outlook-tips.net/beginner/
Outlook 2007: http://www.slipstick.com/outlook/ol2007/



Exchange Messaging Outlook newsletter:
(e-mail address removed)




You can access this newsgroup by visiting
http://www.microsoft.com/office/community/en-us/default.mspx or point your
newsreader to msnews.microsoft.com.


news:[email protected]
On Tuesday, February 17, 2009 2:39 PM Diane Poremsky [MVP] wrote:
You'd need to look at the source. I'm guessing the sender either disabled it
in his version (if using outlook) or the message uses the same style name as
one outlook uses that has spell checking disabled.

--
Diane Poremsky [MVP - Outlook]
Need Help with Common Tasks? http://www.outlook-tips.net/beginner/
Outlook 2007: http://www.slipstick.com/outlook/ol2007/



Exchange Messaging Outlook newsletter:
(e-mail address removed)




You can access this newsgroup by visiting
http://www.microsoft.com/office/community/en-us/default.mspx or point your
newsreader to msnews.microsoft.com.


news:[email protected]
Submitted via EggHeadCafe - Software Developer Portal of Choice
Book Review: Excel 2010 - The Missing Manual [OReilly]
http://www.eggheadcafe.com/tutorial...w-excel-2010--the-missing-manual-oreilly.aspx
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top