RTF documents in Word 2007


J

Janie

I create an RTF document in my genealogy program. When I open it in Word
2007, it is a mess. The original document is in Ariel font and when I open
the RTF in Word, half the pages have some random font instead and half have
the Ariel font, and there are many blank pages throughout the document.

When I open the same RTF in Works, the margins are completely distorted and
when I try to open it in Wordpad, it's a page of symbols.

I thought I should be able to open an RTF document in Word 2007.

Any help, please!
Janie
 
Ad

Advertisements

G

Graham Mayor

You can and have opened the RTF in Word, however Word will only respond to
what is actually contained in the file. The first thing to check is what
page size your genealogy outputs. My guess is that it is larger than the
default page size Word uses.

--
<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
Graham Mayor - Word MVP

My web site www.gmayor.com

<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
 
J

Janie

Thanks, Graham.

The output is standard portrait with margins, Top/Bottom 0.5 and Left/Right
1.0.

The font for the body of the report in the original is Ariel, size 10. I
did a test report of 9 pages.

When I open in Word 2007...it is now 11 pages.
Page 1 - changes the font to PMingLiU, size 9.5
Page 2 - blank
Page 3 - still in the PMingLiU, size 9.5 font
Page 4 - is blank except for last line of previous page
Pages 5 through 11 - font is correct - Ariel, but size has changed to 9.5

Any clues, anyone, as to why this is happening?

Thanks,
Janie
 
G

grammatim

As Graham said, first check the page size. (Letter, A4, Legal, A3,
etc.)

As for why you're getting a Chinese font, check the Set Language
property of the document.
 
J

Janie

Thank you. The page size is Letter, 8 1/2 x 11 in the original document and
the same setting in Word 2007.

Where do I find the "Set Language" in Word 2007. Sorry, I'm new at using
this version of Word.

Thanks,
Janie
 
J

Janie

Regarding the "Set language" - while the font is PMingLiU, all the words are
in English not another language. All the content is in English as it should
be. It is just the change in font and size and added blank pages that are
the problem.

I've tried clicking "Select All" and changing the font back to Arial, size
10, but that does not get rid of the blank pages and completely messes up the
format.

Frustrating!

Janie
 
Ad

Advertisements

G

grammatim

"Set Language" is on the Review tab, third column from the left.
Select the entire document (Ctrl-A) and then open Set Language -- if
US (or whatever) English isn't selected, then there are at least two
languages registered in the document, so pick the variety of English
that you need.

(The Chinese fonts have roman alphabets in them, so your text still
appears in English.)
 
P

Peter Jamieson

The thing about RTF is that
a. there have been a number of versions of the RTF standard.
b. Although RTF is in theory independent of Word, in practice each
version of RTF corresponds to a particular version of Word and the
features that it supports
c. When Word saves in RTF format, the result tends to be very complex,
reflecting the sort of material that /might be present/ in a Word
document (e.g. mixed scripts, perhaps left-to-right, right-to-left,
"east asian" etc.
d. When other programs save in RTF format they tend to use the most
basic facilities of RTF they can, typically using an older version of
the RTF standard than the current one.
e. If the RTF actually deviates from the standard, Word is highly
likely to display it badly. Even if it conforms to the RTF standard,
Word may not process it very well.

If your genealogy stuff isn't too private, or you have a small test tree
that you could export from, you are welcome to e-mail me your RTF and
I'll see if I can spot anything that might make it more usable. It might
be useful to know which software package you are using to generate it (I
have several lying around, but not the most recent versions of e.g. FTM).

If you want to do that, remove KillmapS from my e-address
(e-mail address removed) and email your RTF as an attachment.
(FWIW http://www.goodworth.org is one of my own genealogy efforts, in
need of some work though...)

Peter Jamieson

http://tips.pjmsn.me.uk
 
Ad

Advertisements

J

Janie

Thank you again.

I did another test document - selected the entire document, opened Set
Language.
English-United States was the selected option and the default language -
which is what I want.

It did not correct the problem. I still had the PMingLiU font on the second
page and a blank page in the document.

Back to the drawing board :)

Janie
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top