RIS Problem installing 3rd Party Unsigned Driver for Boot Device


G

Guest

Hello,

I am having problems with a RIS Installation. I've read everything I can
find on this and I can't seem to find an answer that fits my problem.

I have flat images created for Server 2003 AMD64 and 32-Bit Enterprise. I
create a master hdd with necessary drivers, etc. If I use an addon PCI FC HBA
and Install and boot to an external HDD, my RIS configuration works (the
driver for that controller is WHQL signed.)

However, if I configure the master hdd image for the on-board SAS/SATA (both
driver types work with same controller and driver) I get errors when
installing to a target with the same hardware config. Aside from the
controller brand and type difference (FC vs. SAS), the only other factor I
can see is that the driver is unsigned. We are currently waiting for our
supplier to finish qualification on the driver. In the meantime, I'm under
the gun to get this working so we can get some other testing done without
rebuilding the drives manually between activites.

RIPREP copies the image to the server. When I boot the target and select the
install image, the drive is formatted and partitioned (as I have configured
in the riprep.sif file.) The entire image is copied until the very end. I get
an error:

Setup cannot set permissions for device
\Harddisk0\Partition0\OemDir\<driver>.cat (this is the dummy catalog file,
then the oemscsi0.inf file, then the driver.inf, then the driver.sys. I press
ESC after each error message.

If I boot with the newly created drive installed, the Windows logo screen
comes up briefly, then the system just keeps rebooting. If I install the
drive as a second disk to examine it, all of the other files are there but,
these necessary files are not where they should be. The driver (which *is* in
the system32\drivers directory on the master and in the image on the server)
is missing from the \drivers directory on the target. No files are copied to
the OemDir, etc. I have the policy set to ignore. Is this strictly because
the driver is unsigned?

Anyone else run into this problem?
 
Ad

Advertisements

Z

Zac.O.Matic

My workaround has been to set up WinPE on the RIS server so we can boot
into it from the network. It took a while to figure out how to
configure it with the same mass storage drivers as the RIPREP image I'm
trying to deploy. WinPE works a little bit different from RISetup
images.

Once booted into WinPE, I copy the mass storage drivers into the OemDir
and System32 directories. Then the imaged machine boots up normally.
Still not sure why this is happening with these particular files. I've
made other RIPREP images that worked fine.
 
Joined
Nov 2, 2006
Messages
1
Reaction score
0
I have had exactly the same problem, and my drivers are signed (*.cat file is one of the files that produces an error just like the *.sys file, *.inf, etc.)


Anyone come across a fix yet?
 
Joined
Nov 13, 2006
Messages
1
Reaction score
0
RIPREP setup problem with RAID controller driver

I face the same problem too... With a Promise raid controller.
It's start to load the driver in TEXTMODE, copy files to disk but failed at the end of text part of setup. I don't understand why it can't find driver files to continue ...
Any progress on this .... a kind of solution other than Winpe.
Gm'
 
Ad

Advertisements

Joined
Jun 15, 2006
Messages
3
Reaction score
0
New Solution found

Hello,

After 3 days of struggelinjg with the same problem, a accidently found a solution...

Don't press "ESC" when the first error message appears, just power off your machine and it will boot :)

I fell on this solution when I was testing an install for the 100th time but this time, I detached the keyboard to prepare another machine.

When the error came, I could't press "ESC", even after I attached the keyboard. So I just pulled out the plug and booted again and above all my expectations... It booted!!

No I only have to find a solution so he don't copy those Storage driver files (lsi_sas.inf, .cat, ...)

Good luck
Tom
 
Joined
Apr 19, 2007
Messages
1
Reaction score
0
Hello, i have exactly the same problem and your solution works fine. Thank you !
But it's a little bit dirty...
Somebody found something else ?
Thanks in advance
C-dric
 
Ad

Advertisements

Joined
Jun 15, 2006
Messages
3
Reaction score
0
Hello c-dric,


Yes, it's a bit dirty but it always works and causes no harm...
I have already installed over 30 machines this way and I haven't had a single problem.

Nice to know it works for somebody else too


regards
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top