Reverse lookup: PTR entries are not FQDN


T

Thomas Rooselaer

Hi all,

We are using MS DNS/DHCP on W2K3, (DNS not AD integrated yet) where
the DHCP server takes care of DDNS for all clients. Some applications
are using reverse lookups with the FQDN. For AD clients no prob, but
there's a big number of non-AD clients that get their PTR record
registered with just the hostname, not the FQDN.
So far, the only solution I've seen involve a client-side change. Is
there any server side action that can be undertaken to make the
clients use the connection-specific DNS suffix? Or to have the DHCP or
DNS server force the correct suffix to be added to the host name
before registering?

Thanks!
 
Ad

Advertisements

A

Ace Fekay [MVP]

In
Thomas Rooselaer said:
Hi all,

We are using MS DNS/DHCP on W2K3, (DNS not AD integrated yet) where
the DHCP server takes care of DDNS for all clients. Some applications
are using reverse lookups with the FQDN. For AD clients no prob, but
there's a big number of non-AD clients that get their PTR record
registered with just the hostname, not the FQDN.
So far, the only solution I've seen involve a client-side change. Is
there any server side action that can be undertaken to make the
clients use the connection-specific DNS suffix? Or to have the DHCP or
DNS server force the correct suffix to be added to the host name
before registering?

Thanks!


In DHCP, use Option 015 and supply the domain suffix. This may help (never
tested it with non-MS clients). I would probably also suggest to manually
set the suffixes on your non-MS clients, which is what I usually do for my
client machines.



--
Regards,
Ace

Please direct all replies to the newsgroup so all can benefit.
This posting is provided "AS-IS" with no warranties and confers no
rights.

Ace Fekay, MCSE 2000, MCSE+I, MCSA, MCT, MVP
Microsoft Windows MVP - Active Directory

HAM AND EGGS: A day's work for a chicken; A lifetime commitment for a
pig. --
=================================
 
Ad

Advertisements

T

Thomas Rooselaer

Ace Fekay said:
In


In DHCP, use Option 015 and supply the domain suffix. This may help (never
tested it with non-MS clients). I would probably also suggest to manually
set the suffixes on your non-MS clients, which is what I usually do for my
client machines.



--
Regards,
Ace

Please direct all replies to the newsgroup so all can benefit.
This posting is provided "AS-IS" with no warranties and confers no
rights.

Ace Fekay, MCSE 2000, MCSE+I, MCSA, MCT, MVP
Microsoft Windows MVP - Active Directory

HAM AND EGGS: A day's work for a chicken; A lifetime commitment for a
pig. --
=================================


Ace,

Thanks for your reply. When setting option 15, the domain name is set
in the connection-specific DNS suffix. However only when the options
"Use the connection-specific DNS suffix" is set on the client side,
the correct, FQDN will be registered... This option is not set on a
huge number of clients, nor is the correct DNS suffix defined on the
clients who are not on AD.
(All clients are MS clients, but there's a mix of NT and AD domains)
We estimate that 4 to 5000 clients do not get their FQDN registered,
so a client side change would obviously be very expensive...

Regards,

Thomas Rooselaer.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top