Replacing drive Raid 1


J

jawdoc

Hello
I need a little guidance.
Here is my setup. I have an IBM server with an integrated SATA
Adaptec Raid 1 controller on the MB.
I recently had a drive die in the array. Which according to the Array
utiliity was in the port 1 position.
I was getting the "no bootable drive/no OS" error. I removed the
drive from the port 1 position and put the drive from the port 0 in
the port 1 position and it booted great. I get an Array "degraded"
listed at boot though.
I purchased an replacement placed it back in the port 0 and was hoping
that it would automatically add this to the array but it did not. The
utility list it as a drive but list the second drive from the previous
array as missing.
There doesn't seem to be anyway to add this drive manually to the
array within the utility/setup.
I am assuming that I have to delete the array and recreate it with
both drives.
If this is the case will I get a prompt to select a source and target
drive when creating the new array?

Any help will be greatly appreciated!

Same capacity is listed for both drives in the utility.

Thanks in advance!
 
Ad

Advertisements

A

Arno Wagner

Previously jawdoc said:
Hello
I need a little guidance.
Here is my setup. I have an IBM server with an integrated SATA
Adaptec Raid 1 controller on the MB.
I recently had a drive die in the array. Which according to the Array
utiliity was in the port 1 position. ok

I was getting the "no bootable drive/no OS" error.

This does not sound like a dead drive, but rather like a dead array.
If only one drive in a 2 disk RAID1 dies, the system should still
work, with the only difference being warnings about the failed drive.
I removed the
drive from the port 1 position and put the drive from the port 0 in
the port 1 position and it booted great.

Ok, then this controller is trash. That should not happen. It should
still boot if either disk is fine. Given my own experiences with
adaptec, I think they removed everybody competent in their development
team decades ago. However your approach of movind the disk is sound.
I get an Array "degraded" listed at boot though.

As it should be.
I purchased an replacement placed it back in the port 0 and was hoping
that it would automatically add this to the array but it did not.

Well, automatic rebuild can lead to accidential deletion
of data so it typically is not done.
The
utility list it as a drive but list the second drive from the previous
array as missing.
Ok.

There doesn't seem to be anyway to add this drive manually to the
array within the utility/setup.

There should be.
I am assuming that I have to delete the array and recreate it with
both drives.

Definitely not.
If this is the case will I get a prompt to select a source and target
drive when creating the new array?

Recreation will typically wipe one drive and should never be done
as replacement for a rebuild!
Any help will be greatly appreciated!
Same capacity is listed for both drives in the utility.
Thanks in advance!

There is one possibility: The new drive could be slightly smaller.
Then the drive cannot be added to the existing array. HDD sizes
vary by something like +/- 1% by manufacturer and model. You can
either compare the exact secor numbers or byte sizes of both
drives or get a replacement that is definitely larger, e.g.
a 300GB replacement for a 250GB array size. Note that this will
not increase the array size, further replacements just need to
be larger or the same size as the smallest drive that ever was
in the array.

One other hint: Experimenting with rebuild is dangerous. You
may want to mirror the still working drive to a replacewment
(using soem imaging software, again the replacement needs to be
exactly the same size or larger) and put the copy in as
"good" drive. That way you have the original as backup if something
goes wrong, _and_ you get a nivce cold spare you can keep handy.
The downside is that you have to buy an additional disk, but at
current prices that should not be a worry.

Arno
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top