Remote TCP/IP port Printing


G

Guest

I have read other posts regarding this problem and NONE of them appear to
have been resolved. Simple I have remote clients with local TCP/IP port
Printers installed. The remote session from these clients does not connect
the redirected printer. This is not a driver issue as I can change these
printers to a local LPT port and the printer appears in the remote session.
I change back to the TCP/IP port and they are gone. Clients are XP Pro SP2.
Server is 2003 Terminal Server. I assume XP SP2 has rdp 5.2. How can you
tell? Please help.
 
Ad

Advertisements

G

Guest

As far as I know, there is still no support for redirecting TCP/IP printers
in an RDP session.
You will, probably, need a third party solution.

Jetro CockpIT
Fulfilling the promise of server-based computing
http://www.jp-inc.com
 
G

Guest

RDP 5.2 supports the rediriction of all local printers from the client PC
including local TCP/IP port printers. As long as a supported driver for the
local printer is installed on the Terminal Server. I can find NO
documentation from MSFT that says this is not correct. In fact there are
tech docs that say Remote TCP/IP ports are supported with 5.2 RDP and not
with earlier RDP clients.
 
G

Guest

Earlier post from someone with exact same problem This works tested it.
MSFT should post a Tech Doc regarding this ASAP.
Found the problem. Seems the local Port name has to start with either LPT or
COM. So if the ip address is 10.0.0.23 for the printer, you have to make
sure the port name is LPTxxx etc. Works fine now.
 
Ad

Advertisements

G

Guest

Look at this Article see if it helps

Q302361

SYMPTOMS
When you use Remote Desktop Connection or the Terminal Services Client
version 4.0 or 5.0 to connect to another Windows-based computer from a
computer that is not running Windows Server 2003, your local printers may not
be redirected. As a result, your local printers are not available in the
remote desktop or terminal services session.

For example, if your Windows XP-based computer has a multifunction print
device using a DOT4 port, it may not be redirected in a remote desktop
session to a Windows 2000- or Windows Server 2003-based computer.
CAUSE
This problem occurs because the printer port does not begin with COM, LPT,
or USB. By default, printer port names that do not begin with COM, LPT, or
USB are only redirected in Windows Server 2003. By default, multifunction
print devices may not be redirected unless you are running Windows Server
2003 on your local computer because they use DOT4 ports.
RESOLUTION
To resolve this problem on a computer that is not running Windows Server
2003, force all ports (including DOT4) on the client computer to be filtered
for redirection. To do this, add a DWORD value named FilterQueueType to
HKEY_CURRENT_USER\Software\Microsoft\Terminal Server
Client\Default\AddIns\RDPDR and set its value data to FFFFFFFF.

Follow these steps, and then quit Registry Editor: 1. Click Start, click
Run, type regedit, and then click OK.
2. Locate and then click the following key in the registry:
HKEY_CURRENT_USER\Software\Microsoft\Terminal Server
Client\Default\AddIns\RDPDR
3. On the Edit menu, point to New, and then click DWORD Value.
4. Type FilterQueueType, and then press ENTER.
5. On the Edit menu, click Modify.
6. Type FFFFFFFF, and then click OK.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top