Remote Desktop Not Working


G

Guest

Trying to get Remote Desktop to work on my XP MCE '02 functioning so I can
get to my home computer from work.

I simply can't get connected (error is "The client could not connect to the
remote computer... etc"). Here is why I am stumped.

Initially, I left the listening port of RD as the default, 3389. I am trying
to connect over a DSL line with a wireless router. So, I configured the DSL
modem to port forward all traffic on port 3389, and also configured the
wireless router to forward traffic on port 3389, specifically to my private
IP address.

First, I ensure that Terminal Services is turned on. After running netstat
-a, it showed that TCP 3389 was in fact listening, and after going to
canyouseeme.org, it showed that the service was indeed running on port 3389.
Then I try to connect (as I understand, I shouldnt have to configure anything
for outgoing traffic on another computer when trying to connect to my home
computer). Nada, the "client could not connect" error continued.

I could connect to my home computer from another computer in the same
network, but not from outside my network. Next, I tried changing all the
ports to 4444 (what the heck, I thought). So, after editing the reg, DSL
modem, and wireless router, I get the same error, but now on canyouseeme.org,
it shows that 4444 does NOT have any services running. So I change it back to
3389. And now it says it does not have a service running on it when I go back
to canyouseeme.org.

And now for the weird. So I download MS's Port Query to take a look at
listening ports. When I do a scan now (after reseting all ports back to
3389), here is what it throws back at me:

TCP port 3389 (unknown service): NOT LISTENING

UDP port 3389 (unknown service): LISTENING or FILTERED
portqry.exe -n 68.17.136.140 -e 3389 -p BOTH exits with return code
0x00000002.

How can it be listening to UDP only, and not TCP (since I have configured
for both in the router/modem)?

Look forward to see if anyone has some ideas, let me know if i need to
provide a little more info. Thanks.
 
Ad

Advertisements

S

Sooner Al [MVP]

Did you reboot the PC after making the change in the registry from TCP Port
3389 to 4444 and back again. Reboot each time after making the change.

You only need to forward TCP Port 3389 (or whatever port your using) through
the router and firewall. UDP Port 3389 is not needed.

When testing using the public IP of the router make sure you test from a
truly remote PC and not from another local PC on the same LAN and trying to
use the public IP. That is not a valid test.

--

Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the
mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no
rights...
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top