Remote Desktop Connection and XP Service Pack 3


Rogan Josh

Hi, All!

I am experiencing an issue using Remote Desktop Connection (RDC) after
installing XP Service Pack 3. Connecting to servers (Win2003) works without
a problem; however, attempting to use Remote Desktop Connection between PCs
running Windows XP Pro does not work unless the user has already logged onto
the machine locally. For example, if a PC is powered up to the login screen
and a user attempts to use Remote Desktop Connection to connect to the
machine, then the connection will fail. Now, if a user logs into the machine
locally and then that same user attempts to login to the machine using Remote
Desktop Connection, then the connection will succeed. This phenomenon did
not exist prior to the installation of the XP SP3 update.

XP Service Pack 3 contained an update to the Remote Desktop Protocol used in
Windows which may be part of the problem. Has anyone else experienced this
type of behavior from the RDC client?

Any help would be greatly appreciated!

Thanks in advance!


It certainly is not an isolated issue, then. I am experiencing exactly the
same symptoms.


Hi, I have a similar issue:
I can not use Remote Desktop after installing Windows XP SP3 on the target
I accessed my taget machine via RDC, installed XP SP3 (using an RD
connection). It finished without any problems, but since then, I can not
access it via RDC (regardless of the client operating system {Vista Business
32bit, Windows Server 2003}).

Does anyone have a solution?


After rolling back to the restore point where XP SP3 was not installed, RDC
is back again.


After rolling back to the restore point whereXPSP3was not installed, RDC
is back again.

- Zitierten Text anzeigen -
Hi All,

I've had the following problem:
I tried to install service pack 3 on a XP SP2 MUI with KB925877
installed. Installation has aborted with Error. In a newsgroup I found
the hint to uninstall the Patch but my uninstallation directory was
deleted long time ago. So I deleted the registry entries that it was
installed and SP3 installation ran perfectly.
After a restart I tried to start a RDP connection to one of my
servers, but nothing happened. When starting the Taskmanager I saw
that the process has started.

- Stopped the process mstsc.exe
- Created a new folder "RDP" in %windir%
- Copied "mstsc.exe" and "mstscax.dll" from "C:\Windows\
$NtServicePackUninstall$" to this folder
- Copied the folder "en-US" "from C:\Windows\System32" to this folder
- Copied the "mstsc.exe.mui" and "mstscax.dll.mui" from "C:\Windows\
$NtServicePackUninstall$" to "C:\Windows\RDP\en-US"
- Changed my RDP shortcut to ""C:\Windows\RDP\mstsc.exe"

Now I can use the 6.0 Version of RDP without problems. Maybe the next
update will destroy my shortcut in the start menu, but I copied it to
the desktop as well.
Note: At this time it is not possible to reinstall any version of RDP
when SP3 is installed. Hope this will be changed by MS.

I hope this helps.

(* nobody's worthless. He can still be a bad example *)


I think you're missing the problem being described.

They are referring to connecting TO a computer that has been upgraded to
SP3, not FROM one.

To describe how the issues feels to me, to put it simply, it feels as though
the network connection isn't being established (prior to a local logon) OR as
though the necessary services to activate/trigger remote logon isn't

Once any account has been logged in, then even if that account is logged
off, I can still use remote desktop to connect to that computer.

Just to eliminate any confusion, let's use Alpha and Delta as computer
names. Both running XP SP2. Delta gets updated to SP3. Alpha can no longer
connect to Delta using Remote Desktop until someone has logged onto Delta
locally. Alpha can log into other computers with no problem. Delta can
connect to and log on to other computers.


I noticed this problem today as well when deploying SP3 to my users
computers. I would connect to a computer (computer alpha) from my computer
(computer beta) via mstsc and install SP3. Upon reboot, I could not connect
to the machine. I had to go log in at the machine and then I could connect
remotely again. I happened to notice that for some reason, the XP SP3
install was turning off the Windows Firewall/ICS service. I restarted the
service and tried logging out and connecting remotely again and it worked.
Not sure if this will fix everyone's problem, but it fixed mine and thought I
would offer it.

Roy V

Same problem here. SP3 and then I cannot do an RDP connection to this XP Pro
Workstation just upgraded. RDP client freezes. Black Screen. Then connection
error. Agh!! For me, when I logged in with RDP session that was not same as
Host machines current login, all worked well. Eg) I was having trouble
connecting the RDP session as "User1". Note, at host, I was also logged in
locally as "User1". While logged in as User1 at local machine I created a new
user "User2". I then went to remote machine and connected RDP session to host
as "User2". All worked.
SP3 has buggered something up and I'm a bit frustrated, many hours wasted.
Something to do with profiles and not allowing multiple instances of same

Does someone have a fix for this problem induced by SP3?
At least I have a workaround for now...

Any help appreciated.


I can't follow this appraoch as my SP3 is a new install not an update. What
is happening with me is that I am being rejected through "incorrect user name
and password" despite both being correct. It is also happening in net work
mapping. It is as if my keys ar not being recorded correctly.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question