remote connection not always available with PCAnywhere, XP



I have a network of 3 PCs, all XP Pro, Linksys VPN Router, connected
to internet through a static SBC DSL line. The computer which acts as
server for the business software is our PCanywhere host. We connnect
to this sytem remotely on another two computer network with a netgear
router, one computer on XXP PRo and the connecting computer with XP
home and using Comcast Cable. Currently there is no antivirus or
add-on firewall on the host computer. We do not have e-mail or
otherwise access the internet from the host computer.

We only use PCAnywhere when the host office is closed and we are
working from the remote location. The majority of the time the
connection works quite well. On occasion the remote computer will
report that it cannot find the host. Upon returning to the office, we
discover that the host computer is up and running, and the indicator
is that PCAnywhere is waiting to make a connection. At that time I
have also been able to connect to the host from inside the LAN, but
have not been able to use PCAnywhere on a phone/modem connection to
the internet to access the host, although our modem conection is
notoriously slow and weak and intermittent and is an unreliable test

When I cannot access, I have confirmed from the remote location that I
have an internet connection. I can ping various locations but cannot
ping my static address. The last time this happened, we used the
remote connection successfully on Friday, closed down properly and
could not connect on Monday. No one had been in the office or
connected to the computer in the meantime. But this failure has also
occurred within twelve hours of readying the host for connection.
Once we have received the cannot find host message, we have never been
able to make a connection on a subsequent attempt without resetting
the host.

Does anyone have an idea where the problem is? Thanks in advance

Bill Sanderson

I don't know what's happening with PCAnywhere, I'm afraid.

Have you considered trying Remote Desktop instead--to see whether it works
more reliably for you?

It is different--some folks find the file-transfer UI in PCAnywhere easier
to "see".

I suggest this because you have the software already in place to try it
out--so the cost will be in time to learn and test the different remote
access method.

An alternative to consider would be enabling Remote Desktop on the "server"
machine, and using it as a mechanism to troubleshoot, perhaps including
remote restarting.


I have ran into similar problems, when using an SMC barricade router we have
to "hit" the machine twice in a row to connect, the router takes a few extra
seconds to forward the port. In these cases we changed the "retry host
settings " to two with no seconds between retries, and it has pretty much
solved this issue.

The only other way I have solved this issue, in other situations. is to do a
restart on all the devices once a day. (router/DSL Modem/Computer) We use a
"Light Timer" to cut power to the Router/DSL Modem. and a scheduled task on
the machine. All this takes place at 4:00 AM when no one is connected ever!

We have pretty much the same issue here.

Matt suggests you use Remote Desktop, I would also recommend the same if a
scheduled restart is not possible.

Bob Forward

I had a similar problem when I first setup PCAnyWhere on a new XP Pro
at the office. Previously, I had no problems with it on a 98 machine.
I tweaked some of the settings in the properties on the host and
finally got it to connect from home without fail every time. For
PCAnyWhere, XP seems to react much more slowly than 98, have more
overhead, low priority, or something.

My latest problem with PCAnyWhere on XP: it does not pass the Pause
key from the remote computer to the host--can't seem to find where to
fix that.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question