Re: Picture and Fax Viewer -- Default Editor


J

John Inzer

Wayne said:
Until yesterday, whenever I would view a .JPG in Windows
Picture and Fax Viewer, I could click on the icon to close
the viewer and reopen the .JPG for editing. Whenever I
did, the Microsoft Photo Editor would open. Now all of a
sudden, when I do this, Microsoft Paint opens.

I have read every "help" file I can find, but I cannot
figure it out. I really do not like Paint for photo
editing. How can I get the viewer to start opening Photo
Editor again?
===========================================
Did you change/update anything on your computer?
Did you uninstall any programs? Microsoft Photo Editor
was part of an older MSOffice program wasn't it?

If Microsoft Photo Editor is currently installed on your
computer, you should be able to go to...Start / Search...
type in...Microsoft Photo Editor...and find it. If you find
it, you can use the following instructions to set it as your
default image editor.

MSPaint is the default image editor in Windows XP...

It can be changed as follows if you are comfortable
working in your registry.

IMPORTANT: This message contains information
about modifying the registry. Before you modify the
registry, make sure to back it up and make sure that
you understand how to restore the registry if a problem
occurs. For information about how to back up, restore,
and edit the registry, click the following link to view the
article in the Microsoft Knowledge Base:

(256986) Description of the Microsoft Windows Registry
http://support.microsoft.com/default.aspx?scid=kb;EN-US;256986


OK...go to...Start / Run and type in..."regedit" without
the quotes. Then click OK or press...Enter.

In the Registry Editor...drill down to:

HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\edit\command

In the Data column you should see the following string:

"%systemroot%\system32\mspaint.exe" "%1"

(where you see *mspaint* in the example....you will see
your current default)

Replace the string with the path to the program that will
be your default image editor. I wanted Picture It! 7 so
the following is what I changed to.

"C:\Program Files\Microsoft Picture It! 7\pip.exe" "%1"

Now, my images still open in the Picture and Fax viewer
but if I click the Edit button...Picture It! 7 opens.

Good luck.
 
Ad

Advertisements

P

Paul Voogt

===========================================
Did you change/update anything on your computer?
Did you uninstall any programs? Microsoft Photo Editor
was part of an older MSOffice program wasn't it?

If Microsoft Photo Editor is currently installed on your
computer, you should be able to go to...Start / Search...
type in...Microsoft Photo Editor...and find it. If you find
it, you can use the following instructions to set it as your
default image editor.

MSPaint is the default image editor in Windows XP...

It can be changed as follows if you are comfortable
working in your registry.

IMPORTANT: This message contains information
about modifying the registry. Before you modify the
registry, make sure to back it up and make sure that
you understand how to restore the registry if a problem
occurs. For information about how to back up, restore,
and edit the registry, click the following link to view the
article in the Microsoft Knowledge Base:

(256986) Description of the Microsoft Windows Registry
http://support.microsoft.com/default.aspx?scid=kb;EN-US;256986


OK...go to...Start / Run and type in..."regedit" without
the quotes. Then click OK or press...Enter.

In the Registry Editor...drill down to:

HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\edit\command

In the Data column you should see the following string:

"%systemroot%\system32\mspaint.exe" "%1"

(where you see *mspaint* in the example....you will see
your current default)

Replace the string with the path to the program that will
be your default image editor. I wanted Picture It! 7 so
the following is what I changed to.

"C:\Program Files\Microsoft Picture It! 7\pip.exe" "%1"

Now, my images still open in the Picture and Fax viewer
but if I click the Edit button...Picture It! 7 opens.

Good luck.
===========================================

I've got a similar problem but haven't been able to repair it in the way you
describe. In my case the default editor is Paint Shop Pro. I've changed the
registry key to the following string:
"C:\Program Files\Jasc Software Inc\Paint Shop Pro 7\psp.exe" "%1"

When I doubleclick a photo file the viewer opens. When I try to open the default
editor by clicking the icon in the viewer, it closes (as it should I believe),
but then nothing happens. I can however open the file in PSP by rightclicking on
the file.

Any ideas how I can correct this behavior?
 
J

John Inzer

Paul Voogt said:
I've got a similar problem but haven't been able to repair it in the way you
describe. In my case the default editor is Paint Shop Pro. I've changed the
registry key to the following string:
"C:\Program Files\Jasc Software Inc\Paint Shop Pro 7\psp.exe" "%1"
===========================================
All I know is that if the path is correct, it should work.
===========================================
When I doubleclick a photo file the viewer opens. When I try to open the default
editor by clicking the icon in the viewer, it closes (as it should I believe),
but then nothing happens. I can however open the file in PSP by rightclicking on
the file.
===========================================
Maybe there's a problem with your image associations.

If you download and run the FixPix2.inf script from the
following website...it will reset your image associations
to Windows Explorer.
http://www.chris-tech.com/~spc911/index.html
 
W

Wayne

It can be changed as follows if you are comfortable
working in your registry.

IMPORTANT: This message contains information
about modifying the registry. Before you modify the
registry, make sure to back it up and make sure that
you understand how to restore the registry if a problem
occurs. For information about how to back up, restore,
and edit the registry, click the following link to view the
article in the Microsoft Knowledge Base:

(256986) Description of the Microsoft Windows Registry
http://support.microsoft.com/default.aspx?scid=kb;EN- US;256986


OK...go to...Start / Run and type in..."regedit" without
the quotes. Then click OK or press...Enter.

In the Registry Editor...drill down to:

HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\edit\ command

In the Data column you should see the following string:

"%systemroot%\system32\mspaint.exe" "%1"

(where you see *mspaint* in the example....you will see
your current default)

Replace the string with the path to the program that will
be your default image editor. I wanted Picture It! 7 so
the following is what I changed to.

"C:\Program Files\Microsoft Picture It! 7\pip.exe" "%1"

Now, my images still open in the Picture and Fax viewer
but if I click the Edit button...Picture It! 7 opens.

Good luck.

--

John Inzer
Picture It! MVP
return e-mail disabled

Mr. Inzer,

Your solution worked perfectly. Now I can finish editing
my pictures from our 30th annaversary trip to Italy.

Mille Grazia!
 
Ad

Advertisements

J

John Inzer

Jim Goldthorp said:
I am trying to edit the registry as indicated, however, I
cannot find the location of the Microsoft Photo Editor so
I can change the path from Paint.exe to it. Any idea
where I can find it?
=================================
I think it's part of MS Office...maybe you'll find
it there. I'm sorry, but I don't have the program
so I don't know anything about it.

Do you have an icon you launch it with? If you
do, right click the icon and choose Properties,
the path should be displayed in the Target field.

Also, you might find it with a search.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top