Quake 4 Texture compression problem.



This one has beaten me severly about the head & sholders.
Doom 3 runs ok, and uses the same engine as Quake (So I'm told). Quake 4 and
Quake 3 used to run on the same P/C several video cards and dirver versions
ago, with XP SP1a. Doom 3 did not run after windows and Nvidia driver video
card updates, until SP3 and video drivers were updated. Now, Quake 4 gives
me the infamous texture compression error. There is obviously something odd
concerning OpenGl, but I haven't been able to find it.
It looks like the GL-ARB library is at the heart of the problem, and I
cannot find enough info to begin to chase various DLL's that might be

One faint possibility goes back to the P/C, in that it had an older ATI
video card in the past. (Two or three Video cards ago.)
I suppose it's remotely possible that one of the older DLL's from this card
might be involved.
There is also a possibility that an older Nvidia driver made a registry
entry (that I haven't found) that somehow blocks the dll with GL-ARB calls.

The Quake diagnostic message Texture compression unavailable is followed
....unloading OpenAL DLL
sound: STEREO
X..GL_ARB_multitexture not found
X..GL_ARB_texture_env_combine not found
X..GL_ARB_texture_cube_map not found
X..GL_ARB_texture_env_dot3 not found
X..GL_ARB_texture_env_add not found
X..GL_ARB_texture_non_power_of_two not found
X..GL_NV_blend_square not found
X..GL_ARB_texture_compression not found
Fatal Error: Texture compression unavailable
Shutting down OpenGL subsystem
....wglMakeCurrent( NULL, NULL ): success
....deleting GL context: success
....releasing DC: success
....destroying window
....resetting display
....shutting down QGL
....unloading OpenGL DLL
--------------- BSE Shutdown ----------------
Shutting down sound hardware
Texture compression unavailable

Crysis and Far Cry work, haven't tried some of the older URU family games
The P/C uses AGP, (older MSI MBD, and an AMD X2 processor at ~2GHZ)

Going thru the painful process of reinstalling XP and all the other apps
just isn't worth the time & effort for one game.


Whatever the problem was, an NVidia developer tool kit install solved it!
(PerfKit_x86_XP_6.00.0624.1248.exe 0
Interestingly enough, the install claimed I had older drivers, and installed
unnamed drivers, even though the previous drivers were the latest version
listed for the video card on the NVidia web site. ????


Another oddity. Although Quake 4 now runs and is playable, the same texture
compression error will/may occur if game "cheat" commands are included at
the end of the "C:\Program Files\id Software\Quake 4\quake4.exe"?? These
used to work on earlier Quake 4 revs.
Realtek VR OpenGL viewer 3.0 indicates that there are still some driver
anomalies with various open gl function entry points support. Naturally, one
is in the texture area.

What a bag of worms!

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads