Problems with ULS, i.e., removing permissions from tables



Hi all,

My database is almost ready to be distributed to my users so I’m working on
tightening up the security. Yesterday I found information SOMEWHERE on these
newsgroups (or related link??) regarding removing permissions to all tables
and queries and changing queries properties to run with owner’s permissions.
For the life of me I can’t find that info today (I’ve spent a couple hours
searching so far!); hence, my posting.

I’ve tried setting the following permissions for my Read-Only Users:

- current database as open/run
- tables: (1) “Switchboard items†as read data, read design
(2) “Database problems†as read data, read design, insert data
- queries: zero permissions but as mentioned above permissions property set
to Owner’s
- forms: open/run
- reports: open/run
- macros: open/run

I tried testing this by logging in as one of my users. From the switchboard,
I was able to open the form that allows users to report database
problems/issues. However, every other switchboard button that would launch
other forms or reports results in the error “There was an error executing the

What am I missing? I feel perhaps I might have misinterpreted something but
of course I can’t find the information that I found yesterday. :(

Thanks for any and all help!



Oops! I forgot to mention that read-only users have zero permissions on all
other table.s


Joan Wild

You may have been looking at

From your description below, you Read-Only Users should have no permissions
on the tables. You set the RWOP property on each of your queries. But The
RO Users need to have permissions on the queries - i.e. Read Data at a
minimum. If they need to add/edit/delete records while using the query,
then assign those permissions as appropriate.


Hi Joan,

I think I may have read something on your site but not this page. I wish I
had, then I wouldn't have needed this post. :)

Thanks a bunch!



Hi Chris,

Thanks for taking the time to respond. I mistakenly understood it was
sufficient to set the individual query's permissions properties to "Owner's"
(which by the way, automatically added the phrase you suggested). Thus, I
revoked all permissions to queries under "Tools\Security\Group and User
Permissions." I had read the Security FAQ but apparently not closely enough.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question