Problem Installing .Net Framework 3 or 3.5


R

Ralph Tomaccio

I recently downloaded new software and in order to install it, .Net Framework
3.0 is required, which was part of the installer. During the installation
process it presented a window that said "Microsoft .Net Framework has
encountered a problem during setup. Setup did not complete properly."

I contacted the software company and they suggested I try downloading 3.5
direct from Microsoft and try that. I did, and I received the same message.

I use Windows XP SP2 and, in checking Add & Remove Programs, have .Net
Framework 1.1 and 2.0 installed.

What is preventing me from being able to install 3.0 or 3.5 on my computer?

Also, is it okay to remove the oldest version without upsetting the whole
system or must all previous versions be kept on the computer?

Your help is most appreciated as I can't install or use this required
downloaded software without at least .Net Framework 3.0.

Thank you.
 
Ad

Advertisements

J

Jerry

You are not talking to Microsoft here, this is a public newsgroup hosted by
Microsoft.

Newer versions of .NET Framework do not supersede previous versions - you
need them all.

I checked mine and I have 1.0.3705; 1.1.4322; 2.0.50727; 3.0; and 3.5

Beyond providing the above info I have no further suggestion for solving
your problem.
 
R

Ralph Tomaccio

Jerry, Thanks for your reply. I do realize I wasn't talking directly with
Microsoft. I just want to solve my problem and thought this would be the best
place to try. Was there a reason why you mentioned that? Is there a better
place you can recommend?

So, what you're saying, if I understand you correctly, I cannot uninstall
the old versions and try to install the latest, nor should I uninstall older
versions, period!
Correct?
 
F

Family Tree Mike

Ralph Tomaccio said:
I recently downloaded new software and in order to install it, .Net Framework
3.0 is required, which was part of the installer. During the installation
process it presented a window that said "Microsoft .Net Framework has
encountered a problem during setup. Setup did not complete properly."

I contacted the software company and they suggested I try downloading 3.5
direct from Microsoft and try that. I did, and I received the same message.

I use Windows XP SP2 and, in checking Add & Remove Programs, have .Net
Framework 1.1 and 2.0 installed.

What is preventing me from being able to install 3.0 or 3.5 on my computer?

Also, is it okay to remove the oldest version without upsetting the whole
system or must all previous versions be kept on the computer?

Your help is most appreciated as I can't install or use this required
downloaded software without at least .Net Framework 3.0.

Thank you.
You should be able to uninstall all the versions, then install the latest.
When you install the 3.0 or 3.5 versions, it installs the necessary previous
components. You "may" find that when you uninstall the versions, that one is
in use by some product on your computer and prevented the upgrade. I say
"may" because I don't know how the installers handle this condition.
 
R

Ralph Tomaccio

Thanks for your response, Family Tree Mike.

I think I would like to try that, to remove the old versions and try
installing the latest.

But, before I do, if I create a Restore Point before doing so, and things
don't work out with the new install of 3.5, will going back to the restore
point work in this scenario?
 
F

Family Tree Mike

I haven't done that, but I suppose it is a resonable precaution.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top