Power User Cannot Add Local Printer


G

geekgrrl

Hello,

I have a small application that calls AddPrinter to create a copy of
an installed printer.

Everything works fine under the administrator account, or an account
with administrative privileges. When I try to copy a printer with this
application under a user who is part of the Power User group, it fails
with error 1307 (This security ID may not be assigned as the owner of
this object. ) I have added Power Users to the Load/Unload device
driver user rights and the printer still fails to copy.

Strange to me though, I can successfully create a copy of the printer
using the Add Printer Wizard.

Does anyone have any ideas what the add printer wizard is doing
differently?

Thanks.
 
Ad

Advertisements

L

Lanwench [MVP - Exchange]

geekgrrl said:
Hello,

I have a small application that calls AddPrinter to create a copy of
an installed printer.

Everything works fine under the administrator account, or an account
with administrative privileges. When I try to copy a printer with this
application under a user who is part of the Power User group, it fails
with error 1307 (This security ID may not be assigned as the owner of
this object. ) I have added Power Users to the Load/Unload device
driver user rights and the printer still fails to copy.

Strange to me though, I can successfully create a copy of the printer
using the Add Printer Wizard.

Does anyone have any ideas what the add printer wizard is doing
differently?

Thanks.

Replied to your identical post in another group.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top