Philips SPC 900 NC spc900nc Webcam


G

Guest

Hey all,

I have the intel 6600 Core 2 Duo running on Vista Ultimate x64. I just put
my computer together yesterday and installed Vista yesterday. I can't get my
webcam to work. I downloaded the driver from Philips and ran the .exe. It
seemed to work and then after rebooting, Vista still comes up without a
driver for my "Unknown device".

I tried going online by doing the automatic driver update. It did find it
on Microsoft, but it keeps telling me that the download failed. Anyone know
why it's not downloading? I checked other forums and they seem to be able to
download it. I've been able to download other updates except for this
driver. Even the Philips website suggests that I do the automatic download:

http://www.p4c.philips.com/cgi-bin/..._24.148.75.77&ctn=SPC900NC/37&dct=RMF&did=ENG

Now this isn't the first time that I've run into not being able to load a
driver conventionally (download the driver from the manufacturer and do it
manually). Yesterday I went to the D-link website and downloaded the driver
for my wireless network card. It didn't work. I had to get it from the
Microsoft website.

Any suggestions?

Chase
 
Ad

Advertisements

G

Guest

Cheese,

I checked at the Philips link in your message, but the site doesn't disclose
whether the drivers are for Vista 32 bit or for 64 bit. Could this be the
problem? Is it possible that that download includes both versions? I don't
have a way of knowing. You need the 64 bit version. Can you shine some
light on that point?
 
G

Guest

I thought about that too. I have no idea if the driver is 32bit, 64bit, or
both. The website doesn't say. Maybe it's 32 because when I do the driver
update for Vista, it can't find it.

Chase
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top