PC power problem...=(


J

jamesdyang

Hi,

I just built my PC, and hooked everything up, but when i power it on it
turns on for like a split second and dies. The keyboard light stays on
when i turn on the power supply but nothing else works.

I tried disconnecting everything leaving only the ram processor and
psu. For some reason it turned on once, but i never got it working
since.

Is this the PSU unit's problem, or is the mobo dead?

thanks!

I also don't have an extra computer laying around to test things which
is kinda annoying. Is there any other method i can do?

thanks.
 
Ad

Advertisements

J

jamesdyang

Hi,

I just built my PC, and hooked everything up, but when i power it on it
turns on for like a split second and dies. The keyboard light stays on
when i turn on the power supply but nothing else works.

I tried disconnecting everything leaving only the ram processor and
psu. For some reason it turned on once, but i never got it working
since.

Is this the PSU unit's problem, or is the mobo dead?

thanks!

I also don't have an extra computer laying around to test things which
is kinda annoying. Is there any other method i can do?

thanks.

oh yeah and also. the fan inside the psu doesn't spin at all, don't
know if that's important or not.
 
Ad

Advertisements

R

Rod Speed

I just built my PC, and hooked everything up, but when i power it
on it turns on for like a split second and dies. The keyboard light
stays on when i turn on the power supply but nothing else works.

You can get that result in a variety of ways with a new PC.
I tried disconnecting everything leaving only the ram processor and psu.
For some reason it turned on once, but i never got it working since.

If you didnt install the cpu heatsink and fan properly, you may have killed it.
Is this the PSU unit's problem,

Could be, it may have been too small to power the system and its been killed now.
or is the mobo dead?

Could be that too.
I also don't have an extra computer laying around to test things
which is kinda annoying. Is there any other method i can do?

Not really with no sign of life at all now.
oh yeah and also. the fan inside the psu doesn't spin
at all, don't know if that's important or not.

Yes it is, particularly when it did work for a while and now doesnt.

Trouble is that without something to load the psu with, you cant really
even test it by unplugging it from the motherboard and see if it starts
when you short the PS_ON# line to ground to tell it to turn on.

While in theory you can use the hard drive as a load, thats not very
desirable because if the psu is dying, it can kill your new hard drive.

I'd personally get a new psu thats certain to be powerful enough for
your new system, and a decent brand too, and see if thats the problem.
Buy it from an operation that does free or low cost returns so that if
that makes no difference it wont cost all that much to try that.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top