Another post
mentions this problem and the solution was replacing system memory.

I have this problem and System Memory is not the solution.

I assembled an ASROCK P4VM890 based system using a 3.0GHz P4 Northwood, two
1GB sticks of PC3200 DDR1 memory and two SATA-150 drives configured as
non-RAID. This motherboard has integrated graphics as a PCI-express slot for
a graphics card where I have installed GeForce 8500GT 256MB graphics card.

The installation of Windows XP Pro OEM edition went smoothly and at a point
after only the OS had been installed and activated no other drivers or
software or updates had yet been installed that I decided it might be good to
upgrade the processor with a 3.2GHz Northwood that I had bought thru eBay.
That swap out went well and I ran several system benchmark style tests from a
USB stick packed with diagnostic software to conclude that Processor, L1 and
L2 cache, System Memory, Hard Drives and Graphics subsystems were all good.

So I decide to install the most current drivers for the motherboard based on
what I could find at ASROCK web site. I noted that the BIOS was already at
the latest revision. Being a VIA chipset, past experience told me that it is
advisable to first make sure that the VIA quad drivers are up to date. The
drivers I could download from the ASROCK web site would not download
successfully - corrupt ZIP file. So I pulled out the CD-ROM that came with
the P4VM890 motherboard and decided to install the drivers from that media.

Up until this point the system has been stable and I had run numerous memory
and system performance tests to convince myself that I had a stable base to
work from. Alas I did NOT make a Norton ghost image of the hard drive!

The VIA chipset drivers did not install successfully from te driver CDROM.
3 or 4 fail messages appeared before the install wizard completed and stated
that no drivers had been installed. Upon restart the BSOD with
PAGE_FAULT_IN_NONPAGED_AREA and implicating NTFS.SYS appeared for the first
time and kept reappearing. There was no option to enter safe mode.

I tried reducing memory to one stick then swapping out memory for known good
memory from another system. I even swapped out the 3.2GHz Northwood and
replaced it with the original 3.0GHz Northwood that I had originally built
the system with.

Carefully stepping through BIOS settings I tried every conceivable way of
being kind to the memory subsystem including underclocking it, reducing the
memory shared with the graphics subsystem, switching to the onboard graphics
chip, etc.

None of these allowed me to get past this BSOD.

I decided to try an OS reinstall but that was also fouled by the BSOD at the
point where you make a choice from among "Enter" to install, "R" to repair or
"F3" to exit the setup.

Thinking that the NTFS filesystem may have become corrupt, I wiped the
partition table clean and repartitioned and re formated using Norton
Partition Magic. (I could not use the Maxtor PowerMax low level format on
these SATA drives.)

Upon attempting a fresh install of WinXP Pro OEM edition the same BSOD
appears at the same point described earlier. I tried an Upgrade version of
the OS install media and I also tried Win2000 OEM install media but both
failed to progress past the Starting Windows screen.

Heres the surprise - Ubuntu 7.10 Gutsy Gibbon installed and runs without a
hiccup! By the way at this time I have reinstalled the original pair of 1GB
PC3200 memory sticks and am running the graphics card in the PCI-express slot
with 64MB of system memory shared with video.

Encouraged by that success I tried a Win 98 SE install and that appears to
be completing successfully as I type this post.

So based on the above I can't find fault in the hardware and yet a
supposedly clean install of Windows XP Pro (or Win2k Pro) fails with a BSOD.

1) Can someone explain to me how this can be?
2) What are the next fault isolation steps to follow?
3) Should I read much into the fact that Win98Se and Ubuntu Linux install

I have a PATA IDE drive on hand that I may swap in next just to see if there
is something going on with respect to the onboard SATA controller.

I am at a loss!


It turned out that using a different HDD utility to clear the partition table
and repartition the disk was necessary to get past this BSOD problem.

I found a Western Digital Data LifeGuard utility that allowed me to clear
the partition table (NOT a low level format) and create new partitions.

After that step installation from the WinXP Pro OEM disk does proceed
without the BSOD.

Why is this so?

Something about how Norton Partition Magic previously cleared the partition
table must have been less rigorous or sufficiently different to have not
eliminated the root cause of the BSOD. This particular
PAGE_FAULT_IN_NONPAGED_AREA implicating NTFS.SYS was not attributable to
system memory or L2 cache memory issues but rather was attributable to an
unknown issue with the HDD partitioning.

Andrew E.

Simply reseting "virtual memory" in OS properties to "let system manage" from
the default "custom setting" usually eliminates that problem.Also,newgroup
postings are by no means microsoft views of "how to",these posts good or not
so good,are all end users view points.Replacing memory in a page fault would
be my last area to check,you'd see xp blue screen or freeze up with bad
then run microsoft memory tester....

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question