Outlook2003 downloading .ics invite as text


K

Kryten

When I get meeting invites from certain people (over the internet, but sent
from Outlook2003 also), the invite appears as a normal text message with all
the ics code in the message body. I know there was originally a .ics invite
attachment on the mail server because I can see it on my iPhone, but when
Outlook downloads it (POP3) the ics is converted to text and so I cant add it
to Calendar.

An added oddity is that if I forward the ics message on my iPhone to another
mail address it arrives safely as a .ics attachment, but when trying to open
I get the Lunar/Gregorian issue. I investigated the Lunar issue, by opening
in Notepad, and found an email signature at the bottom of the text. So I
removed the signature, saved the file and it works normally as a Calendar
invite.

So:
a) Why does the .ics invite get converted to text on one email account and
not another, and
b) why does the ics have a signature messing things up?

Thanks.
 
Ad

Advertisements

R

Roady [MVP]

It probably got corrupted somewhere. Having a virus scanner which integrates
itself with Outlook is a common cause of this. Disable/uninstall this
integration feature of your virus scanner and try again.
See http://www.msoutlook.info/question/20

When it gets treated as a message, it could indeed also get a signature
appended to it.
 
K

Kryten

I disabled the AVG email scanner but same thing happened. Didnt think there
was anything else in AVG that affects emails.
 
R

Roady [MVP]

Disabling the virus scanner is not the same as removing its integration
components from Outlook. Check the manual of your virus scanner on how to do
that properly. It often requires a reinstall of your virus scanner.
 
V

VanguardLH

Kryten said:
I disabled the AVG email scanner but same thing happened. Didnt think there
was anything else in AVG that affects emails.

Disabling e-mail scanning in many AV products will completely get it out
of the way (so no e-mail traffic passes through it). That's not true
with AVG and McAfee. Disabling their e-mail scanner still has the
e-mail traffic go through their proxy. The e-mail doesn't get
interrogated anymore but their proxy is still in the way. To get e-mail
traffic from no longer passing through their e-mail components you have
to uninstall and then do a custom install where you elect to NOT include
their e-mail scanner.

Also anything upstream of your e-mail client that interrogates the
e-mail traffic can corrupt it. For example, anti-malware, anti-spam,
and firewalls might in the path for e-mail traffic. If you have those,
try temporarily disabling them and retest.

What format was used in the received e-mail? Plain text, HTML, or RTF?

Is is always from the same sender that their iCalendar attachment
doesn't work? Is this sender or senders using Outlook 2000? If so, see
http://support.microsoft.com/kb/307313.

Have you applied the latest Office service pack?

I'm wondering if the one composing the e-mail with the iCalendar
attachment is constructing it correctly. According to the article at
http://kobikobi.wordpress.com/2009/...-requests-to-outlook-via-aspnet-mail-message/,
Outlook 2003 needs the iCal.Method="PUBLISH" attribute or it gets the
Lunar error that you noted.
 
K

Kryten

Thanks for answers. My responses are:

It happens when anyone from a particular client invites me. They operate
Outlook2003 too. However colleagues (with different systems/pcs) can receive
the invites from the client fine.

The text email I get seems to arrive in HTML. Also, I can receive invites
from various other clients without an issue.

I will look into AVG email scanner uninstall.

I have the latest Service Pack for Outlook.

UPDATE: The sender re-did the invite and it worked. She said she used
"iCalendar". I thought Outlook was supposed to automatically do this for
internet recipients to ensure they receive an invite?
 
Ad

Advertisements

B

Brian Tillman [MVP - Outlook]

UPDATE: The sender re-did the invite and it worked. She said she used
"iCalendar". I thought Outlook was supposed to automatically do this for
internet recipients to ensure they receive an invite?

I think by default, Outlook uses vCalendar, not iCalendar. Have one of the
senders whose message is bad click Tools>Options>Calendar Options and examine
the box labeled "When sending meeting requests over the Internet, use
iCalendar format".
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top