Offline Files in Vista



I posted these questions below on the Vista team blog earlier today, but was
requested that I post them here instead.

I’ve been having some problems with Offline files on a Vista Ultimate laptop
that is connected to our Windows 2003 R2 server. We have about 20GB of data
in the share that is being synchronized. I have the following questions:

1) We keep having {GUID like #}.tmp files appearing on the share after a
sync. What exactly are these files and why are they created?
2) About fifteen files are giving an error in the sync center and all it
says is “Access Deniedâ€. I’ve verified that our user has full control to
this location. I think this is probably tied into my first question somehow.
Why does this happen? I’ve ran across a couple of other boards about
Oplocks being disabled that might possibly cause this, but I have not
modified this setting on the server and it looks like they are still on.
I’ve rebuilt the entire cache once and it worked for a day or two and then
started giving these “Access Denied†errors again.
3) When you disable Offline files in the Control Panel why is the CSC folder
not automatically deleted? If it is disabled I would think it should wipe
out that data in the cache, if nothing else to free up space and enhance
security. Not to mention it will quickly become obsolete. It also makes it
a lot harder to clear the cache.
4) Why does the sync center not count an automatic sync on the status under
the last sync was performed on x/x/xxxx? Why does the sync center icon not
animate when an automatic sync is in progress? It also appears that if
errors occur during an automatic sync they are not reported on the sync
center system tray icon.
5) Is it still a good idea to schedule a sync even though it automatically
syncs when you are back online?

Thanks for your help with these questions. I’ve been kind of puzzled about
these issues we have been seeing. I really like the improvements over XP
though and see great promise in them.


After a few hours of troubleshooting today. I was able to work around my
"Access Denied" errors. I had to rename the files before syncing, then after
a sucessfull sync I changed the name back. After performing that process for
each file with an error I was able to delete all the {GUID}.tmp files and
they did not come back after several full syncs.

Jill Zoeller [MSFT]

Good to hear you solved the problem. And thanks for moving your question
here for others to see.



Chances are, you're going to encounter this again. There seems to be a nasty
bug (which I reported to the same blog) that prevents Offline Files from
dealing with renamed or deleted files while offline. Meaning, take your Vista
machine offline, go rename or delete a file or folder in the share, and then
try to reconnect and sync. You'll be greeted by those Access Denied errors.

The workaround is just what you discovered -- rename back to the old name,
sync (or go online), and then perform the rename again. With deleted files,
you have to create a dummy file at the original location, go online, and then
remove it again.

Basically, this bug makes synchronizing impossible (for my environment
anyway) since one of the main points to "Offline Files" is actually being
able to go offline and reconcile the changes when you come back online.
Clearly it's not operating as advertised. One can only hope Microsoft will
provide a solution for us soon so we can stop limping along with this broken
behavior. I was really looking forward to the improvements for Offline Files
in Vista (since the XP implementation had its own issues), but instead I've
ended up with less functionality.

One more gotcha to watch out for -- you have to disable UAC (or perform some
creative elevation exploits) to delete files from the cache, otherwise it
just silently fails and your allocated space doesn't change. Additionally,
you have to be online and the file has to exist at the original share or it
still won't delete it from the cache.

Very frustrating. More so considering 5 months since RTM and still no fix.

Shubhankar Sanyal [MSFT]


My apologies for not responding to your blog comments earlier. I have pasted
the comment here and will try to respond to them:

All three issues you have mentioned here seem to point to the existance of
"ghosts" on your system. Ghosts are files/directories for which you have
entries in your cache, but their data has not yet been filled in. This could
happen if you access one of many files on an autocached share while online.
In this case, the file you did access while online would be available
online, but all the other files in the share would be ghosts while offline.
You should be able to make them out in the UI because their icons will be
grayed out and will have an icon overlay shaped like an 'X.' Additionally
you would not be able to open these items while offline.

Please let me know if you see these ghosts on your system inside the
shares/directories in question, when you encounter the issues you reported.


"I've really been looking forward to the enhancements to Offline Files in
Vista. But, I seem to have run into a couple problems preventing me from
using the feature and I'd really appreciate some help.

I'm working with shares of an XP SP2 machine with caching set to "Automatic
caching of documents". This allowed my Vista Business workstation to
automatically cache files from the share when accessed. After doing this, I
have encountered three issues.

Issue #1: When I go to the Offline Files applet in the Control Panel, I can
see the files are correctly filling up against the Temporary offline files.
When I click "Delete Temporary Files..." I receive the expected dialogs
telling me it's clearing the space and completes successfully. However, the
bar doesn't move, the same amount of space is still allocated when the
deletion completes, and the files still seem to be available offline.
Basically, the button has no practical effect and no space is reclaimed.

Issue #2: While offline, I moved some folders on the XP machine. When I
reconnected with Vista and tried to sync, I received numerous errors all
from the folder location that was moved saying "Unable to sync at this time.
Please try again." I made no changes to the files while offline. Now I
understand some changes were made to this feature to support shares going
offline inside of a DFS root, but these are just sub-folders inside of a
regular share -- why doesn't it realize the subfolder has been removed and
update the namespace accordingly? More importantly, how can I keep this from
happening and how can I correct it now that it has (as in, make the sync
errors to the non-existent directory stop)?

Issue #3: From the General tab of the same applet, I clicked "View your
offline files" and navigated to the share giving me trouble. Inside, I was
able to see all of my folders Online except for the cached copy of the one I
had moved -- it was marked Offline (need to sync). Well, I wanted to delete
it from the cache since it had been moved on the server. So, I right-clicked
and selected "Delete Offline Copy". I was greeted with, "Completed deleting
offline copes." Yet, the cached folder was still listed -- no change.

So to sum up, why doesn't it recognize a moved folder in this situation, and
why can't I delete anything from the offline files cache?

I have reproduced this on two different Vista installations. I can
completely clear the cache and start over, but that doesn't prevent it from
happening again."


Greetings Shubhankar,

I can confirm that was the case for many of the files causing the issue --
they showed as 0 bytes when viewing the cache via the shell extension. In
some cases, however, the file was fully available in the cache with its data
populated but I had either renamed it or the folder containg it directly from
the server. I don't recall whether those cases showed with the X overlay or
not in Explorer when I reconnected the client, but I think I remember being
able to still access the data at the old location even though it no longer
existed. Trying to sync or remove them resulted in the access denied error.

I've since had to manually remove the CSC folder because that seemed to be
the only way to get rid of the problem files and fully reinitialize the
cache. This goes without saying, but I'd really like to be able to use the
feature, and due to the blocking severity of this issue, a hotfix would
obviously be preferred over waiting for Vista's first service pack. I hope
you can help.



Thanks for the responses everyone! This morning I have three files that are
failing to sync again due and are reporting the "Access Denied" error. Every
time we try to sync it will create another copy of the three files with the
"GUID like #.tmp".

This error behavior has me concerned. When all of our computers are on
Vista this could fill up our file share quickly if everyone’s computer
started making the .tmp files. I'm going to try renaming them again once I
get a time setup to work on this laptop again.

Please let me know if there is anything else I can check to figure out what
is causing this to happen. Thanks, Ryan.


I just changed the share permission on my server from "Change" to "Full
Control" for this user group and the three errors cleared up. Thanks to
Shubhankar for the tip. I'm not exactly sure why it did not work with
"Change" permission though. I'll let ya'll know if any errors come back.

Shubhankar Sanyal [MSFT]

Hi Aaron,
It sounds like you do have ghosts and that is what is causing the issues-
problems deleting cache entries and errors syncing server modified files,
when the files are ghosts on the client. Both are bugs that we know about
and that we have fixed/will fix. Unfortunately, I don't have information yet
about when or how the fixes will be released. I shall let you know when I
know more.
As a short term solution, you might try using manually cached files instead
of auto-cached files. So you would make the shares/folders available
explicitly by either manually (rt click->always available offline) or
through a group policy. Pending the fixes, this would alleviate your
Thanks for trying out offline files and reporting the issues.

Hope this helps,


I've been a long time user of offline files, so this was an unfortunate
regression for me after the upgrade to Vista. Fortunately I am able to
configure most of my shares for manual caching as an interim solution. After
some limited testing, it appears to be performing the synchronizations
correctly. I am looking forward to those fixes, however, so I can once again
take advantage of the performance and availability benefits auto-caching
provides. I would appreciate knowing more about the fixes and the timeframe
when the information is available.

Thank you,


I am having an issue with the offline files feature. I am running Vista 64
bit business edition on my laptop, and server 2003 on the server. We have
active directory configured to automatically redirect the my documents folder
to another server on our domain. I am able to work with my documents when I
am online, but as soon as I try to work offline I have issues. I am able to
see all of my files and folders, but as soon as I try to open them I get an
error that says they are unavailable. The only way I can work on my files
offline is by running a virtual pc with xp pro. This however, is rather
inconvenient and will not be acceptable if we decide to roll out xp to the
rest of our users.


Scott, forgive me if you already know some of this, but thought I'd mention
it in case it helps. You said there is a policy to redirect My Documents to a
server within the domain, but that's only half of the process. Is there also
a policy in effect making that location Always Available Offline, and if not,
did you manually enable the option by right-clicking the folder from within
Vista? You should see a green sync overlay icon on those files while online
if they've been marked appropriately. Have you tried manually initiating a
sync via the sync center -- any errors? Finally, if they're using
auto-caching on the domain server share and you haven't marked the files as
Always Available Offline, you have to open the file once while online before
it will be available offline. Due to the problems mentioned in this thread
though, I wouldn't recommend working with an auto-caching share until a fix
is released.

Shubhankar Sanyal [MSFT]

As Aarin mentions, there are two parts to redirected mydocs- the redirection
and the offline availablity. However it is my understanding that setting the
policy for redirection also means that the files will be available offline
(unless you set an exception via policy.)
In any case, it would be helpful to know whether or not you see the green
icon overlay icon over your mydocs. The other way to get at the same
information would be to look at the "offline availability" explorer
property. On your client,
in explorer, highlight your mydocs folder and something inside there, and
let me know what you see as the value for "offline availability". It should
be one of "not available", "available" or "always available"




Thank you for the reply. We currently do not have the policy setting for
offline files set, as we do not want all our computers to have these files
available offline. I have manually enabled the offline files option, and the
files do syncronize and show that they are always available offline. Even if
I have just opened the document online, and closed it after making changes,
then try opening the document offline it will tell me that it is not

Shubhankar Sanyal [MSFT]

Could you let me know the results from my instructions in my previous mail?
I'd also be interested in knowing what the offline availability status is
immediately before you go offline.
Also let me know if you have encrypted your offline files.




I am able to see the green arrows over my documents folder and all
subsequent files. All folders inside my documents folder show up as "Always
Available", the files however show up as "Not Available". When I right click
to make available offline the option is already checked but greyed out. It
may be that we have a group policy configured incorrectly, but as of yet I
have not been able to find it.


Shubhankar Sanyal [MSFT]

It sounds like the group policy has kicked in (and hence the greyed out
option.) It is strange that your files are not available though. Also please
let me know the "offline status" for the items in question when the computer
is connected to the network.
Can you try a manual sync (rt click->sync) and see if any errors show up in
sync center?



I have a BSB2k3 server using my documents redirection. I'm also
redirecting each users desktops since I was unable to keep the users
from saving folders on their desktops. The system has been working
very well for me w/ XP SP2 clients. The company president got a new
laptop with Vista Biz on it. The Vista Laptop seemed to be working
properly, when he logged in, his desktop and my document folder showed
up and had the green sync icons on them. When you right click on a
file they would have the always available option checked. To make
sure the documents were synced, he ran a manual sync and it completes
without any error, but when you remove the laptop from the network,
the files grey out and show as having a size on 0 bytes. I was very
dissapointed with this large problem with vista. I view offline files
as a major feature that worked effectively in XP, it is sad to see MS
not able to make it work with Vista.


I'll post this as this subject as well, because it looks like it's more
popular subject here. Renaming solution, or giving access to Everyone,
mentioned above, is not for me. First, because I have 600 files like that,
second, because it's redirected My Documents deep in DFS tree.


I also have the very same problem, only that my situation is a little

I have a DFS folder share.


And my group policy is set to redirect my documents to

So actually my My Documents folder is now in

And the permissions have been automatically granted to me and to SYSTEM

And Offline files is telling Access Denied to several folders only
\\\files\personal\username\mydocuments\infolder1\folder1 and

How about that complexity, Mr. Shubhankar?

Do you know, maybe there's a fix already, no more a workaround from


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question