New hitachi Deskstar on old AMIBIOS v 1.18 for an ASUS K7M mainboard: setup?


M

Maccroche

Hello, I have a new hard disk 250 GB hitachi Deskstar T7K250:
HDT722525DLAT80 250.06 GB
on an old AMIBIOS v 1.18 for an ASUS K7M mainboard

How to set up this new hard disk?
I need to set up it in the BIOS providing the following info:
Cylinders (max value accepted: 65535)
Heads (max value accepted: 255 )
Write precomp
Sectors (max value accepted: 255)
The maximun capacity is calculated automatically.

But it is not possible to enter the values given by Hitachi: see
below...

The question is: what are the values to enter to define an "user"
configuration???
Using the function "auto" in the BIOS, only 128 GB are recognized...

PS: the bios version is the folowing
ftp://dlsvr02.asus.com/pub/ASUS/beta/mb/bios/km132.zip

The Hitachi documentation d7k250P_spv1.8.pdf gives the following data:
Sectors per track: 630-1296
Data sectors per cylinder: 2520-5184
Logical layout
Number of heads: 16
Number of Sectors per track: 63
number of cylinders: 16,383
Number of sectors: 488,397,168

Total logical data bytes: 250,059,350,016
 
Ad

Advertisements

P

paulmd

Maccroche said:
Hello, I have a new hard disk 250 GB hitachi Deskstar T7K250:
HDT722525DLAT80 250.06 GB
on an old AMIBIOS v 1.18 for an ASUS K7M mainboard
How to set up this new hard disk?
I need to set up it in the BIOS providing the following info:
Cylinders (max value accepted: 65535)
Heads (max value accepted: 255 )
Write precomp
Sectors (max value accepted: 255)
The maximun capacity is calculated automatically.

But it is not possible to enter the values given by Hitachi: see
below...

The question is: what are the values to enter to define an "user"
configuration???
Using the function "auto" in the BIOS, only 128 GB are recognized...

PS: the bios version is the folowing
ftp://dlsvr02.asus.com/pub/ASUS/beta/mb/bios/km132.zip


Latest beta bios, then there is no upgrade to get the 48-bit lba you
need for your drive. Therefor, get a promise hdd controller.

http://www.promise.com/product/product_detail_eng.asp?segment=undefined&product_id=87

FWIW, XP with Sp2 does not seem to care about the bios limits.
 
P

paulmd

Maccroche said:
Hello, I have a new hard disk 250 GB hitachi Deskstar T7K250:
HDT722525DLAT80 250.06 GB
on an old AMIBIOS v 1.18 for an ASUS K7M mainboard
How to set up this new hard disk?
I need to set up it in the BIOS providing the following info:
Cylinders (max value accepted: 65535)
Heads (max value accepted: 255 )
Write precomp
Sectors (max value accepted: 255)
The maximun capacity is calculated automatically.

But it is not possible to enter the values given by Hitachi: see
below...

The question is: what are the values to enter to define an "user"
configuration???
Using the function "auto" in the BIOS, only 128 GB are recognized...

PS: the bios version is the folowing
ftp://dlsvr02.asus.com/pub/ASUS/beta/mb/bios/km132.zip


Latest beta bios, then there is no upgrade to get the 48-bit lba you
need for your drive. Therefor, get a promise hdd controller.

http://www.promise.com/product/product_detail_eng.asp?segment=undefined&product_id=87

FWIW, XP with Sp2 does not seem to care about the bios limits.
 
R

Rod Speed

Maccroche said:
I have a new hard disk 250 GB hitachi Deskstar T7K250:
HDT722525DLAT80 250.06 GB
on an old AMIBIOS v 1.18 for an ASUS K7M mainboard
How to set up this new hard disk?
I need to set up it in the BIOS providing the following info:
Cylinders (max value accepted: 65535)
Heads (max value accepted: 255 )
Write precomp
Sectors (max value accepted: 255)
The maximun capacity is calculated automatically.
But it is not possible to enter the values given by Hitachi: see below...

You should just use an AUTO drive type in any modern system.
The question is: what are the values to enter to define an "user" configuration???
Using the function "auto" in the BIOS, only 128 GB are recognized...

You cant fix that by using explicit values.
PS: the bios version is the folowing
ftp://dlsvr02.asus.com/pub/ASUS/beta/mb/bios/km132.zip

I'd try that, it likely does have support for drives over 132GB, even tho the FAQ doesnt say that.
You'll also need SP1 or better with XP too.
The Hitachi documentation d7k250P_spv1.8.pdf gives the following data:
Sectors per track: 630-1296
Data sectors per cylinder: 2520-5184
Logical layout
Number of heads: 16
Number of Sectors per track: 63
number of cylinders: 16,383
Number of sectors: 488,397,168

Thats all irrelevant to what you should do.
 
T

tcsenter

Maccroche said:
Hello, I have a new hard disk 250 GB hitachi Deskstar T7K250:
HDT722525DLAT80 250.06 GB
on an old AMIBIOS v 1.18 for an ASUS K7M mainboard


K7M with VIA 686A Southbridge cannot support 48-bit LBA. On the
integrated controller, you are limited to hard drives smaller than
~127GB.

Regards,

Tim
 
R

Rod Speed

(e-mail address removed) wrote
Maccroche wrote:
K7M with VIA 686A Southbridge cannot support 48-bit LBA. On the
integrated controller, you are limited to hard drives smaller than ~127GB.

Nope, drives bigger than that will work fine at 127GB
 
Ad

Advertisements

J

JShepherd

Enable large disk support


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Parameters]
"EnableBigLba"=dword:00000001
 
M

Maccroche

JShepherd said:
Enable large disk support


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Parameters]
"EnableBigLba"=dword:00000001

Thank you for all your propositions.

I solved the problem and have by now the 250 GB available for windows
2000

I made it like this.

I configured the BIOS with only the parameter AUTO and didn't let the
BIOS to propose some values, otherwise it would have given the eronated
values.
--> I used an extra CD to boot on Linux and let Linux to recognize it
as a 250 GB. Let Linux format the hard disk as a 250 GB, FAT32.
---> reboot using windows 2000 and the hard disk was recognized as a
250 GB disk, without any change in the registry keys.
--> After the backups, when I do no longer use the disk, I got back
into the BIOS, set the device as "Not installed" and remove the disk to
store it in a safe place.

Conclusion --> if windows, MS is not able to make it, let's make it
using Linux...

Thank you for all your contributions.
 
Ad

Advertisements

R

Rod Speed

Maccroche said:
JShepherd said:
Enable large disk support


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Parameters]
"EnableBigLba"=dword:00000001

Thank you for all your propositions.

I solved the problem and have by now the 250 GB available for windows
2000

I made it like this.

I configured the BIOS with only the parameter AUTO and didn't let the
BIOS to propose some values, otherwise it would have given the
eronated values.
--> I used an extra CD to boot on Linux and let Linux to recognize it
as a 250 GB. Let Linux format the hard disk as a 250 GB, FAT32.
---> reboot using windows 2000 and the hard disk was recognized as a
250 GB disk, without any change in the registry keys.
--> After the backups, when I do no longer use the disk, I got back
into the BIOS, set the device as "Not installed" and remove the disk
to store it in a safe place.

Its important to add 48 bit LBA support in 2K and do that EnableBigLBA
above if you ever do plan to write to it in 2K, otherwise it will wrap at the
137G level and stomp on the data at the front of the drive.
Conclusion --> if windows, MS is not able to make it, let's make it
using Linux...

Thank you for all your contributions.

Thanks for the washup, too rare in my opinion.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top