Network Connections


G

Guest

I have a home network that has a Vista laptop, a Windows 2000 desktop and a
desktop that I just upgraded from XP Home to Vista Home Premium, which would
be considered the "server" of the workgroup. The newly upgraded Vista
desktop is connected via wire to the DLink wireless router. The other two
machines connect wirelessly. In XP Home, once logged onto one of the network
computers, I could connect to any other machine in the workgroup without
being prompted for credentials, whether or not someone was logged on and
using that computer. Since upgrading the main desktop to Vista, I am prompted
for logon credentials when I try to access the Windows 2000 computer in the
workgroup if a user is logged on to that computer. When I try to log on, if
someone is on that machine, my logon credentials are rejected and I can't get
to shared files on the machine. If no one is on the machine, I can log on and
access the shared resources. I saw another thread about removing the
password for printer and file sharing, but I forget where to find the option
to turn off the password. Please refresh my ailing memory : ) I'm wondering
if removing the password option from file and printer sharing on the main
desktop will enable me to access the other machines as before. Any thoughts?
 
Ad

Advertisements

R

Robert L [MVP - Networking]

It is network an sharing center. Go to start>network or control panel, you will be able to access network an sharing center.

Bob Lin, MS-MVP, MCSE & CNE
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
I have a home network that has a Vista laptop, a Windows 2000 desktop and a
desktop that I just upgraded from XP Home to Vista Home Premium, which would
be considered the "server" of the workgroup. The newly upgraded Vista
desktop is connected via wire to the DLink wireless router. The other two
machines connect wirelessly. In XP Home, once logged onto one of the network
computers, I could connect to any other machine in the workgroup without
being prompted for credentials, whether or not someone was logged on and
using that computer. Since upgrading the main desktop to Vista, I am prompted
for logon credentials when I try to access the Windows 2000 computer in the
workgroup if a user is logged on to that computer. When I try to log on, if
someone is on that machine, my logon credentials are rejected and I can't get
to shared files on the machine. If no one is on the machine, I can log on and
access the shared resources. I saw another thread about removing the
password for printer and file sharing, but I forget where to find the option
to turn off the password. Please refresh my ailing memory : ) I'm wondering
if removing the password option from file and printer sharing on the main
desktop will enable me to access the other machines as before. Any thoughts?
 
G

Guest

Well, I turned off the password protection, and at least my son was able to
print to the printer while I was logged on to this computer- but he still
cannot access the public folder on this computer if I'm logged on, and
likewise, I can't access shared resources on his computer. We are presented
with logon screens, and when we enter our credentials, our correct usernames
and passwords, they are rejected. I have tried including the workgroup name
in my logon (e.g. workgroup\dreagan), but it doesn't work. I'm missing
something here, probably something simple : (
 
G

Guest

I found the answer to my problem. I think it's discussed several times in
other threads here. The issue turned out to be the NetBIOS problem that was
specifically associated with XP and Vista, but the same problem exists
between Windows 2000 and Vista, too. Once I set the network adapter
properties to enable NetBIOS on TCP/IP on both the Vista and the Win 2k
machine, they connected just fine with no logon screen, and we all can access
shared files on all networked computers, whether someone is logged on or not.
Problem solved!
 
W

...winston

Have you followed the advice in this Msft article ?
http://www.microsoft.com/technet/network/evaluate/vista_fp.mspx
- Particular attention to common users names on both machines or the
optional use of the Guest account. Password protection can be enabled or
disabled with either approach. Note: If you wish Password Protection and
choose the Guest account approach, enable Password protection last(i.e. add
the Guest account in File Sharing, then enable password protection in the
Network and Sharing Center)

With a wireless access point router in place and machine with wireless
access, ensure the router and all wireless pcs and devices support and use
the same encryption(e.g. wpa2/psk) and are setup with the same encryption
passkey.

..winston
 
R

Robert L [MVP - Networking]

Thank you for the update.

Bob Lin, MS-MVP, MCSE & CNE
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
I found the answer to my problem. I think it's discussed several times in
other threads here. The issue turned out to be the NetBIOS problem that was
specifically associated with XP and Vista, but the same problem exists
between Windows 2000 and Vista, too. Once I set the network adapter
properties to enable NetBIOS on TCP/IP on both the Vista and the Win 2k
machine, they connected just fine with no logon screen, and we all can access
shared files on all networked computers, whether someone is logged on or not.
Problem solved!
 
Ad

Advertisements

G

Guest

Thanks for the link. I pretty much discoverd most of this on my own. the main
issue, as noted above, turned out to be the need to enable NetBIOS on TCP/IP
on all connected units.

D.
 
G

Guest

Hi Dawn,

Could you be more specific about how you changed the settings? Was it
related to the firewall also?
 
G

Guest

Hi Dawn,

Can you be more specific with how you did this in Vista? I've forgotten a
lot of this since everything worked before.

I tried the Network Magic suggested by others which was still a no go.

Thanks!
 
G

Guest

Ok, let's see... In Vista I went to Network/Network and Sharing Center. On
the left side I chose Manage Network Connections which brought up my network
adapter. I right clicked it and chose Properties. In the Properties box I
highlighted Internet Protocol Version 4 and hit Properties. In that box I
went to Advanced. Once there I went to the WINS tab and selected the radio
button to Enable NetBIOS over TCP/IP- NOT the automatic setting! I followed a
similar procedure in Windows 2000 where I went into the network adapter
properties, chose TCP/IP properties/advanced/WINS, and then made the same
change. All worked after that.
 
Ad

Advertisements

G

Guest

DawnR said:
Thanks for the link. I pretty much discoverd most of this on my own. the main
issue, as noted above, turned out to be the need to enable NetBIOS on TCP/IP
on all connected units.

D.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top