multiuser security on the network



I have questions about setting up a secured database for multiple
users on a network. This database will have several
groups and appropriate permissions for groups.
I have been able to set up the permissions so the users in
each group can access only the appropriate data. But I
also want to set it up so each user has to log in. I have
set up passwords for test users, put secured.mdw and this
database(they are in the same folder in a shared folder) on the
It worked fine when i tried to open this database in my computer (in a
shared folder on the network) with a prompt box and i log on any user
i created previously. (ex: poweradmin, steve, ann...)
i checked this in my computer whether i was using the right .mdw and
used the right one.
I did
?dbengine.systemdb ; network drive:\secured_DB
it should be this instead of the default one(c: drive),right?

1. I tried to open this secured database in steve's computer,
go to this secured_DB folder in the network drive and open with access
a prompt box wasn't displayed.

2. Whenever steve opens the secure database on the network drive, it
says that no permissions,
but that isn't true because steve have a few permissions for the
secured database.
I suspect that it has to do with the wrkgadm.exe file and .mdw file

How can i check which .mdw file steve uses for the secured database in
his computer?
In my situation, secured.mdw(above) should be used when steve tried to
open this database.
I can't even open this database and debug window for checking systemdb
since error message is displayed.
Is there a way that i can check this(?dbengine.systemdb) somewhere in

Do i have to make steve to join secured.mdw? ( also, ann and any user
i want to add)



Yes, you should see YOUR mdw file when you check the SystemDB value.

The reason why Steve's computer does not prompt for a login is because
Access is trying to log him in as "admin" with no password. By default,
Access does not open the login prompt when such an account exists in his
current mdw file.

The reason why its working on YOUR computer is because you are pointing to
an mdw file that has the "admin" account modified (i.e. password added).

Steve is probably pointing to his local System.mdw file when he attempts to
open your file. You have two options. 1) Run the workgroup administrator from
Steve's computer and have him point to secured.mdw (not recommended because
Steve's Access will permanently be connected to secured.mdw, even when
opening other mdb files, is that what you want?)

2) Create a shortcut on Steve's computer with the /wrkgrp parameter
(recommended). This will temporarily connect Steve to secured.mdw only when
using your database.

You need to do 1) or 2) on all your users' computers.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question