Migrate profile - cached mode setting


P

ph_acs

Hi,

I'm trying to configure Outlook Cached Exchange mode for all users who will
get Office 2010 installed. Let me outline the process I'm running through...

Currently the majority of users use Outlook 2007 and cached exchange mode is
disabled.

We will be deploying Office 2010 to machines in stages and wish to enable
cached exchange mode for all users who then use Outlook 2010.

However, whilst we want to enable cached exchange mode be default, we can't
set it in a GPO as we still need to allow certian users to disable this
manually (such as those users who hot-desk). The OCT that has been created
for Office 2010 is set to use the existing Outlook profile and upgrade it to
2010. We're doing this becuase we don't want 2010 to create a new profile and
then lose all of the user's customisations and shared calendar links etc.

However what we'd like to do is enable a setting in the gpo (either a reg
key preference, logon script etc.) to ensure that cached exchange mode is
enabled the first time a user logs onto a 2010 machine. If the user decides
to change this setting then their choice shall not be overwritten by policy
of script at second logon. Ideally a reg key policy preference set to run
only once would be best.

Inside the OCT it is set to enable cached exchange mode for new and existing
profiles.
So when a user logs onto a 2010 machine who doesn't have an exisitng Outlook
profile in their roaming windows profile, cached mode is enabled and works as
expected.

However when a user who has an existing profile (2007) logs on to the 2010
machine it migrates their profile (creates a 'BACKUP of profilename'..
profile too) but doesn't enable cached mode.

I've tied both enabling and disabling the 'migrate user settings' checkbox
in the OCT but neither makes a difference. From reading the help it seems
that if this option is enabled, any setting in the users previous outlook
profile would overwrite the ones defined in the OCT for their new profile.
Unticking the option doesn't make any difference though.

Any help and pointers much appreciated.

Thanks,
Phil
 
Ad

Advertisements

M

Mark Needham

I used the link as indicated by Robert to help me on this and came up with the batch file.

Like many others and as stated on howto-outlook.com, I have come accross a variety of reg key values that indicate cached mode is on.

However I have always found that if it begins with 8 it is on, if it begins with 0 it is off. (in online mode)

-------------------------------------
@echo off

:OutlookCachedMode

rem Does a query of the registry to see which Outlook Mail profile is the default one. Please note that if a user choses their profile from a drop down box then this will cause issues using this method.
for /f "tokens=2,*" %%a in ('reg query "HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles" /v "DefaultProfile" ^| findstr DefaultProfile') DO SET defoutpr=%%b

rem Does a find of the value that indicates cached mode is already on. Begins with 8 means its on. Begins with 0 mean its off (online mode)
rem If it is on it pops up a box saying so.
for /f "tokens=2,*" %%c in ('reg query "HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\%defoutpr%\13dbb0c8aa05101a9bb000aa002fc45a" /v "00036601" ^| findstr 00036601') DO SET cachstat=%%d

if /I "%cachstat:~0,1%"=="0" goto EnableCachedMode
if /I "%cachstat:~0,1%"=="8" goto CachedModeOn
goto End

:EnableCachedMode
reg add "HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\%defoutpr%\13dbb0c8aa05101a9bb000aa002fc45a" /v "00036601" /t REG_BINARY /f /d 84190000
echo MsgBox "Your Outlook profile has just been enabled for cached mode. Please expect a short delay on accessing your e-mail the next time you open Outlook. For more information please visit http://helpfullink", vbExclamation, "Cached Mode" >%windir%\temp\nowcached.vbs
start wscript %windir%\temp\nowcached.vbs
goto End

:CachedModeOn
echo MsgBox "This Outlook Profile is already in Cached Mode" >%windir%\temp\alredcached.vbs
start wscript %windir%\temp\alredcached.vbs
goto End

:End
exit
-------------------------------

Obviously the messages are really just to provide an output and don't have to be used.

Please note that adding the hex value 84190000 will turn cached mode on, with Shared folders but not public folders. (The first two tick boxes on the Outlook | E-mail Accounts | Advanced GUI)

Hope this helps someone.

Regards,

Mark Needham
Hi,

I am trying to configure Outlook Cached Exchange mode for all users who will
get Office 2010 installed. Let me outline the process I am running through...

Currently the majority of users use Outlook 2007 and cached exchange mode is
disabled.

We will be deploying Office 2010 to machines in stages and wish to enable
cached exchange mode for all users who then use Outlook 2010.

However, whilst we want to enable cached exchange mode be default, we cannot
set it in a GPO as we still need to allow certian users to disable this
manually (such as those users who hot-desk). The OCT that has been created
for Office 2010 is set to use the existing Outlook profile and upgrade it to
2010. We're doing this becuase we do not want 2010 to create a new profile and
then lose all of the user's customisations and shared calendar links etc.

However what we'd like to do is enable a setting in the gpo (either a reg
key preference, logon script etc.) to ensure that cached exchange mode is
enabled the first time a user logs onto a 2010 machine. If the user decides
to change this setting then their choice shall not be overwritten by policy
of script at second logon. Ideally a reg key policy preference set to run
only once would be best.

Inside the OCT it is set to enable cached exchange mode for new and existing
profiles.
So when a user logs onto a 2010 machine who does not have an exisitng Outlook
profile in their roaming windows profile, cached mode is enabled and works as
expected.

However when a user who has an existing profile (2007) logs on to the 2010
machine it migrates their profile (creates a 'BACKUP of profilename'..
profile too) but does not enable cached mode.

I have tied both enabling and disabling the 'migrate user settings' checkbox
in the OCT but neither makes a difference. From reading the help it seems
that if this option is enabled, any setting in the users previous outlook
profile would overwrite the ones defined in the OCT for their new profile.
Unticking the option does not make any difference though.

Any help and pointers much appreciated.

Thanks,
Phil
Submitted via EggHeadCafe - Software Developer Portal of Choice
Simple .NET HEX PixelColor Utility
http://www.eggheadcafe.com/tutorial...f52bc1/simple-net-hex-pixelcolor-utility.aspx
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top