Japanese language display problem


G

Guest

Hello Sir


My friend brough a toshiba laptop which comes with preinstalled Vista Home
premium(English).She is japanese

So i configure how to type in japanese but say she use a japanese software
we cant read.

Ex. IF she unstalled japanese yahoo messanger she cant read its like Yahoo
???? something...

I cant figure out what to do.I went to language option etc but there is no
display language.

How can i make it read japanese ? can i installed it again and installed
in japanese language is it possible ?

I work in IT but this one i cant figure out...



Please help....



Jayant
 
Ad

Advertisements

A

Andre Da Costa[ActiveWin]

My suggestion would be to get a localized Japanese version of Vista Home
Premium or upgrade to Windows Vista Ultimate Edition which supports All
World Wide Language interfaces.
 
Ad

Advertisements

A

Andrew McLaren

jayant pande said:
So i configure how to type in japanese but say she use a japanese software
we cant read.
Ex. IF she unstalled japanese yahoo messanger she cant read its like Yahoo
???? something...

Applications can display text in other langauges using several different
techniques:

- display text as use Unicode (best);
- programatically call an explicit codepage (okay)
- accept the default codepage in the System Locale (not good, but very
common)

Vista fully supports Unicode (of course); so nothing needs to be done to
configure Vista for Unicode apps. If text displays incorrectly, you can
assume it is non-Unicode text.

On an English language copy of Vista, the default system locale is English
(codepage 1252, I think). The Japanese codepage in 932. If an application
uses the default English system codepage to display Japanese data, the text
will appear scramabled. If the application specifically requested a Japanese
codepage, it would display correctly, even on English language Vista. The
file C:\Windows\System32\c_932.nls is the codepage support file for
Japanese.

So, you may need to change the default non-Unicode language to Japanese. On
Vista Home edition, do this:

Go to Control Panel, Regional and Language Options.

Click on the Administrative tab.

In the "Language for non-Unicode programs box, press the button "Change
System Locale".

In the System Locale drop down box, choose "Japanese (Japan").

You may need to log out and log back in again, for the change to take
effect.

After this change is made, non-Unicode text which doesn't request an
explicit codepage (ie, which takes the default codepage) will display data
in Japanese, rather than English.

If that doesn't fix the problem, then I regret I don't know. Maybe your
friend will need to buy a Japanese-language Vista.

Hope this helps a bit.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top