IT WORKED FOR ME!!! THANK YOU


J

Javier Robles

After two days of trying net sh commands and reinstalling and uninstalling antivirus and personal firewalls, disabling services and even trying to test telnet to 443 ok and telnet to 80 without success, it did work for me this app from Check Point.


THANK YOU!
http://download.zonealarm.com/bin/free/support/cpes_clean.exe

When I run connection diagnostics in IE (Windows XP Pro)
it reports FTP OK, HTTPS - OK, but could not make HTTP connection

Only one computer of three on my adhoc workgroup reports this error.
It reports this error for both wired and wireless connections that are
otherwise available.
Sure enough, I can connect to email, newsgroups, and FTP and websites via
HTTPS.... only HTTP won't work.

What's the problem and how do I fix it?
Open a Run command and type in:
regedit.exe click [OK] locate this Key, does the value exist on it?.
[-]HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\URL\Prefixes =
ftp"="ftp://"
"gopher"="gopher://"
"home"="http://"
"mosaic"="http://"
"www"="http://

= ... First, try to clean up your caches, Internet files and delete cookies
by doing this:
Click Start >> Control Panel >> Double click Network and Internet
Connections >> Double click Internet Options.
On the IE properties windows you will see these Taps:
General | Security | Privacy | Content | Connections | Programs |
Advanced
Under General Tab clear your History, Internet Files and Cookies.
Then click on Advanced tab and scroll down to under the Browsing Option:
[&] Browsing
[ ] Enable Third-Party browser extensions (Req Rest) uncheck this box.

[&] HTTP 1.1 Settings
[ ] Use HTTP 1.1 ,= Make sure this checked
[ ] Use HTTP 1.1 through proxy connections
If you using proxy check the proxy one if not check only the first one.

Then under Security Option:
[&] Security
[ ] Use SSL 2.0
[ ] Use SSL 3.0
[ ] Use STL 1.0
Then click on Programs Tab and click Manage Add-Ons and Disable all non
Verified Add-Ons (You should Renable them later one-by-one and see the
culprit and update it or remove it.

Then download this software and update it then run a scan for malware:
http://www.lavasoft.com/products/ad-aware_se_personal.php

= Then Open a run command and type in these DLLs to re-register them:
regsvr32 SOFTPUB.DLL
regsvr32 Wintrust.dll
regsvr32 Mssip32.dll
regsvr32 Initpki.dll
regsvr32 Msjava.dll
regsvr32 Gpkcsp.dll
regsvr32 Sccbase.dll
regsvr32 Slbcsp.dll
regsvr32 Urlmon.dll
regsvr32 Cryptdlg.dll
regsvr32 Dssenh.dll
regsvr32 Rsaenh.dll
Note you can copy the above and paste in a Notepad and Save As on the
Desktop reg.bat file then you can open a run command and type in:
C:\reg.bat click [OK] and then Yes.
Again on the Run command type in:
ipconfig /flushdns click [OK]
ipconfig /renew click [OK]
netsh winsock reset click [OK]
Reboot your machine and see if you can access any website/link easily and
without the cannot connect error message.

= Open the Windows
Explorer and locate this path:
C:\Windows\System32\drivers\etc = look in the Right Pane/window for this
file called the HOSTS file but not the one with the extension *.SAM* leave
this as is.
If you can't see it try to click Tools >> Folder Options and select show
Hidden files and folder, then right Click the Hosts file and select open with
Notepad.
There see any reference for that site and remove it, you Hosts file will
looks like this:
127.0.0.1 LocalHost
------------------------------------------
Remove all other References other than those above.
You can also try to assign the web address in the trusted zone on the IE
properties.

=> Before we go further are you connecting by Router or Modem, in either try
to
Power or unplug the Power cord for the Router/Modem for about 40 seconds or
so be generous with it <g> turn the computer OFF and wait for the time to go
by!!.
Then Turn the Router/Modem ON and wait a minute or so then Power ON the
computer and try to establish a connection and try the link, does it work?.

If still then continue the heavy work:
Open windows Explorer and locate the Hosts file and Rename it to Hosts.OLD
Reboot the machine and try, does it work.

If not try this:
search for them by this name *index.dat* and you can delete them
then the on reboot the system will recreate them for you.
Some of them here:
C:\Documents and settings\Administrator\Cookies = index
C:\Documents and Settings\User\Cookies = index
C:\Documents and settings\User\User data = index
C:\Windows\Temp\Cookies =index
C:\Windows\Temp\History = index
C:\Windows\Temp\Temporary Internet Files\Content.IE5 = Index.dat
Reboot your machine and see if this helped.
Check your connection (TCP/IP setting) are set correct.

http://www.microsoft.com/communitie...45fb3ead8e70&lang=en&cr=US&sloc=en-us&m=1&p=1
HTH.
Let us know.
nass
===
www.nasstec.co.uk
22:01 -0700, Raymon <[email protected]>
wrote:


Raymon,

One of the things tried above was the native Winsock reset. Our experience here
has been that several different tools, each with its own different ability to
reset a problem, can be necessary to fix LSP / Winsock. If you've just un
installed a security product like the EZTrust suite, this is definitely a
possibility.
<http://nitecruzr.blogspot.com/2005/05/problems-with-lsp-winsock-layer-in.html>
http://nitecruzr.blogspot.com/2005/05/problems-with-lsp-winsock-layer-in.html

And look at the LSP enumeration process too, if corruption isn't the problem.
This will give you a hope of identifying the port 80 block.

--
Cheers,
Chuck, MS-MVP 2005-2007 [Windows - Networking]
http://nitecruzr.blogspot.com/
Paranoia is not a problem, when it's a normal response from experience.
My email is AT DOT
actual address pchuck mvps org.
56:00 -0700, Raymon <[email protected]>
wrote:



OK, you tried the native Winsock reset ("netsh winsock reset"), and you tried
LSPFix. Did you try WinsockXPFix? The Cerelli registry key reload? Reset
TCP/IP?

How many HTTP hosts did you try, that didn't work? How many HTTPS hosts that
did? Did you try to access any hosts by IP address?
<http://nitecruzr.blogspot.com/2006/05/identifying-dns-problem-in-your.html>
http://nitecruzr.blogspot.com/2006/05/identifying-dns-problem-in-your.html

Did you check your MTU?
<http://nitecruzr.blogspot.com/2007/06/determining-mtu-to-single-server.html>
http://nitecruzr.blogspot.com/2007/06/determining-mtu-to-single-server.html

--
Cheers,
Chuck, MS-MVP 2005-2007 [Windows - Networking]
http://nitecruzr.blogspot.com/
Paranoia is not a problem, when it's a normal response from experience.
My email is AT DOT
actual address pchuck mvps org.
I can connect over the Internet using FTP and HTTPS, but not HTTP. (I haven't tried email yet because I want to leave my emails on the server for now.)



[My problem started when I (eventually!) got my PC working again after accidentally installing an old Beta upgrade to Microsoft .NET Framework. That locked up my PC every time I rebooted it, and I eventually fixed it by completely removing .NET Framework, but that left me with the HTTP problem.]



Internet Explorer's "Diagnose Connection Problems" tool (available when it fails to load a web page) eventually led me to the discovery that it was just HTTP that was affected, and that FTP and HTTPS were fine.



I *might* be able to fix the problem by rebooting my PC, but I'd rather find the real cause.



-Les.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top