"Invalid directory on URL" launching no-touch smart client from UR



The following error appears after clicking a hyperlink from an .aspx page to
launch the .exe is:

Unhandled Exception: System.ArgumentException: Invalid directory on URL.

1. App is a .NET Framework 1.1 SP1 WindowsForms application.

2. App gets data via web-service.

3. Windows Server 2003 hosts both the .exe files and the web-service.

4. The web-service uses impersonation using a domain user.

5. The app has a config file for which downloading of config files has been
enabled in web.confg.

6. I can reach the config file from a client browser by fully typing the URL.

7. I can reach the web service from a client browser (Windows XP) by fully
typing the URL.

8. If, on the web-server machine, I launch the app from the file system
directly, works.

9. I get the same error when attempting to launch via URL on both a client
machine and from a browser on the web-server machine.

10. I have configured a web-service extension in IIS for the .exe. This
solved a 404.2 error but left me with the error I am discussing here.

11. I have configured a web-service extension for the web-service supplying
the .exe with data. No effect.

12. The app has four files - 1 .exe, 2 .dll, 1 .config. All four of these
files have been allowed in Web Service Extensions.

13. The .exe is a C# managed executable. The two .dll are
AxInterop.SHDocVw.dll, Interop.SHDocVw.dll. I'm using a web browser control
on the client to display some HTML, that what the interop is for. Thought
maybe this actually might be creating some problems related to browser
ActiveX settings, but not sure.

14. I've run caspol on the client machine giving Full Trust to the .exe.

15. The virtual directory pointing to the .exe is configured as an
application in IIS. The application is configured for "Scripts and

16. I have added permissions using Full Control, the domain user being used
for impersontation of the web service to the .exe file system dir. No effect.
Note that this impersontation user works perfectly for another smart client
app we have deployed.

17. I have tried enabling 'Directory Browsing' for the virtual directory. No

18. I have tried enabling 'Parent Paths' in the virtual directory's
application config. No effect.

I've looked online and definitely found some info regarding this issue, but
nothing conclusive. Have this bad feeling it's something small I've missed,
but I'm currently at a loss. Thanks.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question