Installing CF 2.0 in an XDA


K

Kevin.dhb

My company has over 100 XDA's (XDA 1 aka QTEK 1010, O2 XDA, wallaby
....). The processor is a SA1110, which should support ARMV4
instructions. We have a MSMQ development underway which required
Compact Framework 2.0. Unfortunately, we cannot successfully install
the Cf on the devices.

The error we get when installing the CAB is "Microsoft .NET CF 2.0
failed to install on your device because the installation file is not
intended for this version of the device". The CAB file
NETCFv2.ppc.armv4.cab from "C:\Program Files\Microsoft Visual Studio
8\SmartDevices\SDK\CompactFramework\2.0\v2.0\WindowsCE\wce400\armv4"
was copied to the device using ActiveSync and executed on the device
from the file manager.

The XDA is currently running PocketPC 2003 (not SE), V 4.20.0 (build
13252). We have also tried Windows Mobile 2003 SE. Our problem is
there is only one CAB for the WCE4xx devices. We have also tried
delivering the framework through the desktop installer
NETCFSetupv2.msi, which gives a similar error.

Please note we are not attempting to install the framework on PPC 2002
as this is clearly not supported. The test devices have been upgraded
in house.

Any assistance or suggestions appreciated.
 
Ad

Advertisements

I

Ilya Tumanov [MS]

It's a bug in the OS image. Please see this:
http://blogs.msdn.com/netcfteam/archive/2005/10/11/479793.aspx

I've same device with newer image and NETCF installs just fine. You can
check with manufacturer if update is available.


Best regards,


Ilya

This posting is provided "AS IS" with no warranties, and confers no rights.

*** Want to find answers instantly? Here's how... ***

1. Go to
http://groups-beta.google.com/group/microsoft.public.dotnet.framework.compactframework?hl=en
2. Type your question in the text box near "Search this group" button.
3. Hit "Search this group" button.
4. Read answer(s).
 
K

Kevin.dhb

Please can you post the PDA ROM version that you have been successful
with. This is good news indeed!
 
Ad

Advertisements

K

Kevin.dhb

The ROMs are avilable at http://www.romkitchen.de/ You need the WM2003
SE. The WM 2003 final does not support CF2.0.

All care, not responsibility ... but it works. We will notify
Microsoft of our intention to use the ROM before rollout and offer any
licenses that are required.

Regards,
Kevin Holland.
 
S

Sachin Palewar

Ilya what are your views on using ROMs from romkitchen? Should I try
that? What do you advise?

Kevin, Thanks for that wonderful site link, its very interesting site.
I have a MDA with ROM version of 4.01.16 ENG, but rom creator needs
some older versoin of ROM it seems. What do you advise me? Do you think
by using these ROMs I can convert my PPC to 2003 SE. I mean with
orientation support too? That will indeed be wonderful.

Waiting for your thoughts,

Sachin Palewar
www.palewar.com
 
S

Sachin Palewar

Ilya what are your views on using ROMs from romkitchen? Should I try
that? What do you advise?

Thanks,

Sachin
 
Ad

Advertisements

G

Guest

Kevin,
I've application currently running on iPAQ 4150s and XDAs using PocketPC
2003. As part of an exercise to port it on to WM5, I loaded CF2 on one of the
iPAQs. I used the same file as you did, the target device is Pocket PC
Version 4.20.0 (Build 13252) and CF2 loaded ok. The iPAQs have PXA255
processors.
I'll get hold of an XDA (they're all at clients at the moment) and see if it
works on them

Martin
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top