Initialise removable storage device?


S

simonc

I have a DOS batch script which runs backups using NTBackup to a DAT160
external tape drive. The batch script uses rsm to identify the logical media
guid to pass to NTBackup. When I run this script after inserting the tape in
the tape drive it invariably fails with a mesage

"The operation was not performed because an invalid Removable Storage GUID
was specified."

If I run the script again immediately, without changing anything, it runs
correctly. I've also noticed that if I open the rsm user interface in
Computer Manage before running the backup script the script will run
correctly first time, although in the rsm user interface it often takes
several seconds before the tape drive with the loaded tape shows up in the
media list.

It's as if something in rsm needs to be initialised before the backup script
will recognise the tape. Can anyone suggest how I could adapt my DOS script
to set up rsm before running NTBackup so that it will run first time without
failing?

Grateful for advice.
 
Ad

Advertisements

3

3c273

I don't know what commands you are using in your batch file, but perhaps a
pause somewhere in your batch file will give it time to initialize before
calling ntbackup. (Ping -n 60 localhost) Otherwise, if you don't find any
other solution, you could always schedule the script to run twice since it
works the second time you run it.
Louis
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top