IDE devices, searching for


B

Bob T

Whenever I change the place of an already recognized
drive, be it on the Primary or Secondary, Master/Slave,
IDE channel, the POST seems to loose it or them.

My BIOS is the latest & two years newer than any of the
IDE/ATAPI devices. The BIOS on AUTO, finds them
immediately. But coming out of BIOS setup and into the
full POST, it goes into a 15 second search before locating
them.

I tried pulling the power, disconnecting the IDE cables,
removing the device drivers from the CP, flashing the
BIOS, clearing the CMOS, changing channels for the
devices, but nothing worked.

I again, physically removed all the devices, connection &
power, took them out of the W2K Hardware, reflashed the
BIOS, reinstalled HDD0, but still the same thing.

Completely frustrated, I put the CMOS "clear" jumper on
overnight, and thenext morning, HDD0 was found, with no
wait.--just as it should have been.

I assumed that I could now add devices as if they were new.

I added HDD1--no probelm.
Added my CD-RW to the Secondary Master--no problem.
Added my CD-ROM to the Secondary/Slave (it's original
position on the cable)--

POST lost the drives again.

The only difference was that this time the CD drives, I
thought, would have had different letter names--but they
were retained.

So one problem, loosing the HDD--somehow--corrected itself
but now the Secondary Channel is messed up.

I tried taking off the CD-RW and leaving just the CD-ROM,
then doing the opposite--no problem. But when both drives
are installed on the same cable, POST looses them although
the BIOS sees them.

I clearing the CMOS, but still no go.

I know W2K & XP don't like to have the IDE devices and
cable positions changed--I think there is a reserved part
of the BIOS where W2K or XP writes to for keeping track of
drives. Could this be the problem?

In the MS KB, # 328624 it talks about taking time to
locate IDE/ATAPI devices, but give no solution,
workaround, or anything other than stating the
problem. I've never seen a KB that just said this has
been observed and leave it at that.

Is it a bug? How do I fix it? BIOS see the devices, but
W2K has done something somewhere to make the POST loose
them.

Surely there must be a way to add devices, without POST
having to do a search for them after the BIOS has found
them?

I don't know what more to try or do? What is W2K doing?

Bob
 
R

Rick

Bob T said:
I know W2K & XP don't like to have the IDE devices and
cable positions changed--I think there is a reserved part
of the BIOS where W2K or XP writes to for keeping track of
drives. Could this be the problem?
Yes, it's known as ECSD. When you make a hardware change
make sure the "Force ECSD Update" or "Auto ECSD Update"
option is enabled in your system bios. This will force Windows
to reassign resources based on the new configuration.

It also might be a good idea to set any unused IDE devices in
your system bios to "NONE" instead of "AUTO", and match
these settings with the IDE channels setup in Device Manager.

Rick
 
Ad

Advertisements

B

Bob T.

-----Original Message-----
[..]
I know W2K & XP don't like to have the IDE devices and
cable positions changed--I think there is a reserved part
of the BIOS where W2K or XP writes to for keeping track of
drives. Could this be the problem?
Yes, it's known as ECSD. When you make a hardware change
make sure the "Force ECSD Update" or "Auto ECSD Update"
option is enabled in your system bios. This will force Windows
to reassign resources based on the new configuration.

It also might be a good idea to set any unused IDE devices in
your system bios to "NONE" instead of "AUTO", and match
these settings with the IDE channels setup in Device Manager.
-----Original Message-----
[..]
I know W2K & XP don't like to have the IDE devices and
cable positions changed--I think there is a reserved part
of the BIOS where W2K or XP writes to for keeping track of
drives. Could this be the problem?
Yes, it's known as ECSD. When you make a hardware change
make sure the "Force ECSD Update" or "Auto ECSD Update"
option is enabled in your system bios. This will force Windows
to reassign resources based on the new configuration.

It also might be a good idea to set any unused IDE devices in
your system bios to "NONE" instead of "AUTO", and match
these settings with the IDE channels setup in Device Manager.

Rick



.
Thanks Rick,

I thought it's something like that.

The only ECSD "enable" setting I can find in my Award BIOS
says it is to be used only if the system will not boot.

I've been disregarding that and enabling it anyway, saving
it to CMOS, then rebooting, then clearing the CMOS to make
sure it's the only info there.

Am I maybe not supposed to clear it? Could that be
erasing what the new ECDS has put into the CMOS?

I know that after a BIOS flash you clear the CMOS, but
could that be messing it up in this case?

If I am supposed to clear it, when is the right time to do
it? As soon as the CMOS is saved and before W2K
initializes or let W2K load, shutdown, clear CMOS, return
the ECDS to disable and reboot?

Whatever I'm doing isn't working.


Perhaps the BIOS has gotten messed up and I need to flash
it? --don't like to do that.

I'm using all 4 of my IDE channels, with all my HDD on
Primary and Opticals on the Secondary.

I'm thinking of moving the Secondary Cable to the Primary
slot and see if, with the ECSD enabled, that gives W2K
enough of a headache to force it to reassign the devices.
Or maybe I should flash the BIOS first?

More than having to wait a long time for the IDE devices
to be found, I hate getting a "unable to verify DMI pool"
error. Those are horrendous to figure out--and I've been
getting more than I want to handle.

I still don't understand, if the BIOS on AUTO is finding
all the IDE devices immediately, why are they being lost
when the system goes into POST?

Bob
 
R

Rick

Bob T. said:
I've been disregarding that and enabling it anyway, saving
it to CMOS, then rebooting, then clearing the CMOS to make
sure it's the only info there.

Am I maybe not supposed to clear it? Could that be
erasing what the new ECDS has put into the CMOS?
Don't clear your CMOS unless you've flashed your system bios,
and even then it usually isn't necessary unless you've flashed it
to a different version.
I know that after a BIOS flash you clear the CMOS, but
could that be messing it up in this case?
Probably.

If I am supposed to clear it, when is the right time to do
it? As soon as the CMOS is saved and before W2K
initializes or let W2K load, shutdown, clear CMOS, return
the ECDS to disable and reboot?

Whatever I'm doing isn't working.


Perhaps the BIOS has gotten messed up and I need to flash
it? --don't like to do that.

I'm using all 4 of my IDE channels, with all my HDD on
Primary and Opticals on the Secondary.
The usual/proper way to configure IDE devices is to put
hard drives as masters on all channels, and CDs/DVDs/
Opticals/etc as slaves on all channels. Having two
non-hard disk devices on the same channel is not
recommended.

Rick
 
G

Guest

-----Original Message-----
-----Original Message-----
[..]
I know W2K & XP don't like to have the IDE devices and
cable positions changed--I think there is a reserved part
of the BIOS where W2K or XP writes to for keeping
track
of
drives. Could this be the problem?
Yes, it's known as ECSD. When you make a hardware change
make sure the "Force ECSD Update" or "Auto ECSD Update"
option is enabled in your system bios. This will force Windows
to reassign resources based on the new configuration.

It also might be a good idea to set any unused IDE devices in
your system bios to "NONE" instead of "AUTO", and match
these settings with the IDE channels setup in Device Manager.
-----Original Message-----
[..]
I know W2K & XP don't like to have the IDE devices and
cable positions changed--I think there is a reserved part
of the BIOS where W2K or XP writes to for keeping
track
of

Yes, it's known as ECSD. When you make a hardware change
make sure the "Force ECSD Update" or "Auto ECSD Update"
option is enabled in your system bios. This will force Windows
to reassign resources based on the new configuration.

It also might be a good idea to set any unused IDE devices in
your system bios to "NONE" instead of "AUTO", and match
these settings with the IDE channels setup in Device Manager.

Rick



.
Thanks Rick,

I thought it's something like that.

The only ECSD "enable" setting I can find in my Award BIOS
says it is to be used only if the system will not boot.

I've been disregarding that and enabling it anyway, saving
it to CMOS, then rebooting, then clearing the CMOS to make
sure it's the only info there.

Am I maybe not supposed to clear it? Could that be
erasing what the new ECDS has put into the CMOS?

I know that after a BIOS flash you clear the CMOS, but
could that be messing it up in this case?

If I am supposed to clear it, when is the right time to do
it? As soon as the CMOS is saved and before W2K
initializes or let W2K load, shutdown, clear CMOS, return
the ECDS to disable and reboot?

Whatever I'm doing isn't working.


Perhaps the BIOS has gotten messed up and I need to flash
it? --don't like to do that.

I'm using all 4 of my IDE channels, with all my HDD on
Primary and Opticals on the Secondary.

I'm thinking of moving the Secondary Cable to the Primary
slot and see if, with the ECSD enabled, that gives W2K
enough of a headache to force it to reassign the devices.
Or maybe I should flash the BIOS first?

More than having to wait a long time for the IDE devices
to be found, I hate getting a "unable to verify DMI pool"
error. Those are horrendous to figure out--and I've been
getting more than I want to handle.

I still don't understand, if the BIOS on AUTO is finding
all the IDE devices immediately, why are they being lost
when the system goes into POST?

Bob

.
I just tried again the ESDC from DOS and got the message
that resetting it was successful. I booted again from
DOS, but there was no change in the 15 secs to find the
IDE Devices. I did no clearing of the CMOS.

Since that didn't help, I "Enabled" it ESDC again and let
it continue into the W2K install, shutdown then rebooted--
still the 15 sec. wait.

I'm pretty sure we're on the right track, but I must be
missing something. --this is very frustrating. I am an
MCSE (even passed all my tests the first time) and worked
for INTEL as a software test engineer. --If someone who
is knowledgable on systems can't get it, how can the
average user?

I hope you have a few more ideas. --I'm almost ready to
get a hexeditor and go into the BIOS and see if I can
figure out what's going on, where W2K assigns the drive
settings.

Since booting from DOS doesn't change anything, W2K must
have reset something that is not normally accessed.

If we get this fixed, I need help in transferring my HDD0,
which has the boot and system files, to HDD1, making HDD1
active and using HDD0 as a backup. --but that will be
another thread--although I think it will have something to
do with the EDCS too.

That's where I got into EDCS failing and the "unable to
verify DMI pool." I think the trick there will be to get
W2K see the new drive before it sees the old drive, and
thus reasign the new drive as HDD0--unless, W2K is
actually writing HDD 0, 1, designations to the drives
first sector--then I'm going to have more trouble.

But that's later. Hope you or someone has more ideas.
I just don't understand--BIOS detects all IDE channels
correctly on AUTO, but POST looses them.

Bob
 
G

Guest

-----Original Message-----
-----Original Message-----
-----Original Message-----
[..]
I know W2K & XP don't like to have the IDE devices and
cable positions changed--I think there is a reserved part
of the BIOS where W2K or XP writes to for keeping
track
of
drives. Could this be the problem?

Yes, it's known as ECSD. When you make a hardware change
make sure the "Force ECSD Update" or "Auto ECSD Update"
option is enabled in your system bios. This will force Windows
to reassign resources based on the new configuration.

It also might be a good idea to set any unused IDE devices in
your system bios to "NONE" instead of "AUTO", and match
these settings with the IDE channels setup in Device Manager.
-----Original Message-----
[..]
I know W2K & XP don't like to have the IDE devices and
cable positions changed--I think there is a reserved part
of the BIOS where W2K or XP writes to for keeping
track
of
drives. Could this be the problem?

Yes, it's known as ECSD. When you make a hardware change
make sure the "Force ECSD Update" or "Auto ECSD Update"
option is enabled in your system bios. This will force Windows
to reassign resources based on the new configuration.

It also might be a good idea to set any unused IDE devices in
your system bios to "NONE" instead of "AUTO", and match
these settings with the IDE channels setup in Device Manager.

Rick



.
Thanks Rick,

I thought it's something like that.

The only ECSD "enable" setting I can find in my Award BIOS
says it is to be used only if the system will not boot.

I've been disregarding that and enabling it anyway, saving
it to CMOS, then rebooting, then clearing the CMOS to make
sure it's the only info there.

Am I maybe not supposed to clear it? Could that be
erasing what the new ECDS has put into the CMOS?

I know that after a BIOS flash you clear the CMOS, but
could that be messing it up in this case?

If I am supposed to clear it, when is the right time to do
it? As soon as the CMOS is saved and before W2K
initializes or let W2K load, shutdown, clear CMOS, return
the ECDS to disable and reboot?

Whatever I'm doing isn't working.


Perhaps the BIOS has gotten messed up and I need to flash
it? --don't like to do that.

I'm using all 4 of my IDE channels, with all my HDD on
Primary and Opticals on the Secondary.

I'm thinking of moving the Secondary Cable to the Primary
slot and see if, with the ECSD enabled, that gives W2K
enough of a headache to force it to reassign the devices.
Or maybe I should flash the BIOS first?

More than having to wait a long time for the IDE devices
to be found, I hate getting a "unable to verify DMI pool"
error. Those are horrendous to figure out--and I've been
getting more than I want to handle.

I still don't understand, if the BIOS on AUTO is finding
all the IDE devices immediately, why are they being lost
when the system goes into POST?

Bob

.
I just tried again the ESDC from DOS and got the message
that resetting it was successful. I booted again from
DOS, but there was no change in the 15 secs to find the
IDE Devices. I did no clearing of the CMOS.

Since that didn't help, I "Enabled" it ESDC again and let
it continue into the W2K install, shutdown then rebooted--
still the 15 sec. wait.

I'm pretty sure we're on the right track, but I must be
missing something. --this is very frustrating. I am an
MCSE (even passed all my tests the first time) and worked
for INTEL as a software test engineer. --If someone who
is knowledgable on systems can't get it, how can the
average user?

I hope you have a few more ideas. --I'm almost ready to
get a hexeditor and go into the BIOS and see if I can
figure out what's going on, where W2K assigns the drive
settings.

Since booting from DOS doesn't change anything, W2K must
have reset something that is not normally accessed.

If we get this fixed, I need help in transferring my HDD0,
which has the boot and system files, to HDD1, making HDD1
active and using HDD0 as a backup. --but that will be
another thread--although I think it will have something to
do with the EDCS too.

That's where I got into EDCS failing and the "unable to
verify DMI pool." I think the trick there will be to get
W2K see the new drive before it sees the old drive, and
thus reasign the new drive as HDD0--unless, W2K is
actually writing HDD 0, 1, designations to the drives
first sector--then I'm going to have more trouble.

But that's later. Hope you or someone has more ideas.
I just don't understand--BIOS detects all IDE channels
correctly on AUTO, but POST looses them.

Bob
.
Hey,
I read this post and two things popped to mind. First is
the type of mobo and speed of ata. ata 100? If so do you
have the correct cables for the drives, all of them. Can't
use the older grey cables for the newer types. That brings
2nd up. Maybe the second cable is bad. I just had a
similiar problem on my sons machine. Had to replace the
cable for the cds. Massive weird errors but nothing to put
a finger on. That was last recourse and it fixed it. New
mother board with ata100 or ata133 has 80 pin connectors.
Even if the drive attached is an older ata100 it needs
that special pinned cable. If it is a ata100 then that
cable is needed, etc. etc.
Luck.
 
B

Bob I

You ARE setting the drive jumpers as MASTER and SLAVE not Cable Select,
right? Use 80 conducter cable. Master on the end and Slave in the middle.

-----Original Message-----

-----Original Message-----

[..]

I know W2K & XP don't like to have the IDE devices and
cable positions changed--I think there is a reserved
part

of the BIOS where W2K or XP writes to for keeping
track
of

drives. Could this be the problem?

Yes, it's known as ECSD. When you make a hardware change
make sure the "Force ECSD Update" or "Auto ECSD Update"
option is enabled in your system bios. This will force
Windows

to reassign resources based on the new configuration.

It also might be a good idea to set any unused IDE
devices in
your system bios to "NONE" instead of "AUTO", and match
these settings with the IDE channels setup in Device
Manager.

Rick



.

-----Original Message-----

[..]

I know W2K & XP don't like to have the IDE devices and
cable positions changed--I think there is a reserved
part

of the BIOS where W2K or XP writes to for keeping
track
of

drives. Could this be the problem?

Yes, it's known as ECSD. When you make a hardware change
make sure the "Force ECSD Update" or "Auto ECSD Update"
option is enabled in your system bios. This will force
Windows

to reassign resources based on the new configuration.

It also might be a good idea to set any unused IDE
devices in
your system bios to "NONE" instead of "AUTO", and match
these settings with the IDE channels setup in Device
Manager.

Rick



.
Thanks Rick,

I thought it's something like that.

The only ECSD "enable" setting I can find in my Award
BIOS

says it is to be used only if the system will not boot.

I've been disregarding that and enabling it anyway,
saving

it to CMOS, then rebooting, then clearing the CMOS to
make

sure it's the only info there.

Am I maybe not supposed to clear it? Could that be
erasing what the new ECDS has put into the CMOS?

I know that after a BIOS flash you clear the CMOS, but
could that be messing it up in this case?

If I am supposed to clear it, when is the right time to
do

it? As soon as the CMOS is saved and before W2K
initializes or let W2K load, shutdown, clear CMOS, return
the ECDS to disable and reboot?

Whatever I'm doing isn't working.


Perhaps the BIOS has gotten messed up and I need to flash
it? --don't like to do that.

I'm using all 4 of my IDE channels, with all my HDD on
Primary and Opticals on the Secondary.

I'm thinking of moving the Secondary Cable to the Primary
slot and see if, with the ECSD enabled, that gives W2K
enough of a headache to force it to reassign the devices.
Or maybe I should flash the BIOS first?

More than having to wait a long time for the IDE devices
to be found, I hate getting a "unable to verify DMI pool"
error. Those are horrendous to figure out--and I've been
getting more than I want to handle.

I still don't understand, if the BIOS on AUTO is finding
all the IDE devices immediately, why are they being lost
when the system goes into POST?

Bob

.
I just tried again the ESDC from DOS and got the message
that resetting it was successful. I booted again from
DOS, but there was no change in the 15 secs to find the
IDE Devices. I did no clearing of the CMOS.

Since that didn't help, I "Enabled" it ESDC again and let
it continue into the W2K install, shutdown then rebooted--
still the 15 sec. wait.

I'm pretty sure we're on the right track, but I must be
missing something. --this is very frustrating. I am an
MCSE (even passed all my tests the first time) and worked
for INTEL as a software test engineer. --If someone who
is knowledgable on systems can't get it, how can the
average user?

I hope you have a few more ideas. --I'm almost ready to
get a hexeditor and go into the BIOS and see if I can
figure out what's going on, where W2K assigns the drive
settings.

Since booting from DOS doesn't change anything, W2K must
have reset something that is not normally accessed.

If we get this fixed, I need help in transferring my HDD0,
which has the boot and system files, to HDD1, making HDD1
active and using HDD0 as a backup. --but that will be
another thread--although I think it will have something to
do with the EDCS too.

That's where I got into EDCS failing and the "unable to
verify DMI pool." I think the trick there will be to get
W2K see the new drive before it sees the old drive, and
thus reasign the new drive as HDD0--unless, W2K is
actually writing HDD 0, 1, designations to the drives
first sector--then I'm going to have more trouble.

But that's later. Hope you or someone has more ideas.
I just don't understand--BIOS detects all IDE channels
correctly on AUTO, but POST looses them.

Bob
 
Ad

Advertisements

B

Bob T

-----Original Message-----
You ARE setting the drive jumpers as MASTER and SLAVE not Cable Select,
right? Use 80 conducter cable. Master on the end and
Slave in the middle.

**** Right. Everything is jumpered correctly. My mobo
doesn't support CSL. Even checked the jumpers to make
sure they were making contact. Also tried putting the
Master in the middle of the cable and the slave on the end-
-I didn't think that would do anything since it isn't CSL,
and it didn't seem to have any effect. No observed
difference, then returned it to the correct postion.

One of the things I forgot to mention was that the
Secondary Channel devices (all the opticals) were on a 40
pin cable and I switched them to an 80. I didn't think
this would have an effect. I A/Bd it and it didn't seem
to matter whether the cable was 80 or 40. What mattered
was adding the last CD to the Secondary/Slave. And now
I've learned that it doesn't matter if it is the CD-RW or
the CD-ROM.

I tried pulling everything out and booting from DOS, with
only the CDs in the system. The HDDs in the BIOS were set
for "NONE."

With that configuration, the CD's were found immediately,
whether together on the Primary or together on the
Secondary or one on each channel as Masters--then I set
them to slaves on each channel--the BIOS picked up the
differences in every case and they were found immediately,
recognized as they were jumpered.

I am still leaning to the notion that W2K has written
something into the reserved space of the BIOS that knocks
out the mapping, when the 4th device is added. But how do
I get at it?

The reason I didn't have an optical & a HDD on the same
channel is because the CDs are ATA33, while the HDDs are
at 100 and 133 (mobo only supports UDMA100).

I was under the impression that the system would slow down
to match the slowest drive on the channel and I didn't
want that to happen.

****Is this no longer the case?****

It appears that POST lossing track of the devices occurs
only when I add the finaly optical to the slave position
on channel 2.

But as I mentioned earlier the same problem happened when
I had only one HDD installed in the system, as Master on
the Primary Channel.

That was after I tried to clone my HDD0 to HDD1 and reset
HDD1 to be the active drive.

But I wasn't quick enough in powering down, before W2k saw
both HDDs, got confused with two boot partitions and
boot.ini pointing to different boot drives.

It crashed hard, with the "unable to verify DMI pool" on
power up. So I have a 120 gig HDD waiting, as soon as I
figure this one out. I was up till 4:30 a.m., still
working on this.

I'm going to try every suggestion given. I am also going
to flash the BIOS, but not clear the CMOS and see it that
helps.

Enabling the ESCD, saving it and letting the system go
into POST, it does state that the ESCD was successfuly
updated. So, at least that's good.

If after all this, it still doesn't work, I'm going to put
in different CD devices.

But that is going to mean that I will have two CD-RWs,
configured as slaves. The instructions are to have each
one be the Master on the Secondary Channel. I hope puting
them as slaves on each channel will be ok and it won't
slow down the system.

So, here I go...armed with my screwdrive, new cables, good
jumpers, new CDs and a full bottle of tranquilizers. The
challenge continues...

Bob

anonymous@discussions.microsoft.com said:
-----Original Message-----


-----Original Message-----


[..]

I know W2K & XP don't like to have the IDE devices and
cable positions changed--I think there is a reserved

part

of the BIOS where W2K or XP writes to for keeping
track

of

drives. Could this be the problem?

Yes, it's known as ECSD. When you make a hardware change
make sure the "Force ECSD Update" or "Auto ECSD Update"
option is enabled in your system bios. This will force

Windows

to reassign resources based on the new configuration.

It also might be a good idea to set any unused IDE

devices in

your system bios to "NONE" instead of "AUTO", and match
these settings with the IDE channels setup in Device

Manager.

Rick
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top