htm files on the desktop won't display the associated icon


M

Margo Guda

I am running XP SP3 pro. For some reason, saved web pages (htm and html
extension) don't display the correct icon (for my default browser) on
the desktop, but a generic icon, as when a file does not have an icon
associated with it.
I am able to start the application by doubleclicking the file, therefore
I assume that basically the file association is OK. I have tried
manually to set the file association using File Types or Always Open
With, but this does not solve the problem - or the change somehow is not
saved. This is not a very critical issue but I would like to resolve it.
Ideas would be appreciated.
Thanks in advance.

Margo Guda.
 
Ad

Advertisements

M

Margo Guda

Hello Nightowl, thanks for trying.
It took a while before I could try this, but here are the results: I
went to Ramesh Srinivasan's website and first tried the instructions.
That did not help, and in fact I had already tried correcting the icon
index in the registry.
I then tried downloading and installing the application he has there.
But when I tried to run it, my antivirus software (Avira) identified it
as a trojan. I guess I'm stuck. I have quarantined it but it cannot be
repaired. Do you think it is a false alarm?
 
N

Nightowl

Margo Guda said:
Hello Nightowl, thanks for trying.
It took a while before I could try this, but here are the results: I
went to Ramesh Srinivasan's website and first tried the instructions.
That did not help, and in fact I had already tried correcting the icon
index in the registry.
I then tried downloading and installing the application he has there.
But when I tried to run it, my antivirus software (Avira) identified it
as a trojan. I guess I'm stuck. I have quarantined it but it cannot be
repaired. Do you think it is a false alarm?

Hi Margo

When I had a similar problem, I tried manually correcting it too, and
nothing worked except Ramesh's utility.

Ramesh is a very generous, helpful Microsoft MVP and I personally would
be happy to run any file from his site, though of course you must decide
for yourself. I'd suspect your AV is giving a false alarm because the
utility writes to the registry.

Hope you do find an answer.
 
M

Margo Guda

Hi Nightowl,

I risked it & ran the thing. What happened is that now the icon for
internet explorer is displayed, and the file is associated with internet
explorer, as was explained on the website, in your post, and in the
readme. So I'm not saying I wasn't warned.
I tried to make sure at least that the file is actually opened by
mozilla Seamonkey which is my default browser. And that happens
correctly. So it's only the wrong icon now, that is displayed; is there
a way to get the seamonkey icon displayed? Shortcut icons, btw, are
displayed correctly.
 
Ad

Advertisements

R

Ramesh Srinivasan, MS-MVP

Thanks, Nightowl. Much appreciated!

Yes. It's a false-alarm by Avira, and I've requested Margo to send the
screenshot of the AV window if possible, and their database version. The
utility is packed using UPX which may cause some anti-virus tools to label
it as virus. Once I get the sufficient details, I'll follow up with Avira.
 
M

Margo Guda

Ramesh,

Here is the info on Avira.
I have also sent your file to them so they may already be aware of the
problem.

Product version 8.2.0.336 10/30/2008
Search engine 8.02.00.35 11/20/2008
Virus definition file 7.01.00.122 11/21/2008
Control Center 8.00.70.08 07/19/2008
Config Center 8.00.70.03 07/19/2008
Luke Filewalker 8.01.04.07 07/19/2008
Archive Library 7.06.00.03 01/17/2008
AntiVir Guard 8.00.01.30 10/31/2008
Filter 6.36.00.15 08/30/2006
Scheduler 8.00.00.17 10/31/2008
Updater 1.02.10.34 07/19/2008
 
M

Margo Guda

Hi Ramesh,

In the preferences, Seamonkey is already the default browser. I think it
may be a question of too many html document keys in the registry; I am
unable to change the icon that is displayed by windows explorer. (First
it was the generic icon, then after I ran your utility, it is the
internet explorer icon.) And in the registry the html document is fixed
to refer to the internet explorer icon. I don't know how to make it
point to the seamonkey icon instead. (Only editing the htmldocument key
does not do the trick).
 
N

Nightowl

Hi Margo

Sorry it only half-helped :-(

I use Firefox and after running Ramesh's utility the icons were reset to
Internet Explorer's (as you say, this is mentioned on the website). But
I was then able to go back into Tools | Folder Options | File Types to
associate .htm and .html files with Firefox, and this time the icon
correctly changed too. Previously, though the association itself changed
to Firefox, nothing would seem to get rid of that generic icon.

If going back into File Types and re-associating with Seamonkey doesn't
do it, I'm afraid I don't know what else to suggest. Perhaps Ramesh can
think of something else to try. Sorry, I do hope you find an answer.
 
M

Margo Guda

Hello Nightowl, and Ramesh, if you're still watching this thread, you
may be pleased to learn that I finally solved this problem. It must have
been something with how Seamonkey does the install. These days I am
using both version 1 and version 2, but mostly 2. It has a built-in
update option that does not completely reinstall the program; but
version 1 does not have this. Recently I updated version 1, by
installing the new version from the installer. Lo and behold! - the
desktop icons are finally properly reflecting seamonkey as the default
htm application.
Just thought I'd let you know.
 
Ad

Advertisements

Ad

Advertisements

N

Nightowl

Margo Guda said:
Hello Nightowl, and Ramesh, if you're still watching this thread, you
may be pleased to learn that I finally solved this problem. It must
have been something with how Seamonkey does the install. These days I
am using both version 1 and version 2, but mostly 2. It has a built-in
update option that does not completely reinstall the program; but
version 1 does not have this. Recently I updated version 1, by
installing the new version from the installer. Lo and behold! - the
desktop icons are finally properly reflecting seamonkey as the default
htm application.
Just thought I'd let you know.


That's great news, Margo. I'm really glad you found the answer :)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top