HELP: WINDOWS 2000 SERVER - CLIENT/SERVER NETWORK SETUP


G

Guest

CANONT ACCESS INTERNET:

I have a client/server type network consisting of 1 server (OS = Win 2000
Server) and 4 workstations/PCs (OS = Win XP Pro). The hardwired connections
are as follows:

Cable (Toshib Modem & Comcast service) -----to---- Router (Linksys WRV54G -
1 internet port and 4 LAN ports) -----to---- 1-Windows 2000 Server (Port 1)
and 3- Windows XP Professional Workstations (Port 2-4)

The server acts as a local domain server and the Workstations/PCs log on to
the server to access shared resources. I have enabled DHCP and DNS service
on the server and I have disabled the DHCP server on the Linksys router. The
settings I am using are as follows:

Windows 2000 Server:
IP = 192.168.1.1 & Subnet Mask = 255.255.255.0
DHCP IP range = 192.168.1.3 to 192.168.1.100 & Subnet Mask = 255.255.255.0
DNS IP = 192.168.1.1

PC/Workstation:
TCP/IP setting = Obtain IP addresses automatically

Router Settings:
Internet connection type = Automatic Configuration – DHCP (Do not have
Static IP form Comcast)
Gateway IP = Router’s Local IP = 192.168.1.2 & Subnet Mask = 255.255.255.0
DNS (under network setup) = 192.168.1.1 (IP address of Win 2000 Server)

When the workstations can log on the server and access all the resources but
cannot access the internet. Also, I cannot access the internet from the
server.

I suspect that this is a configuration problem. My knowledge of Server
Operating System (Win 2000 Server) is limited and I would highly appreciate
help from a more knowledgeable person.
 
Ad

Advertisements

K

Kurt

1) Make sure the default gateway on all computers (workstations and servers)
are pointed to 192.168.1.2.

2) On your DNS server, look at yhour forward lookup zones. If you have a
zone named ".", you have two choices.
A) Delete the "." zone. If yo do this, your DNS server will use it's
"root hints" to resolve Internet addresses.
B) Configure a forwarder. Normally this is to your ISP's DNS server. Then
your DNS server will send Inernet requests to your ISP's DNS server to
resolve Internet addresses.

....kurt
 
Ad

Advertisements

J

josepe

I think your schema is around this one:
router .... > Win2000 ..... >>> stations

If you connect the Win2000 and the station to the 4-port router the
server is not enable to sharing internet, because there is a by-pass in
the other ports.
I believe you should install a second ethernet in the box server and
connect to the dynamic IP router.
In the first ethernet -connect to the lan- you should use private
address IP, but need a switch to do this. Enable the Sharing internet in
the Win2000 box.

router .... > Win2000 ... > switch ...> stations
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top