Forms & Reports are missing


G

Guest

I have a database that is used by several members of my group. Over the last
couple of months, there have been several times that we have come in to find
that all of our forms and/or reports are missing. When it first happened, I
thought that maybe someone had accidentily deleted them. However, I later
realized that even the icons to "create form in design view" and "create form
by using wizard" were also missing and you can't delete them. Luckily, we
have backed it up so we can get them back but we need to find out what's
happening so that we can (hopefully) stop it. Any suggestions?
Thanks
 
Ad

Advertisements

A

Arvin Meyer [MVP]

Those icons can be hidden with a checkbox in Tools >>> Options >>> View >>>
New object shortcuts.

You may have someone purposely or accidentally deleting your objects, but
more likely your database is becoming corrupted because it is being shared
without being split into a front-end which runs from each user's
workstation, connected to a backend running on a server. Only data is meant
to be shared, not objects such as forms and reports. Have a look at the
reasons for splitting a database at Tony Toews website:

http://www.granite.ab.ca/access/splitapp/overview.htm
 
G

Guest

You are a genius! I don't know if this will fix the problem but I've been
trying for years to figure out how to do this. Thank you so much!
 
J

John W. Vinson

I have a database that is used by several members of my group. Over the last
couple of months, there have been several times that we have come in to find
that all of our forms and/or reports are missing. When it first happened, I
thought that maybe someone had accidentily deleted them. However, I later
realized that even the icons to "create form in design view" and "create form
by using wizard" were also missing and you can't delete them. Luckily, we
have backed it up so we can get them back but we need to find out what's
happening so that we can (hopefully) stop it. Any suggestions?
Thanks

What version of Access? I've seen A2002's Forms and Reports windows go blank,
but in all cases I can recall, just switching from the Forms window to another
window (Tables or Modules say) and back restores the image. The forms aren't
actually gone.

If this happens again - assuming you have a current backup!!! - note the size
on disk of the database and try Tools... Database Utilities... Compact and
Repair. Does this restore things, or does the size decrease dramatically?

John W. Vinson [MVP]
 
Ad

Advertisements

G

Guest

I haven't yet restored the db from a backup copy because I'm still trying to
figure out what happened. I have tried going to tables and then back and
have even closed down the db and reopened it. They still do not show up.
But thanks for the suggestion.
The DB is only 26,244 KB. Not really that large. Is it?
Thanks for the suggestion
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top