Flash drive not recognized when plugged into front USB port

Discussion in 'DIY PC' started by Ray K, Aug 14, 2009.

  1. Ray K

    Ray K Guest

    I have three flash drives that my newly built computer recognizes when
    plugged into the USB ports on the back panel of my Asus M3A76-CM mob.
    Windows Explorer correctly shows them as the L: drive and the Safely
    Remove Icon appears in the system tray.

    But when I plug them into the front, they don't work. The system tray,
    Safely Remove Icon appears, along with the right drive letter L:, but
    Windows Explorer doesn't show the device. If I try using the Safely
    Remove Icon to stop the drive, I can't do it. I end up rebooting the
    computer.

    Each front USB port is connected to the mobo by four wires: Red, Vcc,
    White, D-, Green, D+, and Black ground, in that order. I tried swapping
    the green and white leads, but then the computer shows a New Hardware
    Found message, but couldn't recognize it with these leads theoretically
    wrong.

    If I again plug the devices into the back USB port, they still work
    okay, so I haven't damaged them due to improper wiring to the front ports.

    Thanks for your suggestions.

    Ray
     
    Ray K, Aug 14, 2009
    #1
    1. Advertisements

  2. Ray K

    Ray K Guest

    I've reused the case, so both front connectors and their cables are the
    same ones that had been working right along, as USB2.0. The cables are
    round, slightly thinner than a standard #2 round pencil. The mobo manual
    warns not to use a 1394 cable to the USB connectors; doing so will
    damage the motherboard. I don't know what a 1394 cable is, but since I
    haven't damaged the mobo, I'm assuming that the cables to the front
    panel are not 1394s.
     
    Ray K, Aug 15, 2009
    #2
    1. Advertisements

  3. Here is a link showing two common methods of attaching the pins to the
    headers as not all motherboards use the same header wiring. Compare the
    instructions to your motherboard pin outs and see if it helps get things
    working for you. The wire color code info may come in handy if the
    motherboard pins don't match what the plug was initially wired for.

    http://www.directron.com/installusb.html

    The connectors on many of the front panel USB port extenders are cheaply
    made. After a couple of plug and unplug cycles the individual connectors
    within the plugs tend to loosen up and may not make a good connection on the
    motherboard header pins.

    If you are able to remove the individual plugs from the plastic you may be
    able to tighten them up a little and make a better connection. If nothing
    else was wrong and you get them working this way you can then put them back
    into the plastic plug holder. Just be sure to do the "pull" (for tightness)
    testing on the individual plugs with the motherboard power off. The same
    for when you plug them all onto the header(s) when ready for a full power
    test. They can short out very easily with the plastic plug cover removed.
     
    GlowingBlueMist, Aug 15, 2009
    #3
  4. Ray K

    Ray K Guest

    My mobo has the Intel header arrangement. Each of the two cables from
    the front panel has four separated pins at the mobo end, without a
    separate ground/shield wire.

    I've submitted the question to Asus forums.

    I don't think this applies in my case.
    Can't do this. The front connectors are in a sealed plastic housing.
     
    Ray K, Aug 16, 2009
    #4
  5. Ray K

    Ray K Guest

    From more googling around, I found the solution. In Device Manager,
    under View, click on Show Hidden Devices. Expand Universal Serial Bus
    Controllers. If any of the entries are shown in gray, right click on
    each and Uninstall it. That's it. I didn't have to reboot for the front
    ports to start working.

    I also had a category called Other, with three subentries. I also
    uninstalled them.

    Problem is, next time I rebooted, there were no more grayed USB entries
    and the Other category stayed uninstalled but the original problem of
    flash drives not being recognized returned.

    Out of curiosity, I plugged a USB external floppy drive into the front
    panel and XP immediately recognized it and assigned a: as the drive
    letter; I also transferred files to it okay. Then when I tried a flash
    drive, XP continued to recognize it, even after rebooting and even if I
    plug two in at once.

    I never thought to try transferring my USB printer from the rear port to
    the front.

    I guess the real key was getting rid of the hidden USB devices and
    trying a non-flash device in the front.

    Other advice, which I did not have to do, includes uninstalling the USB
    host controllers, rebooting, and letting Windows reinstall them. This
    will temporarily disable your USB/wireless mouse.

    Ray
     
    Ray K, Aug 21, 2009
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.