File Sharing in a Workgroup; Access Denied


Z

Zakhary

To allow "My Documents" to be shared between two computers, I set one of the
computers' (\\zm01) "My Documents" folder to be shared on the Workgroup. I
then redefine the other computer's (\\zm02) "My Documents" target to the
share name of the "My Documents" folder on \\zm01.

It recently came to me that I may want to restrict access since a few people
share this home network. So, I tried by disabling "simple sharing" and
setting permissions, but realized that \\zm02\username could not be given
permissions since a common domain doesn't exist. I then changed the share
name to include a dollar symbol ($) at the end so that it would be hidden and
went back to "simple sharing."

After I mapped that hidden folder as a network drive on \\zm02, I tried to
set the network drive as my "My Documents" target on \\zm02, but Windows
wouldn't let me. So, I changed everything back to original settings. But
then, now nothings accessible; \\zm02 isn't able to properly read from
\\zm01. I restart both computers and that seems to fix it. So, I'm now back
at square one with the shared folder being accessible by anyone on the
network and it being set as my "My Documents" target on \\zm02, EXCEPT...

1 - ON BOTH COMPUTERS several files and folders are not accessible; access
is denied. Some are PDF's or Compressed (Zipped) folders with passwords; but
Windows and accessibility shouldn't care about that.
2 - In Windows Media Player ON BOTH COMPUTERS, several files are suddenly
not able to be played. I get the message "Windows Media Player cannot access
the file. The file might be in use, you might not have access to the computer
where the file is stored, or your proxy settings might not be correct."
Interestingly, this message goes away when I am on my laptop (\\zm02) and not
connected to \\zm01 – implying access is not denied on some files if I am not
connected to \\zm01.
3 - Because of this "Access Denied" error, many files are not able to be
made available offline.

What has been tried is redefining permissions, but that doesn't matter
anymore (right?) since simple sharing is enabled again. I also did a system
restore on both computers and the problem continues. I even reset the share
settings and that also did not seem to fix the problem. Also, removing file
sharing setting did not allow me to access the files on the primary computer,
\\zm01.

So, how do I (a) fix the problems detailed above, and (b) if possible,
create a hidden or permission/password restricted shared folder on a
workgroup (NOT a domain)?

NOTE: I did notice that the initial (and returned to) share name was never
able to be unmarked for being made available offline on \\ZM02. As a result,
even when it didn't exist, the folder showed on \\zm02 without any files and
only one or two subfolders (both with no files).

Thanks many to whoever can help on this,
Zakhary
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top