fba.exe Application error

Discussion in 'Windows XP Embedded' started by tcpmeta@gmail.com, Aug 14, 2007.

  1. Guest

    I'm building a XPE system for a car (carputer) so I can have a faster
    boot time and such. Right now I have ran into a major problem. The
    instruction is at 0x02322f5d referenced memory at 0x00000004. Memory
    could not be written.

    Heres my hardware setup.
    Soyo SY-p4VGA
    1GB DDR memory (two stick of 512MB)
    20GB hard drive
    DVD-R drive

    As for the software i'm making it dual boot XP Pro and XPE. It's using
    a single partition (NTFS).

    Windows XP Pro - C:\WINDOWS
    Windows XPE - C:\build\WINDOWS

    Everything boots correctly. I'm using my main system to build the
    image then saving the image via network connection to the system
    stated above. I have the NTFS and NTFS Format components so it should
    work. I ran the dependencies check countless times and no errors or
    warnings. I have the design template set to Kiosk/Gaming Console. I've
    copied all of the hardware from what was listed in device manager from
    XP Pro as well. I'm not using any custom components, just what Target
    Designer has to offer.

    I have not tried using a FAT16/32 filesystem.
     
    , Aug 14, 2007
    #1
    1. Advertisements

  2. A little dangerous with the dual boot. Typically, you want to do dual boot
    with a seperate partition not using the same partition. Better to use
    Virtual PC if you don't have a sperate partition available.

    When do you see there error? During FBA? boot? Application start?

    --
    Regards,

    Sean Liming
    www.sjjmicro.com / www.seanliming.com
    Book Author - XP Embedded Advanced, XP Embedded Supplemental Toolkit
     
    Sean Liming \(MVP\), Aug 14, 2007
    #2
    1. Advertisements

  3. Guest

    I get the error when it's trying to install the components for the
    first time. I'm thinking to put the image on a CD then copy the files
    over to a empty hard drive with a NTFS file system then bless the boot
    kernel with the attrib -h -a -s -r command and see if it boots.
     
    , Aug 14, 2007
    #3
  4. Guest Guest

    I am geting the same error, however I am using a seperate hard drive on the
    same machine with an NTFS primary partition. I have also run the dependency
    checks numerous times and do not have any unresolved errors. The error
    appears after the FBA agent has been running for a few seconds. I can see a
    few command windows open and close in the background before the error
    appears. It seems that the FBA agent is well into its process before the
    error pops up.
     
    Guest, Aug 28, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.