Fax Service in Windows Server 2003


W

Wes Baggerly

I just installed the Fax Service in Windows Server 2003 and I get the
following errors when I open the Fax Service Manager: "Could not open a
connection to the fax service. The fax service might not be started, or the
computer name might be incorrect."

Once I click OK the console will open but there are no devices. I then try
to open the properties I get "Access denied".

A shared fax does show up in the Printers and Faxes. But when I try to
access those properties I get this message: "You do not have permissions to
complete this operation. Contact the fax administrator for more
information." I click OK and the properties open.

I have always logged on as Administrator with all of the rights. I have also
tried to fix this by installing different modems and uninstalling and
reinstalling the software many times. I have seen one other post about this
but it was a reply to an original, but I did not find any post with an
answer. Does anyone have any suggestions on how I might fix this?

Thanks in advance.
 
Ad

Advertisements

W

Wes Baggerly

I found the answer on another string. It was posted by Vonid from Microsoft.
This problem seems to occur when you try to install Fax Services on a domain
controller. Here is what Vonid said:

[Beginning]
Fax Service runs under the account NETWORK SERVICE. In most cases on DC,
such issues happen when applying the domain policy changes the policies that
apply to NETWORK SERVICE. The following policies need to be enabled for
NETWORK SERVICE for fax to work.

(1) Adjust memory quotas for a process
(2) Generate security audits
(3) Log on as a service
(4) Replace a process level token
[End]

If your having this problem on a domain controller then this is were you can
find the settings:
(Start | All programs | Admistrative Tools | Domain Controller Security
Policy)
In the left pane, choose Local Policies then User Rights Assignment. You
will then see the setting on the right.

If your having this problem on a local machine then this is were you can
find the settings:
(Start | All programs | Admistrative Tools | Local Security Policy)
In the left pane, choose Local Policies then User Rights Assignment. You
will then see the setting on the right.

I hope this helps everyone. The more we get this answer out there the easier
it will be for others to find it.

Wes
 
W

Wes Baggerly

I found the answer on another string. It was posted by Vonid from Microsoft.
This problem seems to occur when you try to install Fax Services on a domain
controller. Here is what Vonid said:

[Beginning]
Fax Service runs under the account NETWORK SERVICE. In most cases on DC,
such issues happen when applying the domain policy changes the policies that
apply to NETWORK SERVICE. The following policies need to be enabled for
NETWORK SERVICE for fax to work.

(1) Adjust memory quotas for a process
(2) Generate security audits
(3) Log on as a service
(4) Replace a process level token
[End]

If your having this problem on a domain controller then this is were you can
find the settings:
(Start | All programs | Admistrative Tools | Domain Controller Security
Policy)
In the left pane, choose Local Policies then User Rights Assignment. You
will then see the setting on the right.

If your having this problem on a local machine then this is were you can
find the settings:
(Start | All programs | Admistrative Tools | Local Security Policy)
In the left pane, choose Local Policies then User Rights Assignment. You
will then see the setting on the right.

I hope this helps everyone. The more we get this answer out there the easier
it will be for others to find it.

Wes
 
W

Wes Baggerly

I found the answer on another string. It was posted by Vonid from Microsoft.
This problem seems to occur when you try to install Fax Services on a domain
controller. Here is what Vonid said:

[Beginning]
Fax Service runs under the account NETWORK SERVICE. In most cases on DC,
such issues happen when applying the domain policy changes the policies that
apply to NETWORK SERVICE. The following policies need to be enabled for
NETWORK SERVICE for fax to work.

(1) Adjust memory quotas for a process
(2) Generate security audits
(3) Log on as a service
(4) Replace a process level token
[End]

If your having this problem on a domain controller then this is were you can
find the settings:
(Start | All programs | Admistrative Tools | Domain Controller Security
Policy)
In the left pane, choose Local Policies then User Rights Assignment. You
will then see the setting on the right.

If your having this problem on a local machine then this is were you can
find the settings:
(Start | All programs | Admistrative Tools | Local Security Policy)
In the left pane, choose Local Policies then User Rights Assignment. You
will then see the setting on the right.

I hope this helps everyone. The more we get this answer out there the easier
it will be for others to find it.

Wes
 
W

Wes Baggerly

I forgot to say that I needed to reboot after I made the changes. After that
the Fax Service worked like it is suppose to.

Wes


Wes Baggerly said:
I found the answer on another string. It was posted by Vonid from Microsoft.
This problem seems to occur when you try to install Fax Services on a domain
controller. Here is what Vonid said:

[Beginning]
Fax Service runs under the account NETWORK SERVICE. In most cases on DC,
such issues happen when applying the domain policy changes the policies that
apply to NETWORK SERVICE. The following policies need to be enabled for
NETWORK SERVICE for fax to work.

(1) Adjust memory quotas for a process
(2) Generate security audits
(3) Log on as a service
(4) Replace a process level token
[End]

If your having this problem on a domain controller then this is were you can
find the settings:
(Start | All programs | Admistrative Tools | Domain Controller Security
Policy)
In the left pane, choose Local Policies then User Rights Assignment. You
will then see the setting on the right.

If your having this problem on a local machine then this is were you can
find the settings:
(Start | All programs | Admistrative Tools | Local Security Policy)
In the left pane, choose Local Policies then User Rights Assignment. You
will then see the setting on the right.

I hope this helps everyone. The more we get this answer out there the easier
it will be for others to find it.

Wes


Wes Baggerly said:
I just installed the Fax Service in Windows Server 2003 and I get the
following errors when I open the Fax Service Manager: "Could not open a
connection to the fax service. The fax service might not be started, or the
computer name might be incorrect."

Once I click OK the console will open but there are no devices. I then try
to open the properties I get "Access denied".

A shared fax does show up in the Printers and Faxes. But when I try to
access those properties I get this message: "You do not have permissions to
complete this operation. Contact the fax administrator for more
information." I click OK and the properties open.

I have always logged on as Administrator with all of the rights. I have also
tried to fix this by installing different modems and uninstalling and
reinstalling the software many times. I have seen one other post about this
but it was a reply to an original, but I did not find any post with an
answer. Does anyone have any suggestions on how I might fix this?

Thanks in advance.
 
S

Shawn P. Ryan

Wes,

I am having this problem on SBS2003, but do not have the Domain Controller
Security

Policy console, do you know how to get to it? I have the Local Security
Policy console, but it seems to be locked and I can not add any users or
groups to the items you mention, as the button is greyed out. Do you know
how to get around this?

Regards,

Shawn P. Ryan

Wes Baggerly said:
I found the answer on another string. It was posted by Vonid from Microsoft.
This problem seems to occur when you try to install Fax Services on a domain
controller. Here is what Vonid said:

[Beginning]
Fax Service runs under the account NETWORK SERVICE. In most cases on DC,
such issues happen when applying the domain policy changes the policies that
apply to NETWORK SERVICE. The following policies need to be enabled for
NETWORK SERVICE for fax to work.

(1) Adjust memory quotas for a process
(2) Generate security audits
(3) Log on as a service
(4) Replace a process level token
[End]

If your having this problem on a domain controller then this is were you can
find the settings:
(Start | All programs | Admistrative Tools | Domain Controller Security
Policy)
In the left pane, choose Local Policies then User Rights Assignment. You
will then see the setting on the right.

If your having this problem on a local machine then this is were you can
find the settings:
(Start | All programs | Admistrative Tools | Local Security Policy)
In the left pane, choose Local Policies then User Rights Assignment. You
will then see the setting on the right.

I hope this helps everyone. The more we get this answer out there the easier
it will be for others to find it.

Wes


Wes Baggerly said:
I just installed the Fax Service in Windows Server 2003 and I get the
following errors when I open the Fax Service Manager: "Could not open a
connection to the fax service. The fax service might not be started, or the
computer name might be incorrect."

Once I click OK the console will open but there are no devices. I then try
to open the properties I get "Access denied".

A shared fax does show up in the Printers and Faxes. But when I try to
access those properties I get this message: "You do not have permissions to
complete this operation. Contact the fax administrator for more
information." I click OK and the properties open.

I have always logged on as Administrator with all of the rights. I have also
tried to fix this by installing different modems and uninstalling and
reinstalling the software many times. I have seen one other post about this
but it was a reply to an original, but I did not find any post with an
answer. Does anyone have any suggestions on how I might fix this?

Thanks in advance.
 
Ad

Advertisements

Joined
Apr 4, 2008
Messages
4
Reaction score
1
Fix for w2k3 fax server

I have found a solution...

This server was not on a domain, but I kept getting the same errors you described.

this is what I did to resolve the problem.

start>administrative tools>Local Security Policy

look for the entry marked "Audit: Audit the access of global system objects" and change it to enabled, by right clicking that entry and selecting properties. Then select "Enabled" and apply followed by ok.

Restart the system, and it should work.

Hope this helps...

Neo...
 
Ad

Advertisements

Joined
Apr 4, 2008
Messages
4
Reaction score
1
Neo

A couple of other things I have noted, is that its easiest to configure this server if not added to your domain. Domains will overwrite the security settings and make it difficult to configure the Fax Manager. And make sure that RPC is enabled. Even though the fax component is local, windows treats it as a networked service.

Hope this helps all

Neo...
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top