FAILED upgrade to dynamic disk?

  • Thread starter magnus.timmerby
  • Start date

M

magnus.timmerby

Folks,

I have done these things a number of times but have never seen this
error before. Is the LDM database corrupt? Any suggestions are welcome!

Production machine, Windows 2000 SP4, hardware RAID array (LSI7202 dual
fiber channel board, directly connected, point-to-point).

The first fact is that everything worked just fine. Then I did a
planned restripe/repartitioning of the RAID (with the Windows host
powered down). I exposed two LUNs to Windows, one for each fiber
channel port.

Two scary things happened. First thing is:

After booting up the Windows host, Windows Disk Mgr recognised the two
new disks just fine, *but* also showed a duplicate of one of them, with
the same disk number, i.e. "Disk 1" appeared twice! KB 821393 mentions
a hotfix for this, available from Microsoft only on request. However,
the problem went away after rebooting twice!

Then scary thing #2 happens:

All seemed fine now, but when I try to upgrade one or both disks to
dynamic disks, Windows Disk Mgr just says "The operation could not
complete. Further information about this problem can be found in the
Event Log." But there is nothing at all in the event log!

Tried several times: I have tried to remove the LUNs on the RAID
(always with the Windows host powered down) and expose them anew,
Windows sees that they go away and come back, but same problem again:
Disk Mgr refuses to upgrade to dynamic disk.

Any hints are welcome!

Further details:

The system boot partition (where Windows is installed) is not on the
RAID, so we can rule that out. This RAID is only for data.

The RAID's block size is 512 bytes and the disks are freshly formatted
so they should have empty space for the LDM data. (These are LDM
requirements I know of.)

Magnus Timmerby
 
Ad

Advertisements

M

magnus timmerby

Problem solved: I did diskpart "clean" on both disks, then "rescan".
All seems fine now. Successfully converted to dynamic disks, now up and
running.

Out of curiousity I also did a rescan from Disk Mgr after this, it
showed a duplicate again! The duplicate disappeared after a reboot
though, looks correct now. From now on I will trust diskpart rather
than Disk Mgr.

Maybe this can help someone else.

Magnus
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top