Excel 2003 sticks to the low macro security level


D

Dima

Hello!
Excel 2003 sp2 and sp3 do not remember the macro security level. Excel
returns the level to low after any change of the level.
How to prevent a macro to run when Excel 2003 sp2 and sp3 open a file with a
macro?
Best regards
Dima
 
Ad

Advertisements

D

Dave Peterson

That's one of the settings that's stored in the windows registry.

If it's not sticking, maybe you don't have permission to update the registry?

Time to talk to the IT folks?????

If you're opening the file manually, you can old the shift (left shift???) key
down while you open the workbook.

This won't stop macros in general, but it will stop the auto_open and
workbook_open procedures from running.
 
D

Dima

Thanks Dave for replying!
I talked to the system and domain administrators. They blame microsoft, do
not know how to repair.
I've found the http://support.microsoft.com/kb/910817/en-us
Should I delete the
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\11.0\Excel\Security to repair?
I have the administrator rights on my Windows XP.
Sincerely.
 
D

Dave Peterson

If you found that branch in the registry, I wouldn't delete it.

I'd just change it what I wanted:

HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Excel\Security

This is for Excel 2003. Should be something similar for other versions.

The item is "Level".
1 = low, 2 = medium, 3 = high.

======
ps. I'm not a IT expert, but it sure sounds more like a problem with the
permissions than excel/Microsoft.
 
D

Dima

Thanks Dave for suggestion!
This allows to set another than the low level, doesn't it? How to make Excel
remember a setting in its user interface?
Sincerely.
 
D

Dave Peterson

The problem is that you should be able to make that change through the user
interface and excel should remember it. It's quite unusual that you can't do
this.

I _think_ that in all the posts that describe this problem, it usually comes
down to a permissions setting that the IT staff put on the users. That's why I
think it's not excel's problem, it's you're IT staff's problem.

Thanks Dave for suggestion!
This allows to set another than the low level, doesn't it? How to make Excel
remember a setting in its user interface?
Sincerely.
 
Ad

Advertisements

D

Dima

Thanks Dave for replying!
Our IT staff says that they did not put any LOCAL restrictions on me. I have
full LOCAL administrator rights.
Sincerely.
 
D

Dave Peterson

I don't have another guess.

Good luck. If you find the solution, please post back so that google has it.
Thanks Dave for replying!
Our IT staff says that they did not put any LOCAL restrictions on me. I have
full LOCAL administrator rights.
Sincerely.
 
J

Jim Rech

Dave-

This may not be it for the OP but if the "Level" entry exists under HKLM:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\11.0\Excel\Security

Then it is sticky. It allows you to change it for the current session but
the HKLM setting remains the default. I have no idea how the HKLM gets set
initially though.
 
D

Dave Peterson

I hope the OP is still hanging around.

I remember other posts that describe the same stickyness problem with the "trust
access to Visual Basic project" (IIRC).

Here's hoping that this fixes it.





Jim said:
Dave-

This may not be it for the OP but if the "Level" entry exists under HKLM:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\11.0\Excel\Security

Then it is sticky. It allows you to change it for the current session but
the HKLM setting remains the default. I have no idea how the HKLM gets set
initially though.
 
Ad

Advertisements

D

Dima

Thanks Jim for replying!
Should I delete the "Level" entry under
HKLM\SOFTWARE\Microsoft\Office\11.0\Excel\Security ?
How is OP interpreted?
Sincerely.
 
D

Dave Peterson

OP = Original Poster.

For me, I don't have this key.

You may want to rename it (SecurityX, maybe). Then test it out.

If that fixes the problem, I'd delete the key.


Thanks Jim for replying!
Should I delete the "Level" entry under
HKLM\SOFTWARE\Microsoft\Office\11.0\Excel\Security ?
How is OP interpreted?
Sincerely.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top