Unable to set low macro security level excel 2003

  • Thread starter Marco Margaritelli
  • Start date

M

Marco Margaritelli

I have a brand new computer (XP SP3), new MS Office Pro 2003 installation.
Up to date with all MS patches...
Since I installed Windows Live One Care, the Macro Security Level was set to
HIGH and every time I open a file containing some simple macros (that I
wrote), I receive the message advising that macro were disabled because the
HIGH security setting and advising to reset the security level to Medium or
Low.

I then go to TOOLS>MACRO>SECURITY and set the to Medium or Low, I close
Excel and the re-open and everything it's fine: the same workshet that
previously was blocked, is now allowed and the macros are working fine, BUT
the next day (even withouth reboothing the system), I get the sam problem and
the Security Leve was "misteriously" reset to High.

My guess is that Windows Live One Care overnight while performing its
"security and cleanup" duties, also reset the security level.

This is annoying, as it is happening also in another older computer where I
recently also installed the Windows Live One Care.

I NEED a solution that will enagle Office 2003 to KEEP the Macro Security
Setting Level that I select, once for all...
Any suggestion?

THANK YOU
 
Ad

Advertisements

M

Marco Margaritelli

Jan:

Thank you for the link... Yes it helped me, I solved the problem in my PC
with XP Pro (SP3).

Now I have the same probelm/issue on another PC running XP Home Edition with
Office 2002
I was not able to find instructions on HOW to CREATE a digital Certificate
for self signing on Office 2002.
WHen I go to All Programs>MS Office > MS Office Tools, I do NOT find the
"Digital Certificate for VBA" option.

Do you know on how to do it in Office 2002?

THANKS!
 
Ad

Advertisements

J

jbwhite99

My company locked down this field, and you have to make a registry
change - I was able to hack my system to allow the Security level to
low. Again, you may get in trouble with your IT group for this one,
bht this should do what you want...

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\11.0\Excel\Security]
"Level"=dword:00000001
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top