DVI Problems with ATI AIW 9800 Pro


A

Andrew MacLean

Hello all,

I can't remember if I posted to this group or not, so here goes (again,
maybe)...

PC: Dell Dimension 8100
CPU: Intel 1800
Memory: 768MB
OS: Windows XP Pro
Video: ATI AIW 9800 Pro
Drivers: CAT 3.10 (clean install)

I recently purchased a BenQ FP791 LCD Monitor. Originally, I was using an
old nVidia GeForce3, which allowed me to connect to the monitor via DVI.
The image was great, and life was good. The problem is that after using it
for about 2 weeks, my nVidia self destructed. I used this as a perfect
excuse to run out and buy a much more current card, choosing the AIW for
it's video and PVR features, over the nVidia FX5950.
Here's where the problems began. I plugged the BenQ into the DVI and lose
the signal to the monitor as soon as the Windows drivers load. What this
means is that I can see the CMOS boot, and the WindowsXP loading screen, but
as soon as the screen which would be prompting me for my password is
supposed to load, I get nothing. I know the computer is booting, as I see
continued disk activity, and if I get fancy, the TV can show the display,
just not the monitor on the DVI connection.
Using the TV as another display, I notice that the displays tab in the
properties pages show that the monitor is not connected in the DVI section.
As soon as I remove the DVI cable and attach the VGA cable through the
DVI-VGA adapter, the monitor pops on and everything works. This appears to
be a problem purely with the DVI.

Any ideas? Has anyone else had problems connecting their ATI to an LCD
monitor with the DVI connector? Any help is appreciated.

Andrew MacLean
 
Ad

Advertisements

T

Tim Mostad

I have my 9800 Pro connected to a Planar 20 inch LCD monitor with DVI and
it works pretty good most of the time. Sometimes after rebooting the monitor
goes to sleep mode but if I cycle the monitor power it turns on fine. It is
a minor annoyance and it is not clear whether it is the card's or the
monitor's fault.
 
P

peter

9600 pro using the 3.10 drivers caused this with my NEC 1760NX
so I switched over to the Radeon Omega drivers and all was well
Haven't had that problem since
peter
 
Ad

Advertisements

A

Andrew MacLean

Hello all,

Peter, I wasn't sure if your reply was meant for my problem, or Tim's.
Anyway, I tried some new things to see if I could solve the problem.

1. I uninstalled all ATI drivers (CAT 3.10). Using just the default
Microsoft VGA drivers, I could in fact use the DVI. Everything is fine,
right through the boot process and the logon. Of course, performance sucks,
but at least it worked.

2. I tried the Omega drivers, based on CAT 3.10. Again, as soon as the
logon screen was to appear, No Signal! So, same problem as before.

It appears that this is a serious bug with the ATI drivers. I don't
really want to kick back several versions if I can avoid it. That seems to
defeat the purpose. So, has anyone else had this problem? Did you solve it
with a specific driver revision from ATI? Has anyone reported similar
problems to ATI. I have searched the web and their support pages, but found
only complaints, and no forthcoming solutions.

Again, the help is appreciated.

Andrew MacLean
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top