Disable "expand" for folders in Start Menu


J

Jon Danniken

I am working on an XPsp3 MCE computer, and trying to add a shortcut to a
few networked folders into the start menu.

The problem is that adding a shortcut to those folders ends up being an
expanding entry, which is undesirable for these folders (media folders with
many entries).

Is there any way to disable this behavior, and have the shortcuts not have
the expanding property, but instead open up in a Windows Explorer menu like
they should?

Thanks,

Jon
 
Ad

Advertisements

P

Paul in Houston TX

Jon said:
I am working on an XPsp3 MCE computer, and trying to add a shortcut to a
few networked folders into the start menu.

The problem is that adding a shortcut to those folders ends up being an
expanding entry, which is undesirable for these folders (media folders with
many entries).

Is there any way to disable this behavior, and have the shortcuts not have
the expanding property, but instead open up in a Windows Explorer menu like
they should?

Thanks,

Jon

Instead of dragging a shortcut of the folder to the start menu,
how about using a shortcut to Explorer.exe which points to
the folder like this:
C:\WINDOWS\explorer.exe /n,/e,H:\ThisFolder
You will have to add the \\ if its on a network server.
 
J

Jon Danniken

Paul said:
Instead of dragging a shortcut of the folder to the start menu,
how about using a shortcut to Explorer.exe which points to
the folder like this:
C:\WINDOWS\explorer.exe /n,/e,H:\ThisFolder
You will have to add the \\ if its on a network server.

That works perfectly, thanks Paul.

Jon
 
Ad

Advertisements

E

Etal

Jon said:
I am working on an XPsp3 MCE computer, and trying to add a shortcut
to a few networked folders into the start menu.

The problem is that adding a shortcut to those folders ends up being
an expanding entry, which is undesirable for these folders (media
folders with many entries).

Is there any way to disable this behavior, and have the shortcuts not
have the expanding property, but instead open up in a Windows
Explorer menu like they should?

Am i right when assuming that you try to add the shortcuts by creating
them by using Drag-n-Drop?

(Below i write target as being a local folder. It is the same also for
Volumes, Networked Volumes and Networked Folders.)

Yes, in the name of inconsistency (i guess it must be), it has been
decided that when you by 'Drag-n-Drop'-create a shortcut to a
folder-location - that they will be created differently if you do it to
the 'Start Menu' or any subfolder therefrom then if you do it to
anywhere else in your volume-hierarchy.

The same will happen if you explicitly open the
"%UserProfile%\Start Menu\" (also the "%AllUsersProfile%\Start Menu\")
folder and 'drag-n-drop'-create a shortcut into these open Windows
Explorer windows.

Workaround #1) With this window (or any subfolder-window) open you can
create normal shortcuts to folder-targets by explicitly invoking the
primitive 'Create Shortcut'-wizard (File : New : Shortcut).

Workaround #2) 'Drag-n-Drop'-create the shortcut anywhere else (e.g.
onto the desktop) and then drag(move) the created shortcut-file to where
you want it in the 'Start Menu' hierarchy. It will remain a normal
Windows Explorer shortcut file.

Workaround #3) The workaround that PauliHTx proposed in the other
response, by creating a shortcut pointing to the target only indirectly.
But like with workaround #1, this you can't do by drag-n-dropping.


The strange /expandable/ Start Menu /shortcuts/ are actually not
shortcut-files but folders, but of type 'Folder' (like the 'Recycled'
folder), not type 'File Folder' like normal folders.
These strange folders will hold two files; One, a normal shortcut-file
always named [Target.lnk], with the path to your target-folder. Two, a
[Desktop.ini] file containing a GUID that makes the parent-folder, shall
we say, misbehave:

<content>
[.ShellClassInfo]
CLSID2={0AFACED1-E828-11D1-9187-B532F1E9575D}
Flags=2
</content>

The GUID {0AFACED1-E828-11D1-9187-B532F1E9575D} is described as 'Folder
Shortcut' in the registry.


Can one turn the behavior off? I don't know. I use the second workaround
listed as that is quick, with no copy-paste or typing of paths necessary
like the other two workarounds.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top