Direct X D3d ATI Radeon 9600 issue


Ron Lynne


Hope someone here can assist, ATI can't find a solution
and Miscrosoft wants $100. I recently installed a new MB
an Intel 865 Perl. Now my ATI Radeon 9600 won't run 3d
programs. I have DX9.0b. I am using the latest Catalyst
4.20 drivers. I've updated the AGP driver, and tried
several fixes from AT all to no avail. When I try to run
DXDiag I get the following error message (or any 3d app)

<<The procedure entry point DdEntry1 could not be located
in the dynamic link library GDI32.dll>>

The most recent fix they suggested was to replace
d3d8thk.dll with d3d8thk.w2k (after renaming *w2k to dll)
but I don't see that file on my system. I'm way past the
point of being iorritated, as the Video was working before
I put in this (much better) MB. Any thoughts??? respond to
rondx 'at' ronlynne dott comm


Bob I

Try using some older drivers, say the 3.8 Catalyst. Sometimes in their
rush to make the newer cards go faster the drivers break the older cards.


I ran into this after doing an Upgrade-In-Place when I moved my Win2K system disk to a new box with a better faster motherboard. After Googling DdEntry1, I found lots of people with the problem, but no solutions. Finally found folks recommending the D3D8THK.DLL replacement. I will be trying that tonight. Here is where you can find the file

Any Win2K system successfully running Dx9.0b. Note that the good DLL is 7K, the wrong DLL is 8K

The file which is unzipped out of the DirectX 9.0b update .exe

Wish me luck.


P.S. Any comments from Microsoft folks about this problem?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question