DHCP Help, can't get new reservation


G

Guest

Setup:
I run a 200 person office using active directory on a Windows 2000 SP4
machine. (also does DNS and Print serving)
We have DHCP in use with all machines using reserved addresses. Updated the
machine with the latest updates about 2 weeks ago.

Problem:
When I try to add a new reservation, I get this error message:

An error occurred while accessing the DHCP database. Look at the DHCP server
event log for more information

Symptoms:
- I can release and renew an existing lease
- Status shows that I do have leases available
- No error messages show up in the event logs that correspond to this problem
- Antivirus does not scan this directory, indexing is not turned on
- I have about 19 addresses left

What I have tried:
- Searched Technet, Google for these symptoms. Lots of descriptions were
close, but none identical.
- Tried DHCP shutdown, move database, backup registry, restart DHCP, restore
registry, reconcile. - Didn't work
- Tried rebooting :)

Any suggestions?

Walter
 
Ad

Advertisements

G

Guest

Sorry folks, found the solution myself. The MAC address I was trying to
reserve was already in the database. It was for a printer which didn't print
it's IP address in the configuration page because it was using DHCP. - No
help there- There were no errors or warnings that the MAC address was in use.
There was nothing but misdirection. I had to search through a dump of the
DHCP database to find it. BTW, to dump the database, run this on the server.

netsh dhcp dump

Walter
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top