Desktop Icons insist on auto-arranging


S

Susan Rice

I installed a new video card and suddenly my desktop icons insist on
auto arranging themselves whenever I right-click on the desktop and
select 'Refresh'. Even though I have 'Auto Arrange' unchecked in that
right-click menu under 'Arrange Icons By". How can I stop it from doing
this?

I tried uninstalling all the software that came with the video card. I
can't use system restore as the software used up 200MB and my earlier
restore points have been erased due to space, even though I have System
Restore set to use the maximum allowed disk space.

So now whenever the system desides to refresh the desktop, it
auto-arranges the icons. I want them to stay put where I choose them to
be. And like I said I have 'Auto Arrange' unchecked.
 
Ad

Advertisements

E

Elmo

Susan said:
I installed a new video card and suddenly my desktop icons insist on
auto arranging themselves whenever I right-click on the desktop and
select 'Refresh'. Even though I have 'Auto Arrange' unchecked in that
right-click menu under 'Arrange Icons By". How can I stop it from doing
this?

I tried uninstalling all the software that came with the video card. I
can't use system restore as the software used up 200MB and my earlier
restore points have been erased due to space, even though I have System
Restore set to use the maximum allowed disk space.

So now whenever the system desides to refresh the desktop, it
auto-arranges the icons. I want them to stay put where I choose them to
be. And like I said I have 'Auto Arrange' unchecked.

Go to http://www.kellys-korner-xp.com/xp_abc.htm and click "I". Scroll
down to "Icons - Lock on Desktop" and the other helpful sections.
 
W

Wesley Vogel

If Lock Web Items on Desktop is checked...
Items can be moved, but they are moved back after reboot.

If Auto Arrange is checked...
The icons are arranged in columns along the left side of your screen.

Right click Desktop | Arrange Icons By |
UNCheck: Auto Arrange
UNCheck: Lock Web Items on Desktop

Auto Arrange
[[Arrange the icons in columns along the left side of your screen.]]

Lock Web Items on Desktop
[[Specifies whether Web content windows or items that *you* have placed on
your desktop are locked in place and can’t be moved. Select the check box to
lock Web content in place. Clear the check box if you want to be able to
move Web content.]]

Do you happen to have a program called Anti-Peeper Key?
http://www.ahusoft.com/antipeeperkey.htm

<quote>
You press 2 keys and it will switch you to a completely different desktop. I
had no idea that this might create a problem, but evidently, when you are
running this program (even if it is not active, but loaded and ready to use
when you push the 2 keys to switch desktops) the "align to grid" setting on
the alternate desktop must be unchecked also. I unchecked "align to grid and
when I rebooted, icons popped right into the spaces they were supposed to.
<quote>
from...
http://help.lockergnome.com/windows/Desktop-Icons-Staying-put-ftopict539528.html

If either of these keys loses ownership..
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags\1
or
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags\1\Desktop
The desktop can rearrange itself.
http://groups.google.com/group/micr...ey+author:vogel&rnum=3&hl=en#568149f030edddf5

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In
 
W

Wesley Vogel

Screwed up video drivers can also cause this.

http://groups.google.com/group/micr...ey+author:vogel&rnum=2&hl=en#568149f030edddf5

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In
Susan Rice said:
I do not have Anti-Peeper key.
Both "Auto Arrange" and "Lock Web Items on Desktop" are unchecked.

But it's acting like Auto Arrange is checked, even though it's not.

Never had this problem until I installed the new video card.
I uninstalled all the video software, but it still does it.


Wesley said:
If Lock Web Items on Desktop is checked...
Items can be moved, but they are moved back after reboot.

If Auto Arrange is checked...
The icons are arranged in columns along the left side of your screen.

Right click Desktop | Arrange Icons By |
UNCheck: Auto Arrange
UNCheck: Lock Web Items on Desktop

Auto Arrange
[[Arrange the icons in columns along the left side of your screen.]]

Lock Web Items on Desktop
[[Specifies whether Web content windows or items that *you* have placed
on your desktop are locked in place and can’t be moved. Select the check
box to
lock Web content in place. Clear the check box if you want to be able to
move Web content.]]

Do you happen to have a program called Anti-Peeper Key?
http://www.ahusoft.com/antipeeperkey.htm

<quote>
You press 2 keys and it will switch you to a completely different
desktop. I
had no idea that this might create a problem, but evidently, when you are
running this program (even if it is not active, but loaded and ready to
use when you push the 2 keys to switch desktops) the "align to grid"
setting on the alternate desktop must be unchecked also. I unchecked
"align to grid and
when I rebooted, icons popped right into the spaces they were supposed
to. <quote>
from...
http://help.lockergnome.com/windows/Desktop-Icons-Staying-put-ftopict539528.html


If either of these keys loses ownership..
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags\1
or
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags\1\Desktop
The desktop can rearrange itself.
http://groups.google.com/group/micr...ey+author:vogel&rnum=3&hl=en#568149f030edddf5
 
S

Susan Rice

I do not have Anti-Peeper key.
Both "Auto Arrange" and "Lock Web Items on Desktop" are unchecked.

But it's acting like Auto Arrange is checked, even though it's not.

Never had this problem until I installed the new video card.
I uninstalled all the video software, but it still does it.
 
Ad

Advertisements

S

Susan Rice

Apparently that info is a bit out of date. I can't download the
Layout.dll from it's link. Layout.dll apparently just saves and
restores the desktop layout. I already have WinTidy to do that
for me.

It just keeps auto-arranging even though auto-arrange is unchecked.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top