Desire to Open TXT File With Excel, File Association Not Working


G

Guest

I have tried to associate TXT files with Excel, it's not working. Steps to
date:
1. Open Windows Explorer
2. Right click a .TXT file
3. Click "Open With"
4. Click "Choose Program"
5. Click Browse
6. Click to EXCEL.EXE path, which is C:\Program Files\Microsoft
Office\Office11\
7. Click on EXCEL.EXE
8. Click on checkbox to mark, Always Use The Selected Program...
9. Click OK.

The system continues to open the TXT file with Notepad. If I right-click
the file in Windows Explorer, then click Open With, it does NOT, after doing
the above, even SHOW Excel as an option.

I have tried the DOS command, ASSOC=.TXT= (space)
to delete the association of a TXT file to notepad, but that will not work.
Help! Thanks.

Rick
 
Ad

Advertisements

J

JockoBailey

Rick Hamilton said:
I have tried to associate TXT files with Excel, it's not working. Steps to
date:
1. Open Windows Explorer
2. Right click a .TXT file
3. Click "Open With"
4. Click "Choose Program"
5. Click Browse
6. Click to EXCEL.EXE path, which is C:\Program Files\Microsoft
Office\Office11\
7. Click on EXCEL.EXE
8. Click on checkbox to mark, Always Use The Selected Program...
9. Click OK.

The system continues to open the TXT file with Notepad. If I right-click
the file in Windows Explorer, then click Open With, it does NOT, after doing
the above, even SHOW Excel as an option.

I have tried the DOS command, ASSOC=.TXT= (space)
to delete the association of a TXT file to notepad, but that will not work.
Help! Thanks.

Rick
Add or change to Excel.exe in this key

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExt
s\.txt\OpenWithList
 
G

Guest

EXCEL.EXE is already in the list. Name=b, Type=REG_SZ, DATA=EXCEL.EXE

NOTEPAD.EXE is the first value. Any other suggestions? Thanks!

Rick
 
G

Ghostrider

Rick said:
EXCEL.EXE is already in the list. Name=b, Type=REG_SZ, DATA=EXCEL.EXE

NOTEPAD.EXE is the first value. Any other suggestions? Thanks!

Rick

"JockoBailey" wrote:

This question might have been better addressed and answered in a MS
Office or Excel newsgroup instead of here. AFAIK, the default app for
opening *.txt files is Notepad. Notwithstanding this statement, *.txt
files can be opened from within Excel itself. However, it goes into a
parsing box to separate the text fields and text. This is simply the
generic programming for most spreadsheet programs...they are not (and
were not) designed to handle an entire *.txt file within a single cell.
Instead, spreadsheet applications can (and will) search for delimiters
that puts text into their proper columns, rows and cells.
 
G

Guest

Dear G,

I know exactly how Excel handles TXT files, I push tab-delimited text files
into Excel every day, and they parse perfectly, so this is NOT an Excel
question. It's a Windows question, because I cannot get EXCEL to be listed
in the list of programs which XP presents. when you right-click the file and
choose open with. It's an XP bug, IMHO. Suggestions?

r.
 
B

Bob I

Just R-click txt file and pick Open With, Choose Program, Browse, get
Excel.exe and pop the Always use box. test it. Now go back to Open with
and change the Always open with back to Notepad if you want, but the
Excel will stay.
 
Ad

Advertisements

G

Guest

Bob,

I HAVE tried to associate TXT files with Excel, it's not working. Steps to
date:
1. Open Windows Explorer
2. Right click a .TXT file
3. Click "Open With"
4. Click "Choose Program"
5. Click Browse
6. Click to EXCEL.EXE path, which is C:\Program Files\Microsoft
Office\Office11\
7. Click on EXCEL.EXE
8. Click on checkbox to mark, Always Use The Selected Program...
9. Click OK.

The system continues to open the TXT file with Notepad. If I right-click
the file in Windows Explorer, then click "Open With", it does NOT, after
doing
the above, even SHOW Excel as an option.

I have tried the DOS command, ASSOC=.TXT= (space)
to delete the association of a TXT file to notepad, but that will not work.
Help! Thanks.

r.
 
A

Ayush

Replied to [Rick Hamilton]s message :
I have tried to associate TXT files with Excel, it's not working. Steps to
date:


Control Panel > Folder Options
File types tab > Select .txt and click Advanced (or Restore first)
Select the default action and click Edit
Click Browse and select Excel.exe
Uncheck "Use DDE" > Click OK > OK > OK


if that doesn't work, then :

Click Start > Run > CMD > Run:
assoc .txt=txtfile

Then open regedit.exe
Navigate to: HKEY_CLASSES_ROOT\txtfile\shell\open
Right side, enter:
pathtoexcel.exe "%1"


z
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top