csv files


L

linto

I have created a macro to open a csv file and copy the contents to another
file.
When i run the macro in my system it opens the csv file and in this file all
the data are in seperate columns. but when i run this macro in another system
it opens the csv file but in this file the data are in single column
seperated by commas.

is there a settings difference in different computers that make then open
the csv files differently. how to change this setting in the macro so that
the csv file opens similarly in all systems like each data in different cells
rather than in in one cell seperated by commas
 
Ad

Advertisements

D

Dave Peterson

You could rename/copy the file to have an extension of .txt. Then your macro
would parse the data as comma separated. In fact, you'd have more control of
how each field is treated instead of just letting excel guess at each field.

I think the problem with the troublesome pc's is that their windows regional
setting is different from yours. They don't use a comma as a list
separator--maybe a semicolon (common in non-USA locations).
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top