Save as CSV not saving the same from Excel 2007 then in Excel 2003



If I take an Excel file and Save it as a CSV in Excel 2003 the blank rows
from the Excel file show up on the CSV as blank rows (no commas show in that

But when I save the same file in Excel 2007 (which we recently upgraded) the
blank rows from Excel show up as about 15 commas on the CSV file. There are
also other rows of data in the CSV file that have 5-10 extra commas appended
to the end.

Is there an option in Excel 2007 to save as CSV file but exclude blank rows?

Bernard Liengme

I can confirm that xl 2003 saves blank rows as blank rows while xl2007 saves
them with commas and seems to add a few rows at the end

In an experiment, I did a Data|Filter and deselected the blank rows, then
did Copy & Paste to new worksheet before saving a CSV. Empty rows are gone
as expected.

You could record a subroutine to do this
best wishes

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question