Crystal Report Deployment Problems




I am working on a program for the .NET Framework written in C# with Visual
Studio .NET. With this program, one can print a report realized with the
Crystal Report software included with VS .NET. This has all been working
fine until recently, when I had to install and run the program on more
computers. Then I suddenly start getting error messages like: 'Cannot find
KeycodeV2.dll, or invalid keycode'.

The .NET framework is, of course, installed on the target computers. All
parts of my program, except those using Crystal Reports, are running without

I have made a setup project for my program with VS .NET. The KeycodeV2.dll
is a part of the Crystal_Database_Access2003.msm merge module, which is
included in my setup project. I do find this file in the folder 'C:\Program
Files\Common Files\Crystal Decisions\1.0\bin'.

I have taken care to set the License Key property for the
Crystal_regwiz2003.msm merge module. I have taken the key value from the
About Microsoft Visual Studio .NET dialog box from the Help menu. Could my
trouble be connected with this?

There is something else I don't understand: my setup project includes the
crystal_managed2003.msm merge module. This module includes dlls which I
thought were absolutely necessary for Crystal Reports to work, like
CrystaDecisions.CrystalReports.Engine.dll. On my development machine these
files are in the folder 'C:\Program Files\Common Files\Crystal
Decisions\1.1\Managed'. I do not find this on the target machines. Why is

I hope, someone takes the time to read this long message. In any case, a
hint will be highly appreciated.

Gudni Sigurdsson


I found the solution to this problem myself and describe it here, in case it
will help someone in a similar situation.
When I started using Crystal Reports bundled with VS.NET 2003 a few months
ago, I found that I had to register CR in order to be able to build my
project(s). So I did, and got back an email with a 10-digit Registration
number and a 19 character alphanumeric Product code. I entered the
Registration number into the License Key property of the crystal_regwiz2003
merge module and everything seemed to work. Until recently, that is.
Yesterday, I went to the Business Objects website and downloaded the
document 'Crystal Reports and Visual Studio.NET - Application Deployment'.
There, I saw that I should have used the Product code instead of the
Registration number. After I changed that, everything worked fine.
In retrospect, I do not really understand why this ever worked while I was
using the Registration number for the License Key.
Hope somebody can benefit from this experience is of mine.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question