Copying a 6 GB file onto a 16 GB empty USB memory stick causes a "disk full" message ?


R

R.Wieser

Hello All,

I just tried to copy a 6.2 GB file onto a 16GB usb memory stick, and got an
"disk full" message. Could someone tell me what the problem is / how to
solve it ?

XPsp3

Regards,
Rudy Wieser
 
Ad

Advertisements

R

R.Wieser

Helo David,
How is the 16GB Flash Drive formatted ?
The format is Fat32. It does return the correct free space, both in
"windows explorer" as to a DIR command.

Regards
Rudy Wieser


-- Origional message:
 
R

R.Wieser

Geo,
Could it be a counterfeit flash drive?
Everything is possible., I'll have to check it.

But I think David asked the right question, it just didn't register with me
until a bit later : FAT32 has a file-size limit of 4 GByte (thanks David H.
Lipman :) .

Regards,
Rudy Wieser


-- Origional message:
 
V

VanguardLH

R.Wieser said:
The format is Fat32. It does return the correct free space, both in
"windows explorer" as to a DIR command.
You have run into a maximum file size supported by a particular file
system.

The maximum file size in FAT32 is 4,294,967,295 bytes (4 GiB - 1). You
will have to slice up the file into multiple parts to continue using
FAT32 or convert the USB drive to NTFS.
 
R

R.Wieser

Ant,
That limitation says disk full error? Weird.
Yeah, that was what threw me off too. :-\

Not the first time I've been caught by MSes vague or even (as in this case)
downright wrong error messages though.

Regards,
Rudy Wieser


-- Origional message
 
R

R.Wieser

VanguardLH, Zilbandy,
...or convert the USB drive to NTFS.
Well, thats easy (or so I thought): Just reformat the stick (it was empty).

Well, not *that* easy: while the format selection was easy enough to find in
the context menu it didn't give me an NTFS option (wtf?) ....

It turns out you first you have to right-click the drive -> "properties" ->
tab "hardware" (yeah, Hardware!) -> select the USB stick (again) ->
"properties" (again) -> "Policies" and than select "optimize performance"
(aka: enable caching) before the formatting-option NTFS will be available
for the stick (not that they mention that there).

You thought that that was all ? No sirree -- If you try to format the drive
thru the "disk management" console (under settings -> administrative tools)
you stil won't get the NTFS option (huh?!). That one only pops up when you
right-click the drive in "file explorer" and than select format. Go figure.

Yeah, lost a bit of time because of that non-integration (selecting NTFS as
the format? Popup a message that caching will be enabled too) and
inconsistant behaviour (two non-matching "format a drive" windows). :-(

Regards,
Rudy Wieser
 
P

philo 

Hello All,

I just tried to copy a 6.2 GB file onto a 16GB usb memory stick, and got an
"disk full" message. Could someone tell me what the problem is / how to
solve it ?

XPsp3

Regards,
Rudy Wieser

You were given the correct advice to convert the drive to NTFS or
reformat to NTFS


an alternative would be to use exFat


http://en.wikipedia.org/wiki/ExFAT
 
Ad

Advertisements

R

R.Wieser

Hello David,
Excellent. I figured you knew the reason but just didn't see a
connection.

Its one of those bits of info I've got, but just do not encounter too often
to have it readily in the front of my mind. :-|

I could also blame a late friday evening (having a few pints) having to do
something with my slowness. :)

Got a bit side-tracked by the not all to apropriate "disk full" message too.
:-\

Regards,
Rudy Wieser


- Origional message:
 
V

VanguardLH

R.Wieser wrote:
(after fixing the quoting indentation)
The format is Fat32. It does return the correct free space, both in
"windows explorer" as to a DIR command.


Well, not *that* easy: while the format selection was easy enough to
find in the context menu it didn't give me an NTFS option (wtf?) ....
It turns out you first you have to right-click the drive ->
"properties" -> tab "hardware" (yeah, Hardware!) -> select the USB
stick (again) -> "properties" (again) -> "Policies" and than select
"optimize performance" (aka: enable caching) before the
formatting-option NTFS will be available for the stick (not that they
mention that there).

You thought that that was all ? No sirree -- If you try to format the
drive thru the "disk management" console (under settings ->
administrative tools) you stil won't get the NTFS option (huh?!).
That one only pops up when you right-click the drive in "file
explorer" and than select format. Go figure.
I/we just gave the hint, not the procedure. We wouldn't know your
expertise level and it's a waste of time to recite what someone might
already know, plus some folks take offense at you offering what they
consider simpleton advice as though you've insulted their intelligence.
If they come back and ask "how" is when more info can be provided but
this is not a chat room with instant feedback so it could be hours or
days before there are replies.

Sometimes a hint is all that is needed and the poster may not even come
back with an update after finding the solution so the respondents get no
feedback if their suggestions helped or not. There are a lot of
drive-by posts. Someone might tell you to run 'chkdsk' but figure you
knew 'chkdsk /?' to get its command-line arguments, you could look in
Windows help, or you could look it up online.

After getting a hint, and if you needed more info, you could your own
online search on, say, "format usb drive ntfs" to find:

http://www.ntfs.com/quest22.htm
http://www.ehow.com/how_6177473_format-usb-drives-ntfs.html
http://www.online-tech-tips.com/computer-tips/format-usb-ntfs/

As you see, I'm naturally verbose. Reading skills and attention spans
have waned, especially since the introduction of the Web, and many
Usenetizens get dazed or tune out when having to read more than a
hundred words. A reply like this one is beyond their communication
skills.

By the way, the Microsoft article provided by Zilbandy didn't work to
convert FAT32 to NTFS on a USB drive? I found several articles that
reinforce Zilbandy's suggestion. Or did you not even try it?
 
V

VanguardLH

David said:
By default...
* If a drive is less than 32GB then it is formatted using FAT32.
* If the drive is greater than 32GB then it is formatted using using NTFS.
USB drives come pre-formatted using FAT32 for the widest compatibility
under different operating systems. Since FAT32 partitions can be up to
2 to 16 TiB in size (depending on sector size), pretty much all USB
drives, so far, will come with FAT32 partitioning by default. There are
a couple USB drives that come pre-formatted with NTFS but that is not
the norm.
 
R

R.Wieser

Hello VanguardLH,
I/we just gave the hint, not the procedure.
What I wrote there was just to vent my own frustration about having wasted
time & energy at imagining what could have been wrong with my machine not
showing NTFS as a "format this storage" option, and why the method of
enabeling it is stuck so deep into the settings that you would not find it
other than by obtaining specific information to it (read: using google), as
well as warning other people running into the same problem (phew, a single
sentence spanning five lines).

It was not aimed at anyone here. To you and the others I'm just gratefull
for your help.
After getting a hint, and if you needed more info, you could your
own online search
:) I did ! But only *after* I realized that there was/is nothing wrong
with my OS and the problem must therefore lie somewhere else. And no, I
did not expect you guys to "just tell me everything", but I surely didn't
expect the OS to simply hide the NTFS option due to a (to me) more-or-less
unrelated option hidden 6 levels deep. Hence my frustration.
By the way, the Microsoft article provided by Zilbandy didn't
work to convert FAT32 to NTFS on a USB drive?
As the USB stick was empty I did not even consider using that method, as
just reformatting would than the most efficient.

Regards,
Rudy Wieser
 
V

VanguardLH

R.Wieser said:
VanguardLH,


What I wrote there was just to vent my own frustration ...
Okie dokie, that's pretty much what I figured. You thought it would be
straight forward but had to delve into an obtuse solution. I usually
bracket my undirected outburst by:

<rant>
vent here
</rant>

It's pseudo-HTML to indicate you are venting in that section. I picked
up on this after seeing others use this trick.
 
R

R.Wieser

VanguardLH,
You thought it would be straight forward but had to
delve into an obtuse solution.
The solution itself *is* straighforward: Just reformat the stick NTFS style.

That that option was silently(!!) blocked, only to be un-blocked by doing
something in the bottom of a locked filing cabinet stuck in a disused
lavatory with a sign on the door saying 'Beware of the Leopard' is what got
me frustrated (funny in the book, not so much on my computer).
I usually bracket my undirected outburst by: <snip>
Only after you responded to that I recognised that it could have been read
as a personal "you failed to inform me" attack. At the moment of writing I
was not aware of it, and it certainly wasn't my intention.

But yes, maybe adding a tag like that would not have been a bad idea. I'm
already accustomed to using smilies to indicate intent / take the sting off
of some stuff I say, so why not HTML tags too ? :)

Regards,
Rudy Wieser


-- Origional message:
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top